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CHAPTER  1

Introduction

CAD files come in dozens of different formats, and simply reading the file, not to mention
analyzing and modifying it, has formed a major hurdle for professionals as electronic design
automation has taken over their fields. CAMtastic! provides a single environment for viewing,
inspecting, and editing CAD files from any major source.

Although its extensive capabilities will appeal to advanced users with intricate needs, the
CAMtastic!® 2000 Designers’ Edition environment remains uncomplicated. The heavy tools are
available but concealed, keeping your experience with CAMtastic!® 2000 Designers’ Edition as
straightforward as your individual projects will allow.

For example, the details concerning DXF/DWG imports can be extremely complicated, but in
CAMtastic!® 2000 Designers’ Edition you can simply indicate what kind of project you’re viewing:
PCB, Chemical Milling, Fab Drawing, Silkscreen Panel, etc., and the software will wade through the
details automatically. This automatic detection, however, may be bypassed, allowing advanced
users to make adjustments according to their specific needs.

CAMtastic!® 2000 Designers’ Edition Features
This section highlights some of the powerful features available in CAMtastic!® 2000 Designers’
Edition.

• Comprehensive Import/Export Capability. CAMtastic!® 2000 Designers’ Edition will load and
auto-detect Gerber (RS274-D, RS274X, or Fire9000) formats, AutoCAD’s DXF/DWG files,
HPGL/HPGL2, Excellon Drill, Mill, or Rout files. Its DXF/DWG importer supports all AutoCAD
objects, including LWPolylines, 3d-Faces, M-Lines, Polyline Splines, Hatches and Mtext.
Additional formats are continually added to the program, available for free download from the
webpage.

• Powerful Aperture Control. Nearly a thousand Dcodes are available for aperture definitions,
and an aperture list is created each time a file is imported into CAMtastic! ® 2000 Designers’
Edition. Aperture files for standard and custom parts can be saved and reopened for reuse,
minimizing time spent defining commonly used apertures in the Dcode list. CAMtastic! ® 2000
Designers’ Edition supports filled polygons and voids, circular interpolation (true arcs),
composites, and transcoding.
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• Easy Access Workspace Bar. A panel may be continuously viewed in CAMtastic!® 2000
Designers’ Edition showing layers, query returns, DRC reports and Netlist information. It also
offers quick access to tables, program preferences and report generation, such as PCB
summaries for quotation purposes. This bar may be redocked on any side or left floating in the
workspace.

• Viewing and Inspection Tools. CAMtastic!® 2000 Designers’ Edition’s viewing tools go far
beyond zooming and panning through imported designs. With minimal input, CAMtastic!® 2000
Designers’ Edition can generate netlists and DRCs from Gerber data. Objects may be queried
individually or in groups, yielding Dcode, shape, size, type, length, location, and net
information. Measuring distances between points is made easier and more accurate with over
10 different snap grid methods to choose from. Layers may be compared for their differences,
and a translucent view option lets you see behind overlapping apertures.

• Drawing Tools. Any aperture may be flashed (placed singly) or used as the “pen” to draw lines,
polygons, text (including TrueType fonts), or arcs. Users may choose to have their arcs
displayed as segments with varying resolution, helping speed up screen redraws without losing
the true arc data in the file. Different methods of drawing are available depending on users’
needs and preferences, and snap grids can help place draws and flashes with precision.

• Editing Tools. Flashes may be modified; lines may be extended, broken, or joined; and corners
may be changed, chamfered or bevelled. Selections may be copied, erased, moved, mirrored,
scaled, or replaced by custom apertures. Layers may be renamed, copied, aligned, resized, or
deleted. Efficient selection tools allow you to detect specific targets for any edits you wish to
make.

• Advanced Tools. Wizards help you read custom aperture files, import special DXF/DWG files,
and panelize layers on film. Silkscreen and paste mask layers may be generated from signal
layers with spread and reduce functions. Identical groups of objects may be converted to
single flashes for compatibility with less robust programs. You can fill closed boundaries,
generate outlines the board, and create fabrication drawings. Teardrops may be added
between pads and traces, while isolated pads may be detected and removed. Composite layers
allow you to create non-standard shapes.

• Manufacturing Tools. Boards may be panelized, and loop codes may be embedded to avoid
inflating the file to an unmanageable size. Venting, Copper Pours, and Silkscreen Trimming are
available. Over ten strategies may be applied as you create mill or routing paths. The Tool
Table can hold up to 99 different drill bits for board manufacture, with fields for cutter
compensation, infeed rate, spindle speed, depth offset, plus any special comments you want to
make about any individual tool. Pad pairs may be converted to Homebase Pads for Stencil
Manufacturing, and Epoxy Bars may be added automatically.

• PCB Report. A board may be analyzed and data extracted for PCB sales quotations. A detailed
report may include the following information: Critical Dimensions (minimum trace width and
gap spacing), Overall PCB Dimensions (size, area, perimeter length and number of cutouts),
Surface Mount Pads (minimum pad and pitch, total number), and Drill information—even
detecting blind and buried vias. It can also calculate areas for gold body and immersion boards.
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Guide Overview
While this manual may be read straight through, it is designed mainly for reference.

• Chapter 2 guides you through the installation and setup of the software on your personal
computer, indicating system requirements and recommendations.

• Chapter 3 introduces the workspace environment, including toolbars and panels. You will be
shown how to manage CAMtastic!® 2000 Designers’ Edition sessions, from simple tasks of
opening and closing files, to complex imports. In addition, overarching principles, such as
selection, layer management, and aperture design, are explained in this chapter.

• Chapter 4 delineates the viewing and inspection tools. Different display options allow you to
see your images in outline mode, filled, or even with transparent objects. Dcodes may be
highlighted together, and the Origin, Film Box, and Extent Box are reference tools that will help
you keep your image in perspective. Queries and Measurements show layer-specific data,
while netlists and DRC checks may apply to the entire board. A series of reports are available
for export, allowing you to carefully document your work.

• Chapter 5 guides you through the drawing and editing tools. This chapter is the heart of the
manual, describing in detail each of the building tools and the process by which it is applied.
The tools are divided into Drawing, Basic Editing, and Advanced Editing categories, then
arranged alphabetically within each section for easy reference.

• Chapter 6 contains reference information on the CAMtastic!® 2000 Designers’ Edition wizards
and the program preferences.

• Appendix A shows each of the standard toolbars, with references to the portions of the manual
in which the different buttons are explained.

• Appendix B provides a list of shortcut keys for program features and functions.

Once you have the software running, you will find that in CAMtastic!® 2000 Designers’ Edition (like
most software packages), you can roam by various roads. Menu bars can be browsed with mouse
clicks or by holding down Alt as you press underlined letters. Dialogs may be manipulated with the
keyboard, using the Tab or Shift+Tab keys to hop from one option to the next, with the Space Bar
or Enter key activating the button or field. Toolbar buttons offer access to individual features with a
single click, many of which also have shortcut keys assigned to them. While the existing shortcut
keys are listed in the appendix, the emphasis throughout the manual will be on menu sequences
and toolbar buttons. This is due, in part, to the fixed nature of the menu lists and the toolbar button
icons; the shortcut keys may be modified to your own liking.

Bold fonts and double arrows ( » ) will guide you through menus. For example, Edit » Undo means
that you should choose Edit from the main menu, then Undo. If any function has a toolbar button
assigned to it, a picture of that button will appear beside the description.

Online help is available, of course, in the Help menu, where you may browse through the index of
entries or run a search for specific words. Tips and pointers are also available, and may be set to
display each time the program is opened (Help » Tip of the Day). When individual features, such as
dialogs are displayed, pressing F1 may give additional information about a highlighted button or
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field. Finally the CAMtastic!®  website offers FAQs and user-forums for interactive assistance:
http://www.camtastic.com.



CAMtastic!® 2000 Designers’ Edition User’s Guide 5

CHAPTER  2

Installation and Setup

Installing CAMtastic!® 2000 Designers’ Edition may be as simple as inserting the CD and accepting
the prescribed field contents. Before dashing through the installation, however, certain measures
should be taken. You should be aware in advance of any limitations your PC system may impose
upon this software. You should read and understand the License Agreement before accepting it—
please call for customer support if you have any concerns about this agreement.

System Requirements
Make sure that your PC and its software conform to the following requirements and
recommendations:

Recommended System
• Windows NT 4/2000 Professional

• PC with Pentium III Processor

• 128MB RAM

• 200MB Hard Disk Space

• Desktop area 1024x768 pixels

• 32-bit Color Palette

• CD-ROM Drive

• Mouse or compatible pointing device

Minimum System
• Windows 95/98/2000/Me

• PC with Pentium 166MHz

• 32MB RAM



Chapter 2: Installation and Setup System Requirements

6 CAMtastic! ® 2000 Designers’ Edition User’s Guide

• 40MB Hard Disk Space

• Desktop area 800x600 pixels

• 256 Color Palette

• CD-ROM Drive

• Mouse or compatible pointing device

Installation
Insert the CAMtastic!® 2000 Designers’ Edition Designer’s Edition CD-ROM in your computer, and
wait for the installation window to appear. If nothing happens, you may browse through Explorer to
the CD-ROM drive, and double-click on Setup.exe. You will be shown the End User License
Agreement, which you must accept if you wish to proceed with the installation. If you do accept it,
you will be shown the destination folder for CAMtastic!® 2000 Designers’ Edition; by default, this is
C:\Program Files\CAMtastic 2000 DE. You may browse to any other storage location for
this installation. You should then choose the Typical installation option to install CAMtastic!® 2000
Designers’ Edition Designer’s Edition in its entirety. Finally, you may choose the folder name which
will appear in the Programs list in the Start menu.



CAMtastic!® 2000 Designers’ Edition User’s Guide 7

CHAPTER 3

Basics

To help you get started working with CAMtastic!® 2000 Designers’ Edition, some basic concepts
ought to be discussed first. This chapter will discuss the different components of the workspace,
the way to manage individual CAM sessions, and the concepts that are common to all projects you
may undertake with this software.

Workspace Management
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CAMtastic!® 2000 Designers’ Edition has updated its environment to simplify the design and
verification processes for its users. This section will provide an introduction to the workspace,
along with an explanation of basic viewing and selection tools.

Accessing Tools & Features
Toolbars
CAMtastic!® 2000 Designers’ Edition offers eleven toolbars, all of which (except for the Menu Bar)
can be turned off or redocked anywhere on the screen. The toolbars contain over 70 different
buttons and four pull-down menus. You will see pictures of the buttons as their functions are
described throughout this manual; you may also refer to a brief summary of toolbar features in the
Appendix.

By selecting View » Toolbars from the main menu, you indicate all toolbars you wish to display. In
addition, you can change the existing toolbars, create new ones, delete buttons, and reset the
defaults when unwanted changes have been made.

Select Show Tooltips to have the button name appear when the cursor is hovered over the button.
Select Cool Look to contemporize the layout of the toolbars and their individual buttons. The
figure below shows both button styles, with the tooltips selected.
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To create a new toolbar, select New, and enter a name for your new toolbar. Choosing OK will add
this new name to the list of toolbars. Upon closing the Toolbar dialog, you will notice a new floating
toolbar on your screen, currently empty. You can drag new buttons onto this toolbar by following
the instructions below.

If the Customize Toolbar dialog is open, you may modify an existing toolbar by dragging any
toolbar button from one toolbar to another. Dragging the button elsewhere (anywhere that is not a
toolbar) will delete the button. If the Customize Toolbar dialog is not open, you will need to hold
down Alt as you drag the button to a new location. If unwanted changes have been made to one of
the standard toolbars, the original settings may be restored by highlighting the toolbar, and
selecting Reset.

The Reset button turns into a Delete button when highlighting a custom-made toolbar.

Workspace Bar
The Workspace Bar is a user-friendly control that displays all the information and tools that are
required during the current session. This bar can be resized and docked anywhere. Five views are
available in the Workspace Bar:  Main, Layer, Info, DRC/DFM Check, and Netlists.

The Main View tab displays data tables, reports, and preferences, including general settings that
will apply to any session you create or open. It also contains links to online help and an information
page about the current version of CAMtastic!® 2000 Designers’ Edition.

Any item can be opened with a double click. Each of the available options shown in this view tab of
the Workspace Bar is described individually in this manual; refer to the index to locate specific
instructions about these tables, reports, and preferences.

The Layers View tab displays all layers in the active session. Select any layer you wish to display in
the Design Window. A layer’s color can be changed by clicking on the color box beside its name.
Double-clicking any layer name will make it the current layer—upon which an X will appear over
the colored box next to that layer.  In the figure shown here, all layers are enabled, but only one of
the colored boxes (the final one) is marked with an X, indicating it as the current layer.
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Right-clicking on any layer name displayed in this tab will display additional features, as shown
below.

• Type:  Shows what Type (if any) has been assigned to this layer within the CAMtastic!® 2000
Designers’ Edition Layer Table.

• ON:  Toggles between selected (layer is displayed) and not selected (layer is hidden).

• Current:  Makes selected layer current. The same result may be obtained by double-clicking
the layer name in the Workspace Bar.

• Lock:  Toggles between selected (layer is locked and cannot be modified) and not selected
(layer is unlocked and open for editing).

• Delete:  Deletes selected layer. (This action cannot be undone.)

• Rename:  Allows user to rename selected layer.

• Open with Notepad:  Assumes that the selected layer was created from an imported file, and
opens it. If the selected layer was not imported from a file, this function will generate an error
until some file is created (File » Export submenu).

• Reload File:  Reloads original file (Drill/Rout/Mill or Gerber) to remove unwanted edits.
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The Info View tab displays all relevant information for queries and measurements. Scroll bars are
available if the requested information fills more space than is available in the current dimensions of
the Workspace Bar.  The Info View will create a folder of information for each queried object, as
shown in the figure here.

Double-clicking on individual folders will open or close them. The measurement and querying
tools in CAMtastic!® 2000 Designers’ Edition is described in the Inspection Tools section of Chapter
4: Non-Editing Tools.

The Netlist View tab displays all nets resulting from running Netlist Extraction. Selecting any
individual net will zoom to and highlight it in the Design Window. To refresh this list, select Inspect
» View Nets.

This tab will always be visible once a netlist has been extracted from the active session.
(CAMtastic!® 2000 Designers’ Edition offers the ability to extract nets from displayed images, such as
Gerber data.) If this tab is not displayed in your session, follow the instructions on Netlist Extraction
described in the Inspection Tools section of Chapter 4: Non-Editing Tools.
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The DRC/DFM View tab displays any violations resulting from running a design rules check and/or
design for manufacturing check on the current design.

Major folders display the error in question, and subfolders will be created for each instance where
the rule has been broken. Selecting any of these subfolders will zoom to and highlight the error in
the Design Window. To refresh this list, select Inspect » View Errors.

This tab may not appear in the Workspace Bar if a DRC/DFM Check has not been performed on the
current session.

Status Bar
CAMtastic!® 2000 Designers’ Edition's Status Bar will be displayed if there is a mark beside Status Bar
in the View menu. The status bar is located at the base of the screen and contains information
about the active session.

This bar displays a single line of text describing the currently active process—if no function has
been activated, then this line will remain blank. On the left end of the Status Bar is the Coordinate
Box, and towards the right end are the Image Extents boxes in X and Y measurements. All of these
values will display in the currently selected units. Finally, at the far right end of the Status Bar is the
Total Box.

The Image Extents display the width and height of the image in the session. These values will
update automatically whenever the image is redrawn, and can be very useful to quickly determine
the overall size of a job. The Total Box lists the number of currently selected objects, if any.
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Coordinate Box
The Coordinate Box has two main purposes. The first is to display the current location of your
mouse or pointing device. The second is to assist with drawing or editing functions by accepting
X:Y values (up to 6 decimal places) instead of a mouse click.

For example, select Draw » Line. Instead of choosing the starting point with your mouse, however,
type 1:1 in the Coordinate Box and press Enter. Then clear this line with either the Backspace or
the Delete key, type 1:2 and press Enter. You will see a horizontal line drawn upon the active layer
from (1,1) to (1,2). Continuing with this sequence will draw any number of lines until you press Esc
or right click the mouse. This method of entry is called Absolute Values.

The Coordinate Box can also accept Relative Values from an initial point. These can be entered in
coordinates (Vector) or with a distance and an angle (Polar).

To draw a Vector from an initial point, select Draw » Line and choose an initial point (either with a
left click in the Design Window or with an Absolute Value in the Coordinate Box, as described
above). Now type @1,0 in the Coordinate Box and press Enter. A horizontal line one unit long is
now drawn from the initial point in the Design Window.

To draw using the Polar method, begin as before (selecting Draw » Line and choosing an initial
point), then clear the Coordinate Box and type @1<45 and press Enter. A line one unit long is drawn
at a 45° angle from the initial point in the Design Window.

Absolute Values (Coordinates):  X:Y Enters a point at (X,Y).

Relative Values (Vector):  @X,Y Enters a point X and Y distance from initial point.

Relative Values (Polar):  @DISTANCE<ANGLE Enters a point with DISTANCE and ANGLE from initial
point.

Mouse
As in other Windows applications, CAMtastic!® 2000 Designers’ Edition uses the left mouse for
clicking, selecting and dragging. When moving the mouse, a corresponding selection tool (or
cursor) movement occurs on the screen.

The familiar “pointer” Arrow Tool is used for standard Windows operations, such as choosing from
menus and dialogs.

For user convenience, CAMtastic!® 2000 Designers’ Edition offers shortcuts to many commonly-
used functions in a right-click menu. The contents of this menu depend upon the currently-active
function. If no drawing or editing function is active, right-clicking in the Design Window will
prompt the standard menu, giving you access to various different zooms, the redraw (refresh)
function, and the snap menu.  This menu also allows you to cancel the current action or repeat the
previous one.

Many CAMtastic!® 2000 Designers’ Edition processes, such as drawing or editing, require several key
sequences or mouse clicks. If you are in the middle of a process, a right-click will generally
complete it. (Contrast this with Esc, which cancels an active function.)
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Shortcut Keys
For users who prefer using the keyboard over the mouse to access functions, CAMtastic!® 2000
Designers’ Edition has made browsing menus easy to do with the keyboard. This process is the
same as in many other Windows programs:  simply holding down Alt then typing the letter of an
underlined word in a visible menu will either activate the process or open a submenu.  For
example, pressing Alt+A while in adding selection mode will select the entire image.

As you browse through these menus, you may notice key sequences listed to the right of some
commands. These shortcut keys may be used instead of the menu-browsing method and can save
you time once you learn them.

You may learn the shortcut keys already present in CAMtastic!® 2000 Designers’ Edition simply by
noticing them as you browse through the main menu. A list of all existing shortcut keys has been
included in the appendix of this manual.

While there are nearly 200 macros available in CAMtastic!® 2000 Designers’ Edition, only 50 have
shortcut keys assigned to them by default. As you discover the processes that you run most
frequently, you may apply shortcut keys to them.

Choose Help » Shortcut Keys, which opens the Shortcut Keys dialog, shown below.

Browse through the list of macros to the process you want. These are generally referenced by the
Menu Item under which the process is located. Highlighting any macro will cause a short
Description to appear in the top right corner of the dialog. If any shortcut keys are currently
assigned to the selected process, its key sequence will appear in the Assigned shortcuts area.

You may remove an existing shortcut and replace it with any key sequence you prefer.

Select Create Shortcut to open the Assign Shortcut dialog.
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Press the new key(s) for the macro. If the displayed sequence is correct, simply choose OK and the
new shortcut key(s) now will be displayed when the macro is highlighted.

You may assign more than one key sequence to start the same process. Each key sequence,
however, may only apply to one process. If the new key sequence you enter in the Assign Shortcut
dialog is already in use, a note will appear telling which process is currently assigned to that key
sequence. For example, choosing T as a new shortcut key will summon a message that this shortcut
key is already assigned to View: Translucent (as shown in the example above). If you proceed,
the new process will replace the old when you press that shortcut key.

CAMtastic!® 2000 Designers’ Edition is not case-sensitive, so only one feature may be assigned to
each letter or key sequence.

If you would like to remove all customizations you have made to the shortcut keys and restore the
original configuration, simply select Reset All.

Viewing Images
CAMtastic!® 2000 Designers’ Edition allows you to open and view up to four sessions concurrently.
All open files are listed at the bottom of the Windows menu, with a mark displayed beside the
active document. Select Window » Cascade to have the images arranged so that the Title Bar of
each file is visible; then clicking on any Title Bar will make its Design Window visible and active.
Otherwise, you may select Window » Tile to arrange the images evenly to fill the screen.

Double-clicking on any Title Bar will maximize (fill the screen with) that session. If any sessions
have been minimized (only the Title Bars are displayed), you may choose Window » Arrange Icons
to have these Title Bars lined up in the lower left corner of the screen.

Only one session may be active at a time—its title bar will appear differently from any other open
sessions depending on the color display scheme you have chosen for your computer. You may
modify the current view by zooming in towards or away from the image, or by panning one way or
another. In most cases, you may do this without affecting the status of any processes you are
currently running.

CAMtastic!® 2000 Designers’ Edition offers several different zoom tools. These can be accessed
through shortcut keys, toolbar buttons, or the View » Zoom submenu. The cursor location acts as
the center point for most zoom options.

Zoom All:  Displays all objects contained in active layers, centering their image on the screen.
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Zoom Previous:  Returns to the zoom immediately previous to the current one (functions like an
Undo for zoom).

Zoom Window:  Displays a magnified view from the current view, given a Window selected by the
user. Click once on each corner of the area you desire to view.

Zoom In:  Magnifies the current view.

Zoom Out:  Lowers the current view’s magnification.

Dynamic Zoom:  Allows zoom to be controlled by the cursor being dragged up or down on the
screen. The initial mouse click defines the center of the zoom. An upward drag zooms in, while a
downward drag zooms out.

Zoom Film Box:  Displays all images that fit inside the current Film Box. This feature is not active if
film box is not displayed.

Zoom Dcode:  Zooms out to largest area that displays all Dcodes in use. The current Dcode is also
highlighted.

For more information about Dcodes, see the Building Blocks section of Chapter 3: Basics.  For more
information about the Film Box, refer to the Viewing Tools section of Chapter 4: Non-Editing Tools,
respectively.

Panning, or nudging the view in one direction or another, can be done with the arrow keys. Two
additional panning options are also available:  Center Pan and Dynamic Pan. All of these panning
options can be accessed through shortcut keys, toolbar buttons, or the View » Pan submenu. The
cursor location acts as the center point for most zoom options.

Center Pan:  Waits for you to click somewhere in the Design Window, then repositions the display
with that point as the center.

Dynamic Pan:  Allows pan to be controlled by a click and drag of the mouse.

Selecting Objects
New users may find selecting objects in CAMtastic!® 2000 Designers’ Edition a bit awkward. Most
programs have trained users to select first, then decide what to do with the selection. CAMtastic!®

2000 Designers’ Edition offers the opposite approach. First, choose a process (Query, Chamfer, etc.)
and then select the objects to which it will apply. Said another way: if selecting items is part of a
process, simply initiating the process will put you into selection mode.

Selections in CAMtastic!® 2000 Designers’ Edition are cumulative, meaning that selecting a new item
does not cancel previous selections. Items can be added or removed from a selection either
individually or in groups.

CAMtastic!® 2000 Designers’ Edition selection mode will remain active until the function is either
completed (right click) or cancelled (Esc key).
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When a function requiring object selection is activated, the cursor will default to a square pickbox.
The status bar will display the name of the function you have chosen, followed by instructions on
selecting objects, draws, vertexes, traces, texts, or boundary edges.

Clicking upon any object selects it (an object will turn white when selected). Clicking on an empty
space will move you into window mode (the cursor changes to a crosshair). If this is not what you
want, simply click the mouse once again as close to the original click as possible, leaving the
selection window empty. This will return you to the pickbox for more single-click selections.

Instead of selecting objects one by one, you may want to select all of the objects within a certain
region. There are two types of selection windows available in CAMtastic!® 2000 Designers’ Edition:
the standard Select Window and the Select Crossing Window.

The standard Select Window has a solid-line border, and will only select
objects wholly contained within the window you draw. The Select Crossing
Window has a dotted-line border, and will select all items partially or wholly
contained within the window you draw.

You may activate either of these modes by selecting their buttons in the
Select Toolbar. Either selection window button will allow you to draw a single
selection window, after which the cursor will default back to the pickbox for
additional selections.

Advanced users will prefer a different method of accessing selection windows. As mentioned
above, when the pickbox is clicked upon an empty space, the original click is now used as one
corner of a selection window. By moving the mouse to the left, a Select Crossing Window is drawn.
Moving the mouse to the right draws a standard Select Window.

By default, both Flashes and Draws are enabled on the Select
toolbar, meaning that you can select anything on your screen
when selection mode is enabled. If you only want to select
flashes in a certain area, click on the Select Draws button to
disable it (if it is still enabled), then draw your selection
window. The same logic applies to selecting draws in a certain
area:  disable the Select Flash button on the toolbar before
defining your selection area.

All flashes, draws, or both can be selected by enabling their respective buttons and then choosing
the All button.

The same will apply only to the draws and/or flashes visible in the current zoom of the document
by choosing the Display button.

The Filter button on the Select toolbar gives you additional control over your selections. Choosing
this button will open the Selection Filter dialog, shown below.
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The Dcode and/or Layer number(s) should be entered, separated by commas. Ranges may also be
indicated. You may type, for example, 1,3,5-7 which would select D1, D3, D5, D6, and D7 (or
Layers 1, 3, 5, 6, and 7). Leaving the line blank will select all Dcodes or Layers, and preceding a
number or range with an exclamation point will select everything else.

The pull-down lists are filled as they are completed individually, meaning that complex selections
need only be entered once, even if they are used again in the future.

Once you have selected everything you want, complete the function by right-clicking once. If you
want to cancel the function instead of executing it, simply press Esc.

If you have inadvertently selected certain objects, you may completely cancel the function by
pressing Esc to start over. On the other hand, it may save you time to simply deselect those specific
items. You may do this by choosing the Remove button.

Pick boxes and Selection Windows will continue to operate in exactly the same manner, only
deselecting instead of selecting their contents. You may return to selection mode by choosing the
Add button.

Finally, CAMtastic!® 2000 Designers’ Edition memorizes complex selections, and allows you to
return to past arrangements by choosing the Previous Selection button.

Selection processes may vary slightly depending upon the active editing function. Refer to the
instructions in Chapter 5: Editing Tools for function-specific details.

Because selection plays a central role throughout CAMtastic!® 2000 Designers’ Edition usage,
shortcut keys have been applied to each of these toolbar buttons. See the Appendix for a list of
shortcut keys.
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Session Management
This section describes how to work with existing sessions and/or third-party files. When you open
CAMtastic!® 2000 Designers’ Edition, a new, blank session is automatically generated, which you can
edit, save and close. You may import files from other programs into your session, and similarly, you
may print or otherwise export information from CAMtastic!® 2000 Designers’ Edition in a variety of
formats.

Opening, Saving and Closing Files
Choosing File » New will start a new session. This document will not have a name until it is saved.
The Title Bar will display the name:  [Untitled] until it is saved.

Choosing File » Open will open an existing session. As you browse through Windows folders to
find the file you want, a preview window will help you determine what each .cam file contains
before opening it. Sessions saved by previous versions of CAMtastic!® will automatically be
detected, but no preview will be available.

Choosing File » Close will close the active session. If modifications have been made, you will be
prompted to save the session before closing.

Choosing File » Save will save the current session. If this file has been saved before, then all current
information will replace information stored in the previous save. If this session has not been saved
before, then a dialog will allow you to browse to a desired location and name the new file. All
session-specific settings and preferences are saved, and will be restored when the CAM file is
reopened.

Choosing File » Save As lets you save your session under a different name. All changes that have
been made to the file since the previous save will only be reflected in the Saved As file.

Importing Files
CAMtastic!® 2000 Designers’ Edition reads a large variety of files from other systems. General
options, such as setting defaults, can be indicated in the Import/Export Preferences dialog shown
below. You may access this through the Main tab of the Workspace Bar (see the Preferences section
of Chapter 6: Reference Tools for details).

While the information in this dialog pertains specifically to Gerbers, one feature is the same in
nearly all CAMtastic!® 2000 Designers’ Edition imports. Selecting Import Settings will pull up the
Settings dialog, shown below.



Chapter 3: Basics Session Management

20 CAMtastic! ® 2000 Designers’ Edition User’s Guide

• Digits:  Indicates the number of digits before and after the decimal point (integer and decimal,
respectively) that CAMtastic!® 2000 Designers’ Edition will read upon import.

• Units:  Toggles between imperial and metric to match the units in which the information was
originally saved.

• Type:  Toggles between Absolute and Incremental. (Absolute coordinates are always relative to
the origin; incremental values are relative to each other.)

• Zero Suppression:  Ignores Leading or Trailing zeros, unless None is selected.

Changing the settings here will make these your defaults for future Gerber imports. An identical
box will be available on all individual imports (and exports) of Gerbers, Drill, Mill & Rout files.

If the import preferences are all set to your satisfaction, you are ready to begin importing individual
files. Selecting File » Import will show the following options:  Drill, DXF/DWG, Gerber,
HPGL/HPGL2, Mill/Rout. Importing of aperture lists and aperture library files are also included in
this submenu.

Drill

Drill files contain tool numbers for each drill bit and X and Y locations for each instance that bit is
used on the board. Selecting File » Import » Drill will allow you to browse to this drill file.

While CAMtastic!® 2000 Designers’ Edition can interpret a wide variety of drill file formats, the
preferred format is described in the following example.
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CAMtastic!® 2000 Designers’ Edition by default looks for .drl and .dpt files, as these are common
extensions for drill files. However, any ASCII file can be selected in this menu.

Upon locating the file, the Import Drill Data dialog appears.

Selecting Units will bring up the standard Settings dialog described previously.

In some cases, the tool diameters are not indicated in the drill file, but are supplied separately. If no
drill sizes are detected, CAMtastic!® 2000 Designers’ Edition will use the diameter supplied in the
Shape/Default Hole Size field in the Import Drill Data dialog. You may, however, select Tool Table
to assign tool diameters manually, modify existing tools, or import new ones. The Tool Table will be
described in detail in the Building Blocks section of this chapter.

Import Drill Data will automatically assign a new tool number if the present tool number is
currently being used by another drill layer.
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DXF/DWG

AutoCAD files can be imported directly in to CAMtastic!® 2000 Designers’ Edition. Selecting File »
Import » DXF/DWG brings up the DXF/DWG Import Wizard after the desired file is located.

Since many detailed options are available for these imports, four basic groups of settings have been
pre-arranged:  Standard PCB; Microwave RF; Chemical Drawings and Fab Drawings. The
appropriate wizard should save you time in importing different kinds of DXF or DWG files.

If you inadvertently choose a scale that extends the board beyond the borders of
the CAMtastic 2000 workspace, you will later be offered a choice to scale down
the board.

A pull-down list of Units allows you to choose the system and scale of the
imported files. Simply choose the units and decide if you wish all TrueType fonts
to be filled, then select OK.

If none of the preset wizards successfully reads in your files, you may adjust individual settings
yourself by selecting Skip Wizard, and choosing OK. This will open the Import DXF/DWG dialog,
shown below.
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Each detected layer will automatically be selected for import. Four columns of options are available
for each layer.

• FCB (Fill Closed Boundaries):  If selected, areas bounded by closed 0-width Polylines, solids or
traces will be filled. If not selected, the boundary will be outlined and given the line width
assigned in the Text Options dialog, described below.

• OWP (Outline Width Polylines):  If selected, the outlined boundaries of all polylines will have
their width calculated so as to appear exactly as inside AutoCAD. If not selected, a diameter
will be assigned to match the polyline starting width. This diameter will be traced along the
polyline (all edges will be rounded, and the polyline will be extended by half the width of the
polyline per side).

• FRD (Flash Round/Donut Pads):  If selected, round and donut shapes are detected within your
DXF/DWG files, and flashed apertures are automatically created. If not selected, the boundary
will be outlined and given the line width assigned in the Text Options dialog, described below.

• FRS (Flash Rectangle/Square Pads):  If selected, rectangular and square shapes are detected
within your DXF/DWG files, and flashed apertures are automatically created. If not selected,
the boundary will be outlined and given the line width assigned in the Text Options dialog,
described below.

The File menu in this dialog allows you to open or save settings both for DXF/DWG imports or
Aperture information. In the Units/Scale section of this dialog, you again have access to a pull-down
list of units. In addition, you may rescale the import by changing the Scale value from its default
(1.0). Selecting Hide Import Wizard will bring you directly to this dialog upon your next DXF/DWG
import.

If you are not too familiar with DXF/DWG, we strongly encourage you to only modify the basic
settings found on the Import DXF/DWG dialog. Once you have loaded the DXF/DWG into
CAMtastic!® 2000 Designers’ Edition additional modifications can be easily made.
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Three additional buttons are available in this dialog. The Merge Layers button allows you to
combine layers prior to import (this process is linked to Composite Merge, described in the
Advanced Editing section of Chapter 5: Editing Tools). Importing DXF or DWG files with merged
layers requires an empty session. A warning will allow you to cancel this action before overwriting
any present data.

The Aperture button brings up the Aperture Table, described in the Building Blocks section of this
chapter.

The Options button, however, is unique to the DXF import. Selecting this button brings up the
Advanced Options dialog, shown below.

This dialog allows you to control how the DXF/DWG file will be read into CAMtastic!® 2000
Designers’ Edition. Select one of the three OWP modes:  segmented, squared corners, or
chamfered corners. Modifiable fields in this dialog allow you to change the Line Width and
Rectangle Flash Ratio. Selection boxes allow you to fill or simply outline the imported traces, add or
exclude endcaps, import or disregard hatch patterns or move blocks from Layer 0 to destination
layer.

When most AutoCAD designers create block libraries, all block objects are usually created on Layer
0. When those blocks are subsequently inserted into different layers, they appear to move, but
internally they are still on layer 0. If this feature is selected, CAMtastic!® 2000 Designers’ Edition will
move those objects to the layer in which the block was inserted, thus giving the effect of how the
objects appeared in AutoCAD. If this feature is not selected, objects within blocks will be written to
Layer 0.

Selecting Text Options opens the dialog shown below, allowing you to control how the text in
DXF/DWG files will be imported.
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•  Use AutoCAD SHX:  Allows you to use an .shx font file (AutoCAD standard) for text imports.
If this option is enabled, choosing Select will allow you to browse to change the default file.

• Use TrueType:  Writes text imports with TrueType fonts. Choosing Select if this option is
enabled will allow you choose size, fonts and scripts for imported texts.

• Select TrueType Font Quality:  Controls the line quality used for TrueType fonts.

• Use Polygon/Raster Fill on TrueTypes:  Fills TrueType fonts with Raster (shape) fills rather than
Vector fills. Filling with vectors usually inflates the size of your file.

• Use Same Line Width for All:  Directly assigns a line width value that will be used on all
DXF/DWG text.

• Using Ratio (Height/Line Width):  Determines the line width by using a fixed ratio (assigned by
user) with the text height.

Gerber
Gerber files can be loaded in groups or individually. If you have a folder containing multiple
Gerber files, all of which you want to import, use Gerber Quick Load. If you want to load Gerber
files selectively, use the standard Gerber import.

Quick Load
This feature loads and automatically detects all Gerber and aperture files from a specified folder.
Selecting File » Import » Gerber Quick Load will open the Gerber Quick Load dialog.
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Browse to the drive and folder containing the Gerber files. You may modify the import settings, but
if you are uncertain, you should simply accept the settings CAMtastic!® 2000 Designers’ Edition has
automatically determined.

For this process to function optimally, first ensure that all desired Gerber files are stored in a single
folder.

Selecting Units opens the Settings dialog, described at the beginning of this section.

Selecting Options brings up the Import Gerber Options dialog, shown below.

Use 360 Degree Arcs as default:  If selected, CAMtastic!® 2000 Designers’ Edition will allow imported
arcs to extend beyond 90 degrees.

• End Gerber Block at Newline:  Recognizes a hard return as the end of a data sequence.
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• End of Gerber Block Character:  Recognizes a specific character (an asterisk, for example) as
the end of a data sequence.

The defaults for both of these dialogs (Import Gerber Options and Settings) can be preset in the
Import/Export Preferences (see the Preferences section of Chapter 6: Reference Tools for details).

Selecting the Aperture Wizard Rule pull-down reveals a list of wizard templates used during Gerber
import.

If the source is unknown, select Auto-Detect Apertures (the default setting). New rules can be
defined and added to this list; see the Aperture File Wizard section of Chapter 6: Reference Tools for
details.

Standard Gerber Import
This feature loads in any Gerber (RS-274D, RS-274X, Fire9000) into CAMtastic!® 2000 Designers’
Edition. Selecting File » Import lets you browse to and select the Gerber file(s); multiple Gerber
files can be selected with the Ctrl or Shift key. If at least one Gerber file has been highlighted,
selecting Open will bring up the Import Gerber Files dialog, shown below.

Some of the buttons in this dialog have been described previously.

• Settings:  Opens the Settings dialog.

• Load Options:  Opens the Import Gerber Options dialog
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• Aperture Wizard Rule:  Includes the list of rules described in the Quick Load segment, above.

Three additional options are available in the Import Gerber files dialog.

• Gerber Version:  Toggles sequentially between Gerber RS-274, Gerber RS-274X, and Fire9000.

• Auto-Detect Gerber Formats:  Detects automatically all options and settings required to load in
a Gerber file(s).

• Aperture List:  Allows you to browse to an aperture list for the imported file(s).

Gerber RS-274 does require an Aperture list, while extended versions Gerber RS-274-X and Fire9000
do not (all apertures are embedded inside extended Gerber files).

HPGL/HPGL2
CAMtastic!® 2000 Designers’ Edition can import HPGL (*.hpg, *.hp, and *.plt) files. Selecting
File » Import » HPGL/HPGL2 will allow you to browse to the desired file(s); multiple files may be
selected using the Ctrl or Shift keys. The Import HPGL/HPGL2 dialog (shown below) will then
appear.

If pen separation is necessary, CAMtastic!® 2000 Designers’ Edition can use layers (placing each pen
on a separate layer), or apertures (assigning each pen to a separate Dcode). Indicate what type of
pen separation you desire—if any—and what pen width you wish to use.

If you have any complex fonts in AutoCAD, simply plot them to an HPGL file, and then load them
into CAMtastic!® 2000 Designers’ Edition.

Mill/Rout Data
CAMtastic!® 2000 Designers’ Edition also imports NC Mill/Rout Data (*.rte, *.rou) files.
Selecting File » Import » Mill/Rout will allow you to browse to the desired file(s); multiple files may
be selected using the Ctrl or Shift keys. The Import Mill/Route Data dialog will then appear.
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The Units button will open the Settings dialog described at the beginning of this section. Selecting
Mill Table will open the Tool Table (described in the Building Blocks section of this chapter), where
you may retrieve preset tool sizes or manually assign new ones. Otherwise, the Default Tool Size
will be used for all milling/routing.

Aperture Files
If for some reason CAMtastic!® 2000 Designers’ Edition has been unable to automatically detect the
proper Aperture Wizard Template to use for a particular Gerber import, you may coordinate the
correct wizard with the source file by selecting File » Import » Aperture File (using Wizard Formats).

The pull-down of Existing Wizard Formats displays the list of templates provided by CAMtastic!®

2000 Designers’ Edition, plus any additional wizards you have created yourself (see the Aperture File
Wizard section of Chapter 6: Reference Tools for details).

After choosing an appropriate wizard format, either type in the aperture list file name (including
full path) in the lower field or select the browsing button to the right to locate the file. Once you
have selected both the correct wizard format and Aperture File, select OK. You will be asked if the
new aperture list should overwrite or simply supplement the existing list.

Selecting File » Import » Custom Aperture Library File will look for a .lib file in which you have
stored information on custom parts you have built. Importing frequently-used custom shapes can
save time in future projects (see Reports section of Chapter 4: Non-Editing Tools for details on
creating such a file).
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Exporting Files
CAMtastic!® 2000 Designers’ Edition exports all the same formats that it imports. Default settings,
including the optimization of exported files, can be modified in the Import/Export Preferences
dialog (see the Preferences section of Chapter 6: Reference Tools for details).

Drill Data
This feature writes simple NC Drill files from the current session. Selecting File » Export » Drill Data
opens the dialog shown below.

You will only need to select the layer required for export, and modify the units if necessary.

Selecting OK produces two text files in the same location:  a .drl file and a .rpt file. The .drl
file contains instructions that may be read by certain Excellon machines, and its format is described
above in the segment on Importing Drill files. This file can also be imported into other CAMtastic!®

2000 Designers’ Edition projects. The .rpt file is a report listing the number of holes each tool will
drill.

DXF
This feature writes a DXF from the current session. Selecting File » Export » DXF opens the dialog
shown below:
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All detected layers will automatically be highlighted, any of which may be removed with a single
click.

You may determine if the lines will be exported as 0-width outlines or filled lines. Your filled lines
may also include Endcaps (Military Spec), which causes an exported image to display in AutoCAD
exactly as it appears in CAMtastic!® 2000 Designers’ Edition.

To decrease the size of DXF files, you can also filter out any unnecessary Dcodes, such as line-
strokes (used to fill boundaries), or any other useless type of data for DXF export that is currently
displayed in the CAMtastic!® 2000 Designers’ Edition image. Texts may also be converted to
polylines.

Choose Save when you are ready to proceed with the DXF export and browse to a drive location to
save the new file.

Most DXF files created from Gerber are very large. To decrease the file size of your DXF file, you
may use 0-width lines. This will also improve the redraw speed and is recommended especially if
you are using the DXF/DWG as a reference file.

Gerber
This feature creates Gerber files from the current session. Selecting File » Export » Gerber opens
the Export Gerber Data dialog shown below.
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In the Format section, a button allows you to toggle between standard Gerber formats:  RS-274D,
RS-274X, and Fire9000. The Settings button brings up the standard Settings dialog.

The Options section exists to allow photoplotters with limited capabilities to plot the sometimes
complex and extensive Gerber files created by CAMtastic!® 2000 Designers’ Edition.

• Use Arcs (G75):  This option will include true arcs in your Gerber files. The data must already
be an arc in CAMtastic!® 2000 Designers’ Edition. If not selected, arcs will be sectored.

• Use Step & Repeat Codes (if any):  This option will include Step & Repeat data in your Gerber
files. The data must already have Step & Repeat information. If not selected, Step & Repeat data
will be exploded into individual objects.

• Separate Composite Layers into individual Files:  This option will separate a composite layer
into individual Gerber files. The data must already have composite information.

• Convert Polygons to Vector Fill:  This option will fill polygons with line strokes. The data must
already have polygons or polygon voids.

In the File section, all detected layers are selected.  Deselecting individual lines will prevent Gerber
generation for those layers, and selecting Clear All will remove all selections (choosing the same
button again—now called Write All—will once again select them all). A unique file name is assigned
for each layer according to its layer name, but these fields may be modified. If you would like the
same three-character extension to apply to all exported Gerber files, simply type in the three
characters in the field beside Apply Gerber File Extension then select that button.

The target directory for these files can be indicated and applied in this screen, while individual file
names and locations can still be modified in their individual fields. Clicking on the number beside
any layer number will allow that Gerber file to be exported singly.
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Mill/Route
This feature writes NC Mill/Route files from the current session. Selecting File » Export » Mill/Rout
will open the dialog shown below.

Simply choose the layer you want to export (or else choose All Layers) from the pull-down list, and
modify the Header information, if necessary.

Select Header File if you have header information already saved in a text file.

Selecting Units opens the standard Settings dialog. Select Use Step & Repeat Codes if any have
been defined in the session. The Tool Table button opens the Tool Table, which is explained in the
Building Blocks section of this chapter.

Netlist
This feature exports a simple netlist from the current session. It behaves like a bed of nails tool,
allowing you to test points on the top and bottom of the board. Selecting File » Export » Netlist
opens the dialog shown below.
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You may toggle between All net points and Ends Only. The former will detect the center point
locations of all pads and vias; the latter will disregard the vias.

For a single-sided board, select only the PCB Side that has been assigned in the Layer Table. The
netlist may be exported in a Text Report or IPC-D-356 format (this *.ipc version is the most
common way to transfer netlist information from one CAD/CAM system to another).

For a netlist to export successfully, either Top or Bottom must be assigned in the Layer Table, as
well as a Drill (top or bottom) layer.  See the Building Blocks section of  Chapter 3: Basics for details
about the Layer Table.

IPC-D-350
This exports the active session as version 350 *.ipc file. Selecting File » Export » IPC-D-350 opens a
standard Save As dialog. Simply browse to the location where you wish to store this file and choose
OK.

Bitmap
This feature allows you to create a bitmap from an object or selection window. Selecting File »
Export » Bitmap opens the dialog shown below.
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A bitmap is created with an alterable resolution. Simply choose a DPI from the pull-down list or
type in the resolution you desire. You may also choose between a monochrome and color output.
The image extents of the bitmap are reported in X and Y measurements. Selecting OK will allow
you to browse to the target folder for this bitmap file.

The default background for bitmaps exported from CAMtastic!® 2000 Designers’ Edition is white.

Printing
CAMtastic!® 2000 Designers’ Edition offers several printing options. A print preview is also available
before you actually send the image to the printer. CAMtastic!® 2000 Designers’ Edition images may,
of course, be printed from other applications if the image is copied onto the Windows clipboard
and pasted into the target application.

While CAMtastic!® 2000 Designers’ Edition displays the images on your computer screen with light
colors against a black background, all prints (monochrome or color) are drawn with dark lines
against a white background.

When you are ready to print images from CAMtastic!® 2000 Designers’ Edition, select File » Print.
This will bring up the Print Setup/Preferences dialog, shown below.

• Print Area:  Toggles between Display and Extents. The Display option will print whatever
portion of the image is currently filling the Design Window; the Extents option will print the
whole image, regardless of the current view.

• Print Color:  Toggles between Black & White and Color.
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• Print Scaling:  Toggles between Fit to Page and User Scale. The Fit to Page option will enlarge
or shrink the image to fill the page size you have selected. The User Scale option allows you to
enlarge or shrink the size of the image manually.

• Print Options:  Offers three choices, any or all of which may be enabled:  Center Image on
Page, Print Page Info Header, Separate Page for Each Layer. If the latter option is enabled, the
user may further indicate to have each layer on its own page, or split the page in half or
quadrants for the printing of separate layers.

• Printer Setup:  Offers standard printing setup options, including the printer selection,
properties, page orientation, and paper sizes and sources. Also a Network button will allow
you to connect to a Shared Printer.

If no advanced printing features need to be modified, simply choose OK to print.

Selecting File » Print Screen will give the identical result as setting the Print Area to Display.

Selecting Printer Setup will open an additional dialog, wherein CAMtastic!® 2000 Designers’ Edition
will automatically detect the printers you have installed on your operating system, and will
subsequently offer a standard assortment of options, depending upon the printer you select.
Choose Network to browse your network for printers not showing in this list. Choose Properties
for additional options concerning layout, print quality and other graphic controls.

Selecting OK in the Print Setup/Preferences dialog (shown earlier) will open a final dialog, in which
you may indicate how many copies you want to print. Many of the other printing preferences
available elsewhere can be double-checked and even modified from this dialog. Choosing OK will
send the job to the selected printer.

All images may be previewed before sending them to the printer. Selecting File » Print Preview will
open the same Print Setup/Preferences dialog shown earlier. When the OK button is chosen, the
image will display on the screen with buttons allowing zooming and browsing through multiple
pages (if applicable). Also, a Print button will proceed to the Print dialog shown above, allowing you
to proceed directly to printing.

If you would like to print the CAMtastic!® 2000 Designers’ Edition image from another application,
you may export the image in a variety of formats, including a bitmap image (see Exporting, above).
In addition, selecting File » Copy to Clipboard will copy the current view of the Design Window to
the Windows clipboard, ready to be pasted into other Windows™ applications.

The image will be copied as it appears in CAMtastic!® 2000 Designers’ Edition, with the dark
background and any visible grid dots.
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Building Blocks
Several overriding concepts apply throughout CAMtastic!® 2000 Designers’ Edition and will be
introduced in this section. These include Dcodes (apertures), layers, drawing modes, and tools for
drilling, routing and milling.

Dcodes
A code number between D10 and D999 will be assigned to all different shapes and sizes (apertures)
used in your current session. This list is available for modification in the Aperture Table. If you
import an image into CAMtastic!® 2000 Designers’ Edition, the Aperture Table will automatically
generate all the Dcodes necessary to assemble the image.

The Aperture toolbar contains a button for the Aperture Table and a pull-down list of all assigned
Dcodes.

The Dcode Pull-Down displays the current Dcode—any drawing process you begin will use this
Dcode as the pen. Picking any other Dcode from the pull-down list will make it the current Dcode.

Shapes must be defined in the Aperture Table, however, before they can be placed in the current
image. Once defined, the shape or size of an aperture may be modified by returning to the
Aperture Table. Any changes you make to an existing Dcode will automatically replace all instances
of that Dcode with the new aperture definitions.

The Aperture Table may be accessed from the Main View of the Workspace Bar or by selecting the
Aperture Table button in the Aperture toolbar.
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In a new session, this list will be blank until images are imported or defined manually. CAMtastic!®

2000 Designers’ Edition will create an aperture list automatically from imported files, such as
Gerbers. Otherwise, shapes can be added or modified manually by changing the fields listed in the
Aperture dialog.

A Dcode number between D10 ad D999 is available for each aperture you wish to create. An
asterisk (*) is placed next to all currently used Dcodes. Fourteen options are available in the Shape
pull-down list, and the Size format varies slightly between shapes.

Shape Size Format Shape Size Format

Custom X:Y (extents) Polygon Void Length

Diamond Length:Height Square Length

Donut Outside Diameter:Inside Diameter Rect Length:Height

Oblong Length:Height RoundRect Length:Height

Octagon Length:Height Target Outside Diameter

Round Diameter Thermal Outside Diameter:Inside Diameter

Polygon Length Undefined None

Custom parts must have special attributes assigned to them. For example, if you choose Custom as
a new shape, then enter X and Y dimensions as indicated above, then exit the table, you will find
that no aperture has been created. On the other hand, if you have instances of a normal aperture
already placed in the Design Window, then you change the shape to Custom in the Aperture Table,
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then close the table, all the shapes will turn to small squares. Returning to the Aperture Table, you
will find that the Special button will return an error if you try to assign custom attributes to it now.

The correct method is to first choose a shape that can handle special attributes. Any shape but
Round, Donut, Polygon, or Polygon Void may be rotated. A RoundRect also allows you to choose its
corner radius. A Target will let you choose between one and four rings, and modify the width of its
component tracks. Conversely, a Thermal will allow you to choose two or four spokes and modify
their width.

Rotation degrees may be entered between 0 and 360. No negative values will be accepted.

Once any aperture has been assigned special characteristics, its shape is changed to Custom. After
this point, you may modify any of the special attributes, but you may not change its dimensions by
simply retyping in the Size field, as you would with normal apertures. To change the dimensions of
a custom aperture, you must change it back to a normal aperture first, change the size, then apply
the special attributes anew.

When importing Gerber, DXF or DWG images into CAMtastic!® 2000 Designers’ Edition, an aperture
table will be created, including a pull-down list of all current Block & Shape names defined in the
original files. If you need to map one of these to a Dcode, select the aperture shape & size to be
mapped, and then choose which Block or Shape you need to use from the pull-down list.
Additional entries will be included in this pull-down list when elements in your design are drawn to
custom apertures (see the Advanced Editing section of Chapter 5: Editing Tools for details).

If any undefined apertures have been used in the current session, the Next Undefined button will
be enabled, scrolling down to the next one on the list. If all apertures have been assigned specific
shapes and sizes, this button will become disabled.

An asterisk appears beside all Dcodes that are represented in the design window. The Delete
Unused button will locate all Dcodes that have not been used in the current session and erase their
data, returning them to default settings. This can be useful if you wish to free up additional room
for new apertures. CAMtastic!® 2000 Designers’ Edition will not hold more than 990 Dcodes in a
single session.

Any number between 10 and 999 may be typed in the Goto Dcode field; clicking on the button will
automatically jump to the aperture described on that line.

Layers
All images in CAMtastic!® 2000 Designers’ Edition are drawn or imported onto layers. When a new
session is created, at least one layer must be added for any images to appear on the screen. If the
user does not add a layer manually, one will be automatically created when any Dcodes are placed
in the Design Window.

CAMtastic!® 2000 Designers’ Edition allows up to 50 layers to be used in a single session. Several
tools are available for layer management:  the Layers View of the Workspace Bar (described in the
Workspace Management section of this chapter), the Layers toolbar, and the Layer Table.
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The Layers toolbar offers several commonly-accessed functions. All layers may be
displayed (turned on) by selecting All ON, and similarly, all layers may be turned
off by choosing All OFF. A new layer may be created by choosing Add Layer.

As described previously, the current layer will have an X through its color box in
the Workspace Bar. The current layer will also be displayed on top of the Layer
Control Pull-Down, which is available on the Coordinate Toolbar (shown below).

To change the current layer, select a different layer from this pull-down list. Each layer has its own
number, assigned in the order it was created or imported.

Multiple layers may be combined in a variety of ways. A merge will simply create a new layer out of
existing ones, while composite layers are used to create complex shapes, like donut holes, which
require overlapping layers to display properly. See the Advanced Editing section of Chapter 5:
Editing Tools for details on Combining Layers.

The main tool for working with layers, however, is the Layer Table. You can open the Layer Table in
two ways:  selecting its button in the Layers toolbar, or by double-clicking its icon in the Main View
of the Workspace Bar.

The Layer Table appears in the following format, with columns for Layer Number, Name, Type,
Draw Color, Flash Color, On, Lock and Delete.

• Layer Number:  Displays Layer Numbers. Each layer is assigned a number in the order it was
originally added. The order of this list cannot be modified, although the order in which the
layers are drawn can be—see View Layer Order below.
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• Name:  Displays the Layer Name. Simply clicking your mouse upon any existing layer name will
allow you to rename it.

• Type:  Indicates the Layer Type, if any. Some CAMtastic!® 2000 Designers’ Edition functions
require a Type to be assigned first—for example, Pad Removal requires at least one layer to be
assigned as Internal. Clicking in this field will display a pull-down list, from which you may
choose Top, Bottom, Internal, Neg Plane, Pos Plane, Drill Top, Drill Bot, Drill Int, Silk Top, Silk
Bot, Mask Top, Mask Bot, Paste Top, Paste Bot, Rout/Mill, Insulator, Refdes Top, Refdes Bot,
Temporary, Border, Dark Image, Clear Image, or nothing at all.

• Draw Color:  Shows the layer used for all draws on a particular layer. Clicking on any color will
display CAMtastic!® 2000 Designers’ Edition’s standard 14-color palette from which a new
choice can be made.

• Flash Color:  Shows the layer used for all flashes on a particular layer. Colors may be modified
in the same manner described above for the Draw Color column.

• ON:  Selected boxes indicate which layers are currently displayed.

• Lock:  If selected, the corresponding layer will be locked. A locked layer cannot be drawn to or
edited.

• Delete:  If this is selected, the corresponding layer will be deleted when either the Apply or
OK buttons is selected.

As indicated in the Layer Table’s title bar, right-clicking in the header of any of the last three
columns will toggle between selecting and deselecting all of the boxes below.

Selecting Apply will execute all changes without closing the dialog. This is a time saver when you
have multiple functions to apply to different layers. Choosing View Layer Order will open a dialog
allowing you to change the drawing order of the layers.

Selecting Draw Current Layer Last will change the system default for this value. The corresponding
box in the General Preferences dialog will be updated automatically.
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Drawing Modes
Besides the Layer Pull-Down, the Coordinate toolbar also contains a Drawing Modes toolbar button
and shortcut pull-down menus for different units and snap modes. Units may be set to inches or
millimeters. Many different options are available in the Snap Mode Pull-Down menu, shown below.

If the snap mode is off, then the cursor location will be the point location for drawing functions. If
any other mode is set, then a target marker ( ) will appear as the cursor approaches relevant
locations. Clicking while the target is displayed will use the target location, rather than the true
cursor location, as the point selection.

• Off:  Lets the cursor move freely around the Design Window.

• Grid:  Snaps the cursor to the currently defined grid-points.

• Auto (Center + End):  Snaps to the ends of lines, or to the true center of any arc’s circle.

• Center:  Snaps to the center of any flash.

• CenterLine:  Snaps along the center of a draw (disregarding its width.)

• Edge:  Snaps to an outside edge of a draw’s width.

• End:  Displays a target symbol over the end point of a line when the cursor nears it.

• Intersection:  Snaps to the intersection of two draws (lines or arcs). They need not have the
same width or even be on the same layer.

• Mid:  Snaps to the mid-point of any line or arc.

• Object-Center:  Snaps to the calculated center of an arc or polyline. Think of this as a center of
gravity for the object—the object center of an arc, for instance, will not be the center of the
projected circle, but will depend upon the amount of arc actually displayed.

• Quadrant:  Snaps to the North, South, East, or West point on an arc (or circle). The center point
of the arc’s width is the precise snap location.
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• Text-Insert:  Snaps to the insertion point of any existing Text. In CAMtastic!® 2000 Designers’
Edition, text is not necessarily anything you can read—if a text has been composed of lines or
exploded into polylines, then no snap point will appear.

The Drawing Modes button brings up the Drawing Modes dialog, shown below.

A dot grid is displayed at certain zoom levels in CAMtastic!® 2000 Designers’ Edition if the ON box is
selected. The size and spacing of the grid can be chosen from the Size pull-down menu or typed in
manually. Ortho mode helps you draw, edit, or measure at 90 degree increments. Blip mode causes
a reference plus sign (+) to appear at points that are entered when no drawing or editing function is
active. These reference points are temporary and will disappear when the image is refreshed.

The pull-down list of snap modes is also available in this dialog, as is the option to toggle between
the imperial and metric systems. Finally, the default direction of arcs is defined in this dialog.
Remember that regardless of the default, the direction of arcs can be changed individually as they
are drawn.

Tool Table
This table contains all drill, mill and route tools used. If you have indicated drills or any
routing/milling on the board, then this table will be updated automatically to describe all necessary
tools for drilling, routing and milling (see the Advanced Editing section of Chapter 5: Editing Tools
for details). Otherwise it will remain empty unless you enter tool sizes manually. Dcodes
(beginning at the first available code after 499) will be assigned to each tool.

The Tool Table may be opened from the Main View of the Workspace Bar.
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• Number (#):  Tool numbers (1-99)

• Size:  Drill diameter

• Comp.:  Cutter compensation

• Feed:  Infeed rate

• Speed:  Spindle speed

• Z-Axis:  Depth offset

• Plated:  Plated or unplated bit (selected or not selected)

• Ref. Dcode:  Existing Dcode used for display of route path

• Comments:  Reference notes

Tool files may be created or imported also, but there is little leeway in the format of this file. Below
are the crucial components of a Mill/Rout Table Settings file, which must be saved in ASCII format.

[any text line]

Ver=2

[any text line]

Tool=1,[Size],[Comp.],[Feed],[Speed],[Z-Axis],[Tab],[Dcode],[Plated],[Comments]

Tool=2, etc.

If any of these values is unknown or non-essential, a zero should be entered in its field (except for
Comment, which should be left blank). Unplated is indicated by a 0; plated is indicated by a 1.

The Ref. Dcode does not create a Dcode, it simply allows assignments from its pull-down list. So if a
particular Dcode has not been assigned in your Aperture table, then this Ref. Dcode box will
remain blank, even if its number is contained in the .mts file.
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CHAPTER 4

Non-Editing Tools

Many users are interested in viewing imported files to read and verify their contents. CAMtastic!®

2000 Designers’ Edition offers a variety of tools for viewing and inspecting files. Several types of
reports can be generated from these files.

Viewing Tools
The most commonly used viewing tools (zooming and panning) are covered in the Workspace
Management section of Chapter 3: Basics. In addition, CAMtastic!® 2000 Designers’ Edition offers a
variety of alternative viewing options. Anything you print will reflect the active view.

Fill Toggle
An outline sketch of your image can be seen by selecting View » Fill. By default, the Fill Toggle is
active, meaning that trace widths, flashes and polygons are all filled in. When disabled, this feature
will display all flashes and polygons as outlines and traces as 0-width lines. Custom apertures are
not affected by this command.

Negative Toggle
A negative of your image may be displayed by selecting View » Negative. When enabled, this
feature displays the current Image using the opposite field. While the standard view consists of a
normal background and colored images, the negative view will show a colored background with
clear images.

Translucent Toggle
This feature displays objects with a transparent effect, allowing you to see objects partially or
entirely overlapped by others. It may be activated by selecting View » Translucent. While powerful
and useful, this feature opens you up to certain hazards. Stacked objects are sometimes displayed
in white—a color otherwise seen only in selections. This can be confusing when making selections,
as some overlapping objects may appear to be selected when they are not. In addition, the editing
redraw speed is faster when the translucent view is not enabled.
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Difference
Layers may be compared with CAMtastic!® 2000 Designers’ Edition showing only their differences.
Simply enable the layers you wish to display, then choose View » Difference. Only elements that
are not precisely the same on at least one other layer will appear.

Highlight Dcode
All instances of a particular Dcode may be highlighted together. First verify that the current Dcode
(the one displayed above the Dcode pull-down list) is the one you want to highlight. If it is not,
choose another, then select View » Highlight Dcode. This feature is for viewing only, and will not
be available if an editing or drawing function is active.

While the Highlight Dcode displays the apertures as if they were selected, this is not a true
selection, as no editing feature can be enabled during use. To edit these items together, activate
the editing function, select the Filter button from the Select toolbar, type the Dcode number(s) in
the top field, and choose OK. Then drag a selection window across the desired area.

Film Box
The film box is a rectangle used as a visible reference, usually for placement of objects before
export to Gerber. If a film box has been previously defined, then selecting View » View Film Box
will display it.

A film box may be defined or modified by selecting View » Film Box, which opens the dialog shown
below.

A pull-down list of previously defined film boxes is available. A new film box may be defined by
typing in a Box Name and defining its measurements and relationship to the origin. Select Display
Film Box at StartUP if you want this box to appear at the beginning of your next CAMtastic!® 2000
Designers’ Edition session.

While the Box Size must be greater than zero and no more than 65 inches, the dimensions of the
Lower Left Corner may be positive or negative.
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Extent Box
The Design Window fills the screen, but not all of this screen is necessarily accessible by the user.
CAMtastic!® 2000 Designers’ Edition allows 65 by 65 inches for design work—this area is called the
Extents Box. This area may be displayed by selecting View » Extents Box. If you cannot see the
entire Extents Box at your current view, zoom out until the dashed line is entirely visible. You'll
notice that the X:Y Coordinate Box (on the far left side of the Status Bar) reports the cursor's
location as "Out of Limits!" for any movement outside of the Extent Box.

Origin
The origin is usually invisible, but the X and Y axis may be displayed by selecting View » Origin.
This origin automatically resides at some point within the 65 by 65 inch Extent Box area. Its default
location may be indicated in the General Preferences (see the Preferences section of Chapter 6:
Reference Tools for details). However, the origin may be changed on an individual basis by
choosing Bonus » Set Origin then choosing the new location. The numbers shown in the X:Y
Coordinate Box (on the left side of the Status Bar) will reference the new origin.

The lower left corner of imported files will be placed at the origin, so you may get an import error if
your origin is too close to the upper right limits of the Extent Box area. You will be asked if the
origin can be adjusted to fit the document inside.

Redraw
The Design Window will be periodically refreshed, usually upon the execution of a function within
CAMtastic!® 2000 Designers’ Edition. However, the screen may be automatically refreshed at any
time by selecting View » Redraw. All enabled layers are redrawn in the viewing order established
within the Layer Table (see the Building Blocks section of Chapter 3: Basics for details).
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Inspection Tools
CAMtastic!® 2000 Designers’ Edition makes it easy to measure distances and perform queries on
single or multiple objects. If enough information is provided, it can also run design rule checks and
generate netlists.

Measurements
Distances between points are calculated by selecting Inspect » Measure: Point to Point. Indicate
the first point, then the second. The Info View of the Workspace Bar is automatically brought into
focus, reporting the distance, angle, coordinates of each point, and the X and Y displacements of
the line.

For precise measurements, point coordinates may be entered manually in the X:Y Coordinate Box
(left side of the Status Bar). Pressing Enter is the same as left-clicking on a point with the mouse.

If you are interested in measuring the distance between objects rather than points, select Inspect »
Measure: Object to Object. The results are once again displayed in the Info View of the Workspace
Bar.

The actual selection of Point 1 and Point 2 when measuring between objects will depend upon the
snap mode selected before the Measurement feature is activated.

Queries
Objects (flashes or draws) may be queried for information.

Selecting Inspect » Query will turn the cursor into a pointing finger, ready for object selection. One
object may be selected at a time in this mode. A list is generated displaying the object’s Dcode,
Layer Type, Layer name and number, Length, Net (if already extracted), Shape, Size, Type, and
closest Vertex. As with measurements, this information appears in the Info View of the Workspace
Bar, which is automatically brought into focus.

A group of items may be queried together with an associated function. Selecting Inspect » Query
Group will turn the cursor into a pickbox, which will allow selections in the standard format:  single
picking or selection windows (see the Workspace Management section of Chapter 3: Basics for
details). A tally of selected objects will appear in the Total box (right end of the Status Bar), and
right-clicking in the Design Window will generate the query list.

This information is again displayed in the Info View of the Workspace Bar, but each individual
query is contained within an object folder, as shown in the example below.
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Double-clicking on an open object folder will close it.

An additional query function is available for nets if the Netlist Extraction process has already been
performed on the image. Selecting Inspect » Query Net will turn the cursor into a pointing finger,
and clicking on any object will highlight its entire net and display net information in the Workspace
Bar. This query displays the net number assigned by CAMtastic!® 2000 Designers’ Edition, and its
length and layer information (name, number and type).

Querying one net after another will not refresh the screen, meaning that a first net will remain
highlighted after a second net is selected. Redrawing the screen after a new net is selected will
display the image with only that net highlighted.

Netlist Extraction
This function generates netlist information from displayed images, such as Gerber data. A single
net is assigned for all connected images on each layer. Selecting Inspect » Netlist Extraction will
generate this list of nets and display them in the Netlist View of the Workspace Bar, as shown
below.
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Before running this process, make sure that you have defined the following applicable layer types
in the Layer Table:  Top; Bottom; Drill Top; Neg Plane; and Pos Plane.

Clicking on any folder will highlight that net and zoom into it in the Design Window. This list may
be refreshed at any time by selecting Inspect » View Nets (in Workspace Bar), and any new objects
will be assigned nets of their own. Once generated, the netlist may be exported according to
descriptions in the Session Management section of Chapter 3: Basics.

Design Rule Check (DRC)
Several tools help you check your designs in CAMtastic!® 2000 Designers’ Edition for any violations
under the rules that you define. Selecting Inspect » DRC/DFM Check will convert the cursor into a
pickbox, ready to select single objects or drag selection windows across the screen. A single right
click in the Design Window will open the dialog shown below.
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The main portion of the window describes size and clearance constraints for objects and layers.
Modify the minimum clearance (either in mils or millimeters, depending on the current settings) to
the right of each field name or disable the field altogether by clicking on the name itself.

The DRC can check for annular rings on the pad layer even if a pad layer has not been created.
Simply substitute it with a component or solder trace layer and CAMtastic!® 2000 Designers’ Edition
will create its own pad layer using the flashes from the substituted layer.

The DFM (Design For Manufacturing) Checks include additional options as shown below. Simply
select any of these options to add it to or remove it from the list of checks.

The File menu option within this same dialog will allow you to open or save box settings. Select OK
to begin the check. You will be informed if no violations were detected; otherwise a DRC Summary
of Violations appears on the screen. The Error View of the Workspace Bar is now made available
with a folder for each category containing errors and a subfolder for each individual error.

A reference layer named DrcError is automatically created (placing a diamond upon each error
location), and selecting any individual error subfolder in the Workspace Bar will jump to and
highlight the error marker for that violation. A detailed DRC report (named DrcReport.txt) is
automatically saved in the same folder as the CAMtastic!® 2000 Designers’ Edition session, listing the
number of violations for each check, the X & Y locations for each specific violation, and the total
number of violations.

This list of violations shown in the Error View of the Workspace Bar may be viewed at any time by
selecting Inspect » View Errors (in Workspace Bar), but this will not recheck the design for
additional violations. To use this feature, you must already have run a DRC on the board, otherwise
you will receive a message that the DrcError layer was not found.
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An additional check for invalid polygons is available. Polygons are continuous outlined boundaries
that are Raster filled. Raster-filled boundaries cannot support overlapping or multiple shared
vertices. If your design contains invalid polygons are present on your design, the data you export
can cause you machine to crash or give unwanted results. To search for invalid polygons, select
Inspect » Invalid Polygon Check. If an invalid polygon is located you will receive a message:  #
Invalid Polygons Found. The Invalid Polygons will be highlighted and assigned to an empty
Dcode.

Copper Area Calculation
The Copper Area of any selected objects can be calculated in CAMtastic!® 2000 Designers’ Edition.

Selecting Inspect » Copper Area Calculation will change the cursor to a selection pickbox. Follow
the general selection procedure to determine which portions of your board should undergo this
calculation. A single right click in the Design Window will begin the calculation for all enabled
layers. A report file (Copper.txt) is created and displayed, showing the amount of copper used on
each layer. The total copper area is also indicated.



Reports Chapter 4: Non-Editing Tools

CAMtastic! ® 2000 Designers’ Edition User’s Guide 53

Reports
Reports may be generated at any time from active sessions. In the Main View of the Workspace Bar
a Reports folder may be opened to show the nine options shown in the figure below. Each will be
described in this section.

All reports are saved in ASCII format and placed in the last folder that was opened in CAMtastic!®

2000 Designers’ Edition. If you are generating a report from a session that has not yet been saved,
its location may vary. In this case, you should check the folders CAMtastic!® 2000 Designers’ Edition
has used most recently. Of course, you may simply use the Save As feature in the text editor and
give any report a name and location of your own choosing.

Some reports will take their names from the active session, while others receive a generic name. In
the latter cases, a file location will be the only clue as to its source.

No warning is offered if a new report is about to replace an old one. This can be a problem for
users who have multiple CAMtastic!® 2000 Designers’ Edition sessions saved in the same folder.
Since some reports will have the same name (drill.rpt, for instance) regardless of which session
is used to create them, we recommend you rename these files if you have multiple .cam files saved
the same folder.

Apertures
Choosing the Apertures Report will create a text file from your current Aperture Table and display
it. As shown in the example displayed below, this file will include header information, default
settings, and a list of defined Dcodes with their associated apertures.
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This file is saved with an .lst extension and may be accessed in CAMtastic!® 2000 Designers’
Edition by selecting File » Import » Aperture File (see the Session Management section of Chapter 3:
Basics for details).

Custom Aperture Library
The details of all custom shapes in the current session’s Aperture Table are documented in this
report file.

This file is saved with a .lib extension and may be accessed in CAMtastic!® 2000 Designers’ Edition
by selecting File » Import » Custom Aperture Library File (see the Session Management section of
Chapter 3: Basics for details).
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Dcode/Layer
Selecting this report brings up a dialog in which the scope of the report may be narrowed.

A pull-down list allows you to select ALL Layers, ON Layers, or any individual layer names. (ON
Layers, of course, refers to those layers currently enabled in the Design Window.) The rest of this
dialog shows the ensuing information that will be written to the report file if the Save button is
selected. The top half of the report shows the Dcode number, shape, and size for each aperture,
then the number of times it is flashed and the number of times it is drawn in the selection. The
lower half of the report arranges information by layers, starting with the total, and descending into
each individual layer. The extents of each layer are reported, as are its total number of flashes and
the total number of draws. If saved, this information is written to a file named Report.txt which
will include the information shown above, as well as some brief header information (session file
name, time, date, etc.).

DRC/DFM Errors
If a DRC/DFM check has been run in the current session, a report named DrcReport.txt has
already been generated (see the Inspection section of Chapter 4: Non-Editing Tools for details).
Selecting this report in the Main View of the Workspace Bar will simply reopen this report for you.

No error report will be generated if no errors were detected in your design.
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Drill
A text file named Drill.RPT will describe all drills that have been made on the board. Each drill
will be reported by its tool number and size described in the Tool Table (see the Building Blocks
section of Chapter 3: Basics for details), and the number of instances it is used in the image.

This report will show all drill points, whether or not their respective layers are displayed.

PCB Sales Quote
CAMtastic!® 2000 Designers’ Edition will generate a report to send to prospective PCB fabrication
and assembly shops for issuing quotations. This keeps your design work confidential, laying out
only the information a shop will need to estimate a production cost, such as dimensions (trace
width, gap spacing) and total pads and vias.
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Selecting the PCB Sales quote will immediately open the dialog shown above. At least one route
layer must be assigned before building a PCB report (see the Building Blocks section of Chapter 3:
Basics for details about the Layer Table).

• Select PCB Border:  Returns you to the main screen where your cursor has changed to a
pickbox, ready to select the border. You may click directly on each trace of the border or drag
a selection box across it. A single right click will return you to the PCB Sales Quote dialog with
the Horizontal and Vertical data completed. If you have made a mistake in your selection,
simply choose the Select button again and start over.

• Select Minimum Trace/Gap:  Returns you to the main image in the same manner as the PCB
border selection (above). Here you will either choose the smallest trace on the board or drag a
selection window across any portion of your design. We recommend that you drag a selection
window across the entire PCB image to ensure that the smallest Trace/Gap and Dcode in use
will be considered in the PCB report.

• Options:  Opens the dialog shown below.

CAMtastic!® 2000 Designers’ Edition offers over 30 fields that fabrication houses may

consider when generating quotations. Simply deselect any field that will not affect the price of
fabrication for your particular project, and that feature will not be included in the final report.

After selecting the options you wish to include, simply choose the Report Units and Panel Size,
then select OK to return to the previous dialog.
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Once the border has been selected, the minimum trace/gap and Dcode have been defined, and all
other options have been specified, select OK in the PCB Sales Quote dialog. Immediately a text file
named PcbReport.txt will be written to your hard drive and opened for viewing. This file will
contain the CAMtastic!® 2000 Designers’ Edition session name, date, time, units, and any fields you
have selected in the PCB Report Options dialog.

This report may also include additional comments, such as Paste Layer(s) Not Detected.

Rout/Mill
A text file named Rout.RPT will be written describing all defined rout/mill paths on the board. See
the Advanced Editing section of Chapter 5: Editing Tools for details on creating these paths.

This file will contain tool numbers and sizes as indicated in the Tool Table, then the number of
routing paths for that tool. The total routing/milling distance covered by each tool is indicated last.

As with the Drill Report, this file will describe all routing paths, whether or not their respective
layers are displayed.
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Status
The Status Report, unlike other reports, is not written to a text file, but simply displays a dialog
showing session and system information.

This report can warn you when you are nearing the limits of available resources.

X/Y Coordinate List
Double-clicking on this function will not generate a report immediately, but instead waits for you
to select the portions of the design to analyze. Upon right-clicking when the selection is finished, a
file named xylist.rpt will be automatically generated.

The coordinates here described are not the same coordinates shown in the Design Window, but
rather relative coordinates to an origin placed near the center of the selection extents.
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CHAPTER 5

Editing Tools

The instructions in this chapter are of an introductory manner, and will describe processes in terms
of menu options and mouse clicks. For precision editing, bear in mind that the X:Y Coordinate Box
in the Status Bar can replace the use of the mouse for any point locations. Additionally, the General
Preferences dialog offers the ability to Auto Repeat Functions, which will save time when several
similar edits must be performed (see the Preferences section of Chapter 6: Reference Tools for
details).

Basic Concepts
Most of the tools for modifying (rather than simply viewing) CAMtastic!® 2000 Designers’ Edition
sessions are found under the Draw and Edit menu options. A few concepts apply throughout these
features and should be touched upon here.

• Undo/Redo:  Selecting Edit » Undo negates the last Drawing or Editing function. You may only
undo one step. Similarly, you may change your mind about an undo you performed, and redo
it (Edit » Redo) as long as no subsequent edits have been made.

• Step & Repeat:  CAD files have a tendency to inflate in size, causing difficulties when hard disk
space is limited. Certain features such as panelization and data arrays will allow a Step & Repeat
function, which uses a loop code rather than rewriting identical sequences in the saved file. If
these codes are used in a session, any Gerber or NC Drill/Mill output files will use them also,
offering improved performance for photoplotters and NC drilling or milling machines. If you
have used a Step & Repeat in your file, but later wish to make individual modifications, you
may select Bonus » Step/Repeat and choose either Modify or Explode.

• Closure:  Several features will require lines to be closed, but this means more than simply
having lines meet or cross. Only polylines and polygons can be automatically closed in
CAMtastic!® 2000 Designers’ Edition. Other lines, however, may be closed manually; see the
Join heading in the Edit section of this chapter for details.
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Drawing
Any drawing tools will use the current Dcode as the point of its pen. The current Dcode is
displayed in the Dcode pull-down menu on the Coordinate toolbar, and may be changed by simply
selecting another aperture from this pull-down menu.

Flash
A single placement of any aperture is called a flash. You may place a flash anywhere in the
workspace by choosing Draw » Flash. Then click upon the desired location—or for more precise
placement, type the coordinates in the X:Y Coordinate Box and press Enter.

Line
If you simply need to draw straight lines, you may use the Draw » Line feature. Line closure is only
available with the Draw » Polyline feature.

To draw straight lines, select Draw » Line, then choose the starting point. Another point selection
will set down the next vertex, and so on until your sequence of straight lines is complete. Right-
clicking (or pressing Esc) will end the line.

One advantage that the standard line feature has over the polyline is the ability to change Dcode
and/or Layer mid-line.

To draw lines that need to be closed or that will contain arcs, click on Draw » Polyline. This feature
behaves identically to standard lines until the right mouse button is clicked. Instead of
automatically ending the line, right-clicking in Polyline mode will offer a drop down list of options,
shown below.

• End:  Ends the line without closing it.

• Close:  Draws a final line from the last vertex to the original vertex, closes it, and ends it.

• Line:  Toggles from arc mode to straight line mode.
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• Arc:  Toggles from straight line mode to arc mode.

• Clockwise:  Draws arc from previous vertex in a clockwise direction.

• C-Clockwise:  Draws arc from previous vertex in a counter-clockwise direction.

• Undo:  Negates previous vertex.

• Snap:  Enables or Disables the Snap mode during polyline draw.

• Cancel:  Negates all vertices placed during this polyline function. Lines will disappear when
screen is redrawn.

Any polyline may be broken into its component lines, and any continuous line may be converted
into a single polyline. See Explode » Polylines and Join » Single in the Basic Editing section of this
chapter for details.

If you need to draw a series of lines, selecting Line or Polyline from the main menu may become
tedious. After a line is ended, you may right click in the Design Window and choose Repeat, which
will restart the previous drawing or editing function.

Rectangle
Selecting Draw » Rectangle will allow you to select two corners. Simply click on one corner and
then on the opposite corner—the rectangle will be drawn on the active layer with the current
Dcode.

Arc
Arcs may be drawn as a part of a polyline (see above) or they may be drawn individually. Several
different methods of drawing arcs are available to suit your different needs and preferences. An arc
that is drawn with any portion outside the Extent Box is ignored by CAMtastic!® 2000 Designers’
Edition and will disappear upon the next redraw.

The following options are available in the Draw » Arc submenu:

Center, Start, Sweep Angle:  Accepts center and start point, then asks you to enter the sweep angle
degrees (positive values will sweep counter-clockwise, negative values will sweep clockwise).

Center, Start, End*:  Accepts center, start, and end points, respectively.

2-Points*:  Draws a 90-degree arc between any two points.

3-Points (Start, End, Tangent):  Accepts start and end points, then displays the potential arc
between them as you move the mouse. Left click or press Enter when you see the arc you wish to
draw. This function is also available on the Draw Toolbar.

Tangent, Tangent, Radius:  Allows you to select two non-parallel lines, then indicate the radius. An
arc will be drawn between the lines, convex with respect to their intersection. If polylines are to
use this feature, only adjacent straight lines from the same polyline are eligible tangents. Otherwise
you must explode the polyline before drawing the arc.
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* These methods of drawing arcs will determine the arc direction from the Drawing Modes dialog
(see the Building Blocks section of Chapter 3: Basics for details).

Remember that the relevant points of any arc may be defined precisely by entering the consecutive
points in the X:Y Coordinate Box, then pressing Enter. The Snap Grid may also aid you in defining
your points with precision.

Circle
As with arcs, a variety of methods is available for drawing circles. The current Dcode and Layer are
used for all methods.

Selecting Draw » Circle reveals the following options:

Center, Tangent Point:  Accepts a center point then a perimeter point. This function is also
available on the Draw Toolbar.

Center, Radius: Accepts a center point, then prompts you to type in a radius.

Tangent, Tangent, Radius:  Allows you to select two non-parallel lines, then indicate the radius. If
polylines are to use this feature, only adjacent straight lines from the same polyline are eligible
tangents. Otherwise you must explode the polyline before drawing the circle.

2-Points:  Accepts any two perimeter points defining diameter.

3-Points:  Accepts three perimeter points. These points must not lie along the same plane.

Ellipse
Selecting Draw » Ellipse will wait for you to indicate two opposite corners of the reference
rectangle which will bound the ellipse. After the first corner is located, the screen will display the
potential ellipse as you move the mouse. When you see the ellipse you want, click once or press
Enter to draw the ellipse.

Polygon
A polygon is a raster-filled boundary that requires an outline to be made of straight lines. It must
have three or more distinct vertices. Selecting Draw » Polygon will allow you to select a starting
point, and then all sequential points until you are ready to end the polygon. Right-clicking once will
fill the polygon.

In contrast, a Polygon Void is an area that will be emptied of any draws or flashes. Otherwise it
behaves exactly as a polygon. Selecting Draw » Polygon Void will allow you to select a starting
point, then all sequential points until you are ready to end the polygon void. Right-clicking once
will empty the boundary.

Text
Both single stroke and TrueType text fonts are available in CAMtastic!® 2000 Designers’ Edition.
Selecting Draw » Text will let you indicate the point of placement in the Design Window. A Draw
Text dialog will then appear as shown below.
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By default, the Use Standard (rather than the Use TrueType) option is selected when you open the
Draw Text dialog. In this case, the Select button will allow you to browse to the AutoCAD
Text/Shape file (*.shx) you plan to use.

• Mirror:  Mirrors the entire text paragraph, if enabled.

• Italic:  Makes the entire text paragraph italic, if enabled.

• Justification Pull-down:  Controls the character placement within your selected paragraph
rectangle. Justification options include Top-Left, Top-Center, Top-Right, Middle-Left, Middle-
Center, Middle-Right, Bottom-Left, Bottom-Center, Bottom-Right.

• Height:  Accepts the height to be used for the text message.

• Rotate:  Accepts the rotation value for the text.

• X Scale:  Determines the length scaling for the text.

• Message:  Accepts the character string information that will be used.

• Import Text:  Allows you to browse to any existing text document. Its contents will be
imported automatically into the Message window.

If you have selected Use TrueType (instead of Use Standard) in the Font section, then the Select
button will display a Font dialog. There you will be able to choose from a list of TrueType fonts and
any associated Scripts. You may also indicate a custom font size.

Three additional fields become available when the Use TrueType option is selected:
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• Bold:  Makes the entire text paragraph bold.

• Fill Font:  Fills every character using raster fill.

• Quality:  Controls the font quality.

As with all other drawing features, the current Dcode and Layer will be used for Text.

Dimension
Dimensions can be placed vertically or horizontally in CAMtastic!® 2000 Designers’ Edition. Before
any dimensions are drawn, however, you should verify all the settings for fonts, accuracy, and
spacing. Selecting Draw » Settings will display the dialog shown below.

• Font:  Allows you to browse to a font file. CAMtastic!® 2000 Designers’ Edition will automatically
look for AutoCAD Text/Shape files (*.shx).

• Mirror:  Mirrors the dimension text.

• Bold:  Makes the dimension text bold.

• Italic:  Italicizes the dimension text italic.

• Upside Down:  Flips the dimension text upside down.

• Fill Font:  Fills every dimension text character using raster fill.

• Height:  Assigns the height to be used for the dimension text message.
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• X Scale:  Determines the length scaling for the dimension text.

• Quality:  Controls the font quality of the dimension text.

• Accuracy:  The decimal places of accuracy for dimension text. This number is also displayed
beside the dimension’s end point.

Once all values are set to your satisfaction, select Draw » Dimension to place a dimension on your
image. The following submenu will appear:

• Ordinate:  Creates a dimension describing the appropriate X or Y coordinate. (A horizontal
dimension will display the Y-axis value; a vertical dimension will display the X-axis value.)

• Horizontal:  Creates a dimension displaying the horizontal distance between two extension
points. Enter both endpoints, then a third somewhere between them where you want the
measurement to display.

• Vertical:  Creates a dimension displaying the vertical distance between two extension points.
Enter both endpoints, then a third somewhere between them where you want the
measurement to display.

• Radius:  Creates a dimension displaying the radius of any arc. Select a point on the arc then
another point away from it to draw the leader. Right-clicking will end the line and draw the
dimension.
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Basic Editing

Array
Selected objects may be copied along the X-axis, the Y-axis, or both.

Access this feature by choosing Edit » Array. The cursor is converted to a pickbox, ready to select
single objects or areas. When everything you wish to array is selected, right click once. This will
open the dialog shown below.

Two methods of spacing are available:  Distance and Gap. If Distance is selected, then the enabled
fields will include the Number of Columns and Rows, and the X and Y Distance. These distances
will equal the amount of shift along the X and Y axes you wish the selected objects to appear for
each copy.

If the Gap spacing method is chosen, the Distance fields become disabled, while the Image Size
and Gap for the columns and rows become enabled. The gap indicates how far between images.
The image size reports the extents (X and Y) of the selected area, but it may be modified to provide
an additional gap or boundary around the selected image.

Images may overlap by entering a negative value for the X or Y gap, or if the sum of the Gap and
modified Image Size is lower than the original Image Size.
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In all cases, the units depend on the system—imperial or metric—that has been selected in the
Drawing Mode dialog (see the Building Blocks section of Chapter 3: Basics for details).

Step & Repeat Codes are also available in this function, which can greatly reduce the file size and
improve performance (see the Basic Concepts section of this chapter for additional details).

Selecting Preview will sketch a block outline of the image size spread across the indicated rows and
columns. This will give you an idea of how accurately you have chosen the Distance or Gap values.

Break
Any straight trace may be separated into two individual segments by selecting Edit » Break. Click on
any and all points where you wish to segment traces; right click when done.

Chamfer
Two adjoining trace edges may be bevelled by selecting Edit » Chamfer. A dialog lets you enter the
X and Y distances from the intersection that the new connecting line should be drawn. Separate
these distances with a colon, then choose OK. The cursor will become a selection pickbox; click on
the first then the second line. The chamfer distance may not exceed the extents of the selected
lines.

Copy
Objects may be copied and placed either once or multiple times in the same CAMtastic!® 2000
Designers’ Edition session. Choosing Edit » Copy » Single will change the cursor to a selection
pickbox. Select items singly or drag the cursor across an area until your selection is complete (see
the Workspace Management section of Chapter 3: Basics for details on selecting objects). Right
click to end selection mode, then left click once to determine the reference point. Moving the
mouse will now pivot a frame of the selection extents around the reference point. A final left click
will place the copied selection.

The image may be panned at any time using the arrow keys without disrupting the sequence of
clicks in this process.

Selecting Edit » Copy » Multiple will allow you to place the same copied selection multiple times.
This feature works exactly like the Copy Single mode, except that placing the selection does not
end the process. The selection will remain on the cursor, ready for additional placements until the
right mouse button is clicked.

In either of these copying modes, a single selection may contain objects from several different
layers—but each selected object will always be copied onto its same layer.

If you are trying to copy items or groups onto a separate layer, you should select Edit » Copy to
Layers. The cursor changes to a selection pickbox; use any necessary selection strategies until
selection is complete. Right-clicking will open the Select Layers dialog, shown below.
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All existing layers are shown, and may be selected individually with single mouse clicks or as a
group by choosing All. The entire selection will be merged onto each selected layer.

Erase
To delete objects from a CAMtastic!® 2000 Designers’ Edition image, select Edit » Erase. This will
activate selection mode, highlighting each object as it becomes selected. If any objects are
inadvertently selected, you may remove items from the selection using the Select toolbar, or cancel
the whole process by pressing Esc. Right click when finished, and refresh the screen, if necessary,
to see the modified image.

To delete a single segment of a polyline, use either the Break or Explode Polyline feature first, then
the Erase feature.

Explode
Polylines, Text, and Custom Apertures are considered to be a single object in CAMtastic!® 2000
Designers’ Edition, even though they are composed of multiple draws or flashes. In some instances
you may need to ungroup or fracture these objects into their component parts. For example,
drawing arcs or circles between tangents will not work optimally until the polylines are exploded or
fractured into  their single-line components.

Selecting Edit » Explode shows the submenu of Polylines, Text, and Custom Apertures. The process
is the same for all of these features:  simply select the relevant objects, then right click to explode
them.

Exploding Text will separate the parts into component polylines. Exploding Polylines or Custom
Apertures will separate the parts into their most basic components (lines and/or flashes).

If any Step & Repeat codes have been applied within your session, these too may be exploded—
meaning that the space-saving codes are deleted, and the repeated data is written out every time it
appears. See the Advanced Editing section of this chapter for additional information.

Extend
A line may be extended to meet another. Selecting Edit » Extend changes the cursor to a pickbox.
Click first upon the target line, then upon the line you wish to extend. If extending the second line
will never intersect with the target, an error message will be displayed.
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Multi-edged polylines may be selected as the target, but not as the line you plan to extend. If you
must extend a portion of a multi-edged polyline, explode it first (see above) into its component
lines. Arcs cannot be extended.

Fillet
Any two adjacent lines may have their connecting edge rounded by selecting Edit » Fillet. A dialog
immediately asks the desired fillet radius.  The units of this value will depend on the current
settings in the Drawing Modes dialog (see the Building Blocks section of Chapter 3: Basics for
details). Choosing OK lets you choose two adjoining lines, the corner of which will be replaced
with an arc as specified.

The fillet radius should be chosen carefully, as the lines will be extended forward until the arc is
made to fit.

Join (and Fix Polylines)
Separate lines or polylines may be joined together. If two lines of equal width are touching, then
selecting Edit » Join » Single will let you join them together with a single click.

It is not enough, however, for the line ends to intersect—their ends must meet perfectly or very
closely. This may be done by setting the Snap grid to End and drawing a trace between the two
lines you wish to connect.

More options are available with the Edit » Join » Group feature. After selecting objects and/or areas
you wish to fix, right click to open the dialog shown below.

Tolerance:  Accepts a distance value (from either pull-down menu or keyboard). If two selected
ends are separated by a value greater than the tolerance you have set, they will remain open. If
their gap is less than the set tolerance, they will be closed (fixed).
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• Fuzzy Join Method:  Locates the nearest existing endpoint for use when the polyline is created.
The endpoint locations may be slightly altered depending on the tolerance that you supply, but
this alteration will never be more than the tolerance size that you assign.

• Intersection Join Method:  Automatically calculates the intersection point between two
neighboring objects for use as endpoint when the Polyline is created. This option can create
perfect boundaries from the original data.

• Display Open Boundary Markers:  Places error markers over each open end and draws them
on a new layer called Polyline PRO Open Markers. This layer is temporary and should not be
used to hold design information, as it will be erased and regenerated each time the Join »
Group feature is executed.

• Fill Closed Boundary(s):  Fills any polylines completely enclosed by boundaries.

Choosing OK will generate a report based on your settings and the selection you made previously.
An example is shown below.

If certain boundaries remain open, you may wish to repeat this function using a higher tolerance.

Mirror
Any group of items can be mirrored. Selecting Edit » Mirror will allow you to select all desired
items. Right click to end selection mode, then left click to place the mirror. Moving the mouse will
adjust the mirror plane (vertical or horizontal) and a final left click will execute the function. You
will be asked if you wish the original items to be deleted upon mirroring.

Modify/Change
Groups of items may be selected together and assigned a common Dcode or Layer. Selecting Edit »
Modify/Change will allow you to begin selections. Right click when finished. A dialog will then
appear as shown below.
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You may choose to change the shape and/or the layer for the selections. Leaving a field blank will
cause no changes to occur in that field.

If the Use Dcode box is selected, all selected objects are modified to a defined aperture chosen
from the pull-down list. If the Use Dcode box is not selected, you must choose from a pull-down
list of available shapes and assign a size.

The size must be entered in inches or mm, depending upon the system selected in the Drawing
Modes dialog (see the Building Blocks section of Chapter 3: Basics for details). This number may be
changed slightly once the aperture is calculated internally.

If you would like to move all selected objects to a new or existing layer, select the target layer from
the pull-down list.

If you choose New Layer a layer will be created and named by CAMtastic!® 2000 Designers’ Edition,
for example, Layer4. This layer may be renamed in the Workspace Bar or the Layer Table.

Move
Objects may be selected and moved within a CAMtastic!® 2000 Designers’ Edition image. Selecting
Edit » Move will put the cursor in selection mode, ready to pick individual objects or drag windows
over areas to be selected. Right click when selection is complete, then left click on a displacement
or pivot point. Moving the mouse now displays a frame around the extents of the selection; a single
left click will move the objects from their original placement to their new destination. All
components will remain on their original layers.

The image may be panned at any time using the arrow keys without disrupting the sequence of
clicks in this process.
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Offset
Any trace or arc may be offset (shadowed). If the trace is closed, then running this feature will
create an outline or internal border, depending on which side of the boundary you choose for the
offset to appear. Selecting Edit » Offset will prompt you for the offset distance (units will depend
upon your current Drawing Modes settings). Selection mode will be activated, but will only allow
pickbox (single object) selections. Once any trace is selected, you must click on one side of it. The
offset line(s) will be drawn on that side at the distance you have indicated.

You may cancel this function with a single right click or by pressing Esc.

Rotate
Single objects or groups may be rotated by selecting Edit » Rotate. The cursor is put in general
selection mode. Right click once when the selection is complete, then left click upon the pivot
point. You will be prompted to enter the rotation angle in degrees; a positive value will rotate the
selection counter-clockwise, and a negative value will rotate the selection clockwise.

The X:Y Coordinate Box and/or the Snap grid may help you choose the pivot point with precision.

Scale
Single objects or groups may be enlarged or reduced based on a selected base point and scale
factor that is uniform in both X & Y directions. Selecting Edit » Scale will put the cursor in general
selection mode. Right click when done, then left click upon the base point. The X:Y Coordinate Box
and/or the Snap grid may help you choose the base point with precision.

A dialog will appear asking you to enter the scale factor. The default is at 100%, which will cause no
change to the selection. A higher number will enlarge the selection, while a lower number will
shrink it. You will also be given the option to scale apertures. Only positive numbers will be
recognized in the scale factor field; an absolute value will taken from any negative entry.

Text
Existing text may be modified by selecting Edit » Text, then clicking on any individual text string.
The Draw Text dialog appears as shown earlier—see the Drawing section of this chapter for more
information on Text options.

If a text has been exploded into polylines or if the text was drawn in CAMtastic!® 2000 Designers’
Edition with placed lines rather than text, then it will not be eligible for modifications.

Vertexes
Vertexes may be added, deleted, or moved in CAMtastic!® 2000 Designers’ Edition. Any line or
polyline may have a vertex added (thus making it a polyline if it wasn’t one before), and any
polyline that contains more than two vertexes may have a vertex deleted or moved.

Adding a vertex to any straight line may be done by selecting Edit » Vertex » Add, then clicking on
the line you wish to modify. A flash of the same Dcode as the line you have chosen hovers over the
mouse, ready to mark the new vertex. Left click again to place it. The new polyline will be redrawn
automatically.
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Deleting a vertex from any polyline may be done by selecting Edit » Vertex » Delete then clicking
on the vertex you wish to delete. Clicking on any segment of a polyline will delete the oldest
vertex.

An existing vertex may be moved by selecting Edit » Vertex » Move. Click on any straight line within
an existing polyline. While the whole polyline will appear to be selected, a reference line will trail
from the nearest vertex. This is the vertex that will be moved—clicking the mouse on the new
location will move it.

The vertexes of arcs may not be moved.
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Advanced Editing
Many advanced editing tools are available in other menu choices. These are arranged in
alphabetical order and explained individually.

Align Layers
Entire layers may be shifted to match other layers. The easiest way to do this is if there is a matching
outline border or a target on both layers. Enable all layers that contain a matching border, then
select Bonus » Align Layers » Border (Auto-Detect). Click on the target border, then all layers with a
matching border will be automatically aligned to it. Any layers where no matching border is
detected will be left alone.

The selected border should be a straight edge of a closed boundary.

Layers may be aligned to one another individually. Multiple layers may be enabled together, but as
only two layers may be involved in this process at a time, we recommend that all other layers be
turned off. Select Bonus » Align Layers » Selective, then click on an object on the base (target) layer.
Now click on an object on the layer you wish to move. The selected entity should be common to
both layers (such as a PCB outline corner or target). If the selected objects do not match precisely,
then the point of selection on each layer is matched.

You may need to repeat either of these functions multiple times until the layers are aligned to your
satisfaction.

Assembly Utilities
CAMtastic!® 2000 Designers’ Edition allows you to build a parts list from the displayed image by
grouping identical footprints. These parts may be defined by selecting Tools » Assembly Utilities »
Create & Group Parts. This puts the cursor in general selection mode.

Grouped parts may not contain items from separate layers. Neither may they contain parts already
grouped.

Right-clicking will end the selection and open the dialog shown below.
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• Description:  Allows you to add or select a name that best describes the selected part.

• Rotation (Deg.):  Allows you to indicate the rotation of the selected part.

• Board Side:  Allows you to choose the Board Side for the selected part (choose Top, Thru, or
Bottom).

Choosing OK will search for matching groups, all of which will be redrawn as filled rectangles with
an X through the center. While searching, CAMtastic!® 2000 Designers’ Edition looks only on the
same layer and it only recognizes exact matches (shape, size, and rotation). Any additional items
may be added to this parts list manually by running the process again, selecting a new instance of
the part, and assigning it the same name. The rotation and board side information may also be
modified.

Any information you enter manually will not be verified by CAMtastic!® 2000 Designers’ Edition;
dissimilar selections may be assigned the same footprint name and/or rotation.

Reference Designators may be added to any successfully grouped parts. Selecting Tools » Assembly
Utilities » Assign Ref Designators will change the cursor to a pickbox and allow you to click on any
grouped part. A dialog will prompt you for the Reference Designator for this part. Once entered,
the new designator will appear in the center of the grouped part.

The second designator you place will automatically increment one the previous integer by one.
This will assist you in assigning designators to all instances of the same part.

If a group has already been assigned a reference designator, it is still eligible for a new assignment,
giving you the ability to revise your designations.

All parts grouped by CAMtastic!® 2000 Designers’ Edition’s Assembly Utility will be listed in the
Assembly Parts Table, including the following information:  Center Point; Part Description;
Reference Designators; Rotation; and Board Side. This table may be accessed in the Main View of
the Workspace Bar.
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Choosing Export List allows you to save any displayed information as a text file (Part Centroid File,
*.pcf).

These fields merely describe the image in the Design Window—modifying any of them will not
affect the image when the table is closed.  Any changes that are made within the Assembly Parts
Table will only apply to an Exported List. For example, if the Assembly Parts Table is modified,
closed, then reopened, it will again reflect the original settings.

Combining Layers
A new layer may be created containing the merged images of any group of existing layers. Selecting
Bonus » Merge Layers opens a dialog as shown below.

A list of all existing layers appears in this box, and a single click will highlight any layer. Clicking on
a highlighted layer will deselect it. Select all layers you wish to merge, type in a name for the New
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Layer, and choose OK. A new layer is created containing the merged layer information. The original
layers will not be deleted or modified.

The All button makes the Merge Layers function the fastest way to create a single layer out of all
existing layers.

Certain images can only be created in CAMtastic!® 2000 Designers’ Edition with Composite Layers.
Much more powerful than a simple merge, a composite layer allows you to add or subtract images
from one another (create voids inside filled areas, etc.). Furthermore, a composite layer can be
exploded back into its original layers, unlike the merge feature.

Composite layers may be created from selected items or built with selected layers. Selecting Bonus
» Composite Layers » Auto Create Composite will put the cursor in general selection mode. Right-
clicking to complete the selection will bring up the dialog shown below.

Choose either Positive (clear background, dark image) or Negative (dark background, clear image)
polarity for the composite. Choose OK when finished. A new layer is automatically created and
named based on the total number of existing layers (for example, if eight layers already exist, the
new layer will be called Layer9).

This new layer can be renamed in the Layers View of the Workspace Bar or in the Layer Table.

A composite layer may be built from existing layers by selecting Bonus »  Composite Layers » Build
Composite. A dialog will immediately appear, as shown below.
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• New Layer:  Accepts a new name for the composite layer.

• Composite Layer Polarity:  Toggles between Positive and Negative polarity. Choosing this
button will simply toggle all individual polarity settings.

• Select Layer(s):  Allows selection of existing layers from pull-down menu.

• Individual Layer Polarity:  Toggles between Dark and Clear for each layer image. If Dark (the
default value) is chosen, the entire layer will be added to the final composite merge. If Clear is
selected, all images on this layer will be subtracted from the composite.

• Spread (per side):  Enlarges or shrinks all apertures on layer. This offers the ability to enlarge &
reduce layers simultaneously—a very powerful aid in soldermask and copper pour generation.

The order in which the layers are selected is vitally important because that is the order in which
they will be compiled. For example, if you wish a small area to be voided from a larger polygon, it is
essential that the void’s layer is selected after the large polygon’s layer. This method is often called
paint and scratch merging, and proper layer sequencing puts the painting before the scratching.

Existing composite layers should not be used to build new ones.

Once you have created a composite layer, you may reopen the Composite Merge dialog to modify
its parameters. Simply select Bonus »  Composite Layers » Modify Composite. The cursor becomes
a pickbox upon which you may choose any area where the composite shows overlapping images.
The composite layer must be displayed for the pickbox to recognize it.

Once the composite layer is detected, the Composite Merge dialog reopens. The component
layers, however, have been given new names—instead of L1, L2, etc., you will see C1, C2, etc. These
layers may be removed (choose the blank space from the pull-down menu) and new layers may be
added. In fact, all of the original options from Build Composite are again available.

Should you need to disband a composite into its component layers, select Bonus » Composite
Layers » Explode Composite. Then click on an area where images are overlapping within the
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composite layer. Each composite layer (C1, C2, etc.) is instantly converted to a new layer. These
layers will be named Name-1, Name-2, etc. depending upon the name of your composite layer. The
Composite Layer itself is deleted. This action cannot be undone.

If you only wish to disconnect the internal layers of a composite temporarily, you should use the
Bonus » Composite Layers » Open Composite for Editing feature. This will behave like Explode
Composite, but once all layer-level edits have been finished, the layers may be reunited by
selecting Bonus » Composite Layers » Close Composite.

Composites are intended to overlay images to create designs that are not possible with single-layer
flashes and draws. To modify or explode a composite layer, you must click on an overlapping
area—which assumes that such areas exist. You may find it difficult or impossible to modify or
explode layers that are not true composites, but are simply merged layers without any overlapping
images.

Copper Pour
Any closed boundary may be filled with copper by selecting Tools » Copper Pour. In CAMtastic!®

2000 Designers’ Edition, closed means more than simply enclosed. The only boundaries that are
automatically closed are circles and rectangles. Polylines may or may not be closed, depending
upon how they were made (see Lines in the Drawing section, above). If a boundary is made up of
lines that have not been grouped together, you must join them into a single, closed polyline before
the copper pour will work within that boundary (see the Join Group heading in the Basic Editing
section, above).

Clicking on a closed boundary will open the Copper Pour dialog, shown below.

A clearance boundary may be added to the fill. This ensures (especially around arcs) that the pour
pattern is contained entirely within the image.

Only positive clearances are accepted. Any negative numbers, if entered, will have their negative
sign ignored.

The most recently used pattern is automatically offered each time this dialog is opened. Choosing
Edit Pattern opens the dialog shown below.
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If the Fill Type is set to Polygon (Raster), then all other settings in this dialog are disabled. The
boundary will be filled with a solid polygon with a clearance as indicated previously. Notice that a
new polygon Dcode will be added to your aperture list for this type of fill.  It will display in the
Dcode pull-down list as Poex, signifying it as a polygon shape.

If the Fill Type is set to Vector, then you may choose between using a solid image or a
Shape/Dcode. You may choose a shape and size or select Use Dcode to highlight an existing
aperture for the fill. If Solid is not selected from the Image area, then you may indicate the X and Y
spacing of the shape or Dcode.

While the Polygon (Raster) fill appears the same as the Vector (Solid), it will be defined by large
overlapping shapes rather than minute fills. This will generally keep the file size much smaller,
allowing faster redraws.

Draw Conversions
Various conversion techniques are available in CAMtastic!® 2000 Designers’ Edition.  These have
been designed for users who may need to send their images to older, less robust programs. Any
object or group of objects that is repeated identically in a design may be replaced with a single
aperture.

There are several different ways to do this. Selecting Bonus » Draw to Flash » Automatic lets you
assign all selected objects to flashes. Select the objects or define the area(s) you wish to convert to
flashes—remember that you may use the Filter button on the Select toolbar to narrow your
selection across the board.

Right-clicking will open the dialog shown below.
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If the Use Dcode box is not selected, then a shape of your choosing will be applied to all different
shapes—its size varying with the items it represents. Otherwise the same Dcode (chosen from the
list of existing apertures) will be applied to all selected objects, regardless of their differences.

You may have the new flashes displayed on the same layer, a new layer, or an existing layer,
depending upon your choice from the available pull-down. Furthermore, you may Delete Old
Objects or keep them for reference. You may set a Flash Tolerance for matching objects across the
selection, and you may enlarge or reduce the final size of the new flashes by changing the
Over/Under Size value.

This automatic feature is particularly useful if you have carefully tailored your selection. The Bonus
» Draw to Flash » Selective offers an opposite approach.  It allows you to select a single instance of
the object you want to be replaced across the board, then searches the current image for matches.
Once the prototype is selected, a single right click will pull up a dialog similar to the one for
automatic detection, shown above. All of its settings are identical, except that there will be no
automatic resizing of different shapes, as only a single sized selection will be made.

Choosing OK returns you to the Design Window, where you may select the area you want to
search and replace with the designated aperture. Right-clicking at the end of this second selection
will make all replacements instantly.

CAMtastic!® 2000 Designers’ Edition will automatically detect all aperture sizes required, and will
add them to the aperture list (beginning at the first empty Dcode).

You are also offered the alternative of converting all selected objects to a Custom Aperture.
Selecting Bonus » Draw to Custom Aperture will allow you to select the object(s) you wish to
convert to a single Custom Aperture. Right-clicking when finished will open a dialog asking you to
name the new Custom Aperture. You may not use an asterisk (*) in this name.
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The Custom aperture will be automatically added to the Aperture Table (using the next available
Dcode). It can then be redefined if necessary, and inserted anywhere just like a standard flash. This
is an excellent feature for grouping objects together, and decreasing the file size for large arrays.

Existing custom apertures cannot be redefined in a new custom aperture.

Drills
Flashes can be converted to drill points by selecting Tools » Create Drill then selecting the
individual circular flashes you want to convert, and right-clicking when finished. The tool table will
be created automatically. Any existing tool information will not be affected and information may be
modified or added manually at any time. For more information about the Tool Table, see the
Building Blocks section of Chapter 3: Basics. If selecting View » Drill/Rout/Mill reveals a mark beside
Drill Symbol, all drill points will be displayed with a white X marking the center point.

If you wish a different tool to be used for certain drills, select Tools » Modify Drill, then select all
the drill points you wish to change to a new tool. Right-clicking when finished will open the dialog
shown below.

Any existing tool may be selected from the pull-down list. All selected drill points will be changed
to the new tool upon choosing OK.

Selecting Tools » Add Drill Point will open this same dialog from which any existing tool may be
chosen. Upon choosing OK, a single instance of the selected drill point will hover on the cursor,
ready for placement in the Design Window.

A Drill Layer may be created from Gerber information after drill points have been created. Selecting
Tools » Build Drill Layer (Plated-Through Hole) will do the same as Create Drill, except all of the
Drill information will be written to a new layer named Drill Template, rather than to the individual
source layers themselves. All circular flashes on the board will be automatically detected, and
displayed on the Drill Template layer. This layer is automatically assigned to Drill Top in the Layer
Table’s Type field.

Before a Drill Layer can be created, a Top and Bottom layer must be assigned to the Type fields in
the Layer Table. See the Building Blocks section of Chapter 3: Basics for details.

If any layer has already been assigned as a Drill layer (in the Layer Table, Type field), then a Fab
Drawing may be created from it. Selecting Tool » Create Fab Drawing (from Drill) will bring up the
dialog shown below.
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The overall dimensions of the PCB are automatically detected if CAMtastic!® 2000 Designers’ Edition
recognizes the PCB border. Company, Contact, and P/N information can be indicated, and any of
six standard sizes may be chosen for the Fab Drawing. Choosing OK will create a new layer named
Fab Layer with the PCB drawn with symbols marking each different tool size used on the board. A
legend is written to the side of the board describing each tool. This layer may be edited like any
other within CAMtastic!® 2000 Designers’ Edition before printing.

Fill Boundaries
Any closed boundary may be filled with optimized line strokes, offsetting towards the center.
Selecting Bonus » Fill Boundaries will turn the cursor into a pickbox, ready to be clicked on any
properly closed boundaries. Right-clicking when the selection is complete will open the dialog
shown below.
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• Layer:  Draws the offsets on the same layer, a new layer, or any existing layer.

• Minimum Tool Size:  Accepts any tool size value—nothing larger will be used to draw the
offsets.

• Use Single Tool:  Determines if one or more tools should be used to draw the offsets.
Deselecting this option allows CAMtastic!® 2000 Designers’ Edition to optimize the number
lines filling each boundaries.

• Use Single Internal Offset:  Offsets a single time only, then proceeds to fill the boundaries
with line patterns.

• Use ‘Snake’ Pattern for Internal Area:  Allows CAMtastic!® 2000 Designers’ Edition to use
diagonal lines (if necessary)to fill the remaining area once offsets are halted.

• Delete Old Objects:  Deletes original boundaries.

Choosing OK will begin offsetting all selected boundaries inward until another offset is no longer
possible. A line pattern will then be used to fill the remaining area.

Generate Outlines
While one trace may appear wider or thinner than another in CAMtastic!® 2000 Designers’ Edition,
the width is cosmetic rather than inherent to the line. Turning off the View » Fill feature will reveal
the skeleton of the drawing, wherein a thick line displays identically to a thin line. If, however, an
outline is generated of the different lines, the width of its pen (Dcode) will be made apparent, as an
outline is extracted from all drawn objects.

Selecting Bonus » Generate Outlines will put the cursor in general selection mode. Once all
objects you wish to outline have been selected, right-clicking will open the dialog shown below.
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• Trace Outline Mode:  Offers three modes for outlining traces:  segmented, squared corners, or
chamfered corners.

• Layer Pull-Down:  Draws the new outlines on the same layer, a new layer, or any existing layer.

• Dcode Pull-Down:  Lists the entire list of Dcodes from the Aperture table with which the
outlined traces may be drawn. Two additional options are also available:  0.005 inches (the
system default), and polygon.

• Delete Old Objects:  Deletes original traces from the session. Deselecting this option will
allow you to keep the original traces for reference.

Generate Outlines can be used with more that one layer simultaneously.

Pad Removal (Isolated/Stacked)
All isolated and/or stacked pads can be identified and removed in CAMtastic!® 2000 Designers’
Edition. This tool helps eliminate potential problems in the PCB manufacturing process. Selecting
Tools » Pad Removal will scan all active internal layers for stacked or isolated pads, and remove
them. A report will be generated automatically and display on the screen, as seen in the figure
below.

At least one Internal Route layer must be defined before running this function. Open the Layer
Table and designate the Type of one or more layers as Internal.

Panelize PCB
CAMtastic!® 2000 Designers’ Edition offers simple methods of board panelization. Selecting Tools »
Panelize PCB put your cursor in general cursor mode, ready for you to define all objects you wish
to panelize. A right click upon completing your selection will open the dialog shown below.
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All fields will initially be filled, according to your board size and certain defaults that you can
manipulate according to your own requirements. Any of these fields may be changed manually.

• Image Size:  Displays the X and Y extents of the selected image. These fields can be modified
when Gap Spacing is selected.

• Sheet Size:  Displays the sheet size onto which you will panelize the selected image.

• Offset:  Shows the center-to-center X and Y distances between panels, based on the Minimum
Border.

• Gap:  Shows the X and Y Gap between images.

• Minimum Border:  Shows the minimum border allowed between the panelized image and the
sheet edges.

• Part Count:  Displays the columns, rows and total number of panels to appear on the sheet.
The row and column fields are only open to manipulation if the Calculate option is not
selected.

• Calculate:  Calculates the maximum part count and spacing for the given image and sheet
sizes. If not selected, the column and row fields may be manipulated, and the sheet size will
show the minimum space needed to contain all panels.

• Center:  Centers panelized board on the sheet.

• Use Step & Repeat:  Uses embedded codes to generate panels rather than rewriting all data
information for each panel, thus saving space (see the Basic Concepts section of this chapter
for details).
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• Preview:  Arrays columns and rows of frames representing the selected area, allowing you to
verify that your spacing is correct.

• Defaults:  Fills the Sheet Size, Minimum Border, and Gap Spacing fields with default entries the
next time this feature is activated.

Routing/Milling
Routing and Milling paths may be created and modified within CAMtastic!® 2000 Designers’ Edition.

A complete routing path around the board may be created automatically. Selecting Tools » Auto-
Rout PCB Border will let you select the border of the PCB. The placement of this first click will be
plunge/retract point for the routing/milling tool. As you move the mouse, a thread will follow the
cursor from that initial point as you choose the direction (relative to the plunge point) for the tool
to cut. A dialog will appear then as shown below.

A pull-down list shows all the tools previously created in the Tool Table; auto-routing will not be
possible if this table is empty. Each tool lists its size, compensation and depth. If there is no
compensation assigned to the tool you choose, you will have the option to assign a default value
(same as the size) before proceeding. Extensions for the plunge and retract points are to be entered
in the units (inches or mm) shown in the Drawing Modes dialog (see the Building Blocks section of
Chapter 3: Basics for details).

Choosing OK will create a new layer with a name derived from the layer on which the boundary
was originally found. It will contain the routing path with certain symbols, depending upon you
View settings. Selecting View » Drill/Rout/Mill opens the submenu shown here.

The Drill Symbol mark has been explained under the Drill heading of this
section. The other items all refer to Rout/Mill layers, and if they are enabled,
these symbols will appear when viewing the newly created layer. The Plunge
and Retract symbols will appear by the vertex chosen initially, and the
Direction Arrows will be seen along the trace. The CenterLine Path displays
the routing path (normally a dashed line) as a solid line.
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The effects of the CenterLine Path viewing option can only be recognized when View » Fill is
turned off.

CAMtastic!® 2000 Designers’ Edition allows users to modify existing routing paths or create new
ones. These features may be accessed by selecting Tools » Create Rout Path(s) or Tools » Modify
Rout Path(s). In either case, select all relevant traces in the normal fashion, right-clicking when
finished. The dialog boxes for these two features are essentially the same; the Modify Rout Path(s)
dialog is shown below.

The tool may be changed, as may be the tool offset (if any). Choosing Toggle Direction will reverse
the direction arrows and replace all plunge points with retract points, and all retract points with
plunge points. The Plunge and Retract buttons allow you to change the position of these points
from their default locations.

Certain modifications to plunge and retract points may not be undone.

Unless connecting lines are joined together as a single polyline, each line will have its own plunge
and retract points. Joining a line together (Edit » Join) before routing will ensure that only one
plunge and one retract point is created. Conversely, plunge and retract markers may be added to a
routing paths by breaking (Edit » Break) the path at all desired locations.

While routing normally refers to traces, certain options can be set to manage the inclusion of
flashes in the routing path. Selecting Tools » Rout Options opens the dialog shown below.

• Drill Round Flashes:  If selected, any round flashes found in the selected routing path will be
drilled rather than routed. If not selected, a normal routing path will be determined for flash.
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• Add Cleanup Cut:  The algorithm is repeated to optimize paths.

• Plunge in Center:  If selected, the plunge point is placed at the center of the aperture. If not
selected, the plunge point is placed at an edge.

The following apertures cannot be used in a rout/mill path:  Custom, Diamond, Donut, Target, and
Thermal.

Scale Layers
Entire layers may be rescaled CAMtastic!® 2000 Designers’ Edition. Selecting Bonus » Scale Layers
(X/Y) will open the dialog shown below.

All existing layers are listed, and may all be modified to a new size or each to individual sizes.
Values greater than 100 will enlarge the layer, values between zero and 100 will shrink it. Leaving a
value at 100% will result in no change, while negative values will mirror the layer on either axis.

Apertures are not scaled; should you need to scale apertures, you should use the Scale feature
described in the Basic Editing section of this chapter.

Spread/Reduce Sizes
In addition to rescaling objects and layers, CAMtastic!® 2000 Designers’ Edition offers yet another
way to resize objects. The Spread/Reduce feature is powerful because it can thicken or thin
apertures without moving them, and is valuable when designing silkscreens and paste masks.
Selecting Tools » Spread/Reduce Sizes will put the cursor into general selection mode, until all
desired objects are selected. Right-clicking will open the dialog shown below.



Chapter 5: Editing Tools Advanced Editing

92 CAMtastic! ® 2000 Designers’ Edition User’s Guide

In the Settings box, enter a value for the spread (per side) of the selected items. The units will
depend upon the settings assigned in the Drawing Modes dialog (see the Building Blocks section of
Chapter 3: Basics for details). Enter a negative value to reduce the sizes of all selected objects.
Select Delete Old Objects unless you wish to keep the original images for reference. The changes
may be reflected upon the same layer, a new layer, or any existing layer, depending upon the
selection made from the available pull-down list.

If you reduce sizes and write to the same layer, nothing will happen unless Delete Old Objects is
selected.

SMT Utilities
CAMtastic!® 2000 Designers’ Edition has added tools to assist in SMT stencil manufacturing.

Homebase Pads
Homebase pads are used for improving the area of paste (per pad) deposited with an SMT stencil.
Any two flashes may be selected then converted into a Homebase Pad across any selected portion
of your image.

Selecting Tools » SMT Utilities » Homebase Pad Conversion will put the cursor in selection mode.
Select the pair of pads you wish to convert. While CAMtastic!® 2000 Designers’ Edition will allow the
original pair to be made of dissimilar pads, only the smaller pad will be used to determine the size
of the Homebase Pad.

Once the pads are selected, right click once. This will bring up the dialog shown below.



Advanced Editing Chapter 5: Editing Tools

CAMtastic! ® 2000 Designers’ Edition User’s Guide 93

• Direction:  Determines whether bevels on the pad pair will face inward or outward.

• Edge Factor:  Determines the width and height of the bevel. This value is entered as a
percentage of the width and height of the selected pads.

• Delete Old Objects:  Deletes the original pads. If not selected, the original pads can be kept as
reference.

• Layer Assignment:  Specifies the layer upon which the converted pads will be written. Choices
include the same layer, a new layer, or any existing layer.

• Flash Tolerance:  Indicates the margin of error allowed when searching for matching pad pairs.
The units (inches or mm) will depend upon the settings in the Drawing Modes dialog (see the
Building Blocks section of Chapter 3: Basics for details).

Once all fields are correct, choosing OK will return you to selection mode. Choose all objects
and/or areas where you want the conversion to take place. Right-clicking when done will change all
matching flash pairs to a Homebase Pad.

Once converted, the Homebase Pad is treated as a single object, although unconnected. Selecting
end will automatically select its partner.

Epoxy Bars
Epoxy Bars may also be added between certain pads across the board. Selecting Tools » SMT
Utilities » Add Epoxy Bars will allow you to choose any pair of pads (flashes). Right-clicking when
finished will open the dialog shown below.
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The Gap Factor of the Epoxy Bar indicates the width and height of the bar between the two pads.
The width is a function of the horizontal distance between the pads (measured from inside edge to
inside edge). The height is a function of the vertical distance covered by the pads (measured from
the top edge of the higher pad to the bottom edge of the lower pad). Only values between 10 and
100 percent may be entered for these fields.

The same options for deleting original objects, assigning a layer for the new replacements, and
tolerating a certain amount of mismatch described in the Homebase Pad Conversion, are again
available.

Choosing OK will return you to the image, where you can define the objects and/or areas where
matching pad pairs might be found. Right-clicking when the selection is complete will search and
write epoxy bars for all matches within the selected area. An epoxy bar will be centered between
each pad pair.

If this feature is run twice in a single session, the Add Epoxy Bars dialog will only display if the
template pad pair is different from the previous template. Otherwise, CAMtastic!® 2000 Designers’
Edition assumes you want to apply the same settings, and will allow you to select the conversion
area directly.

Step & Repeat Features
 Some CAMtastic!® 2000 Designers’ Edition features, such as Panelization and Arrays, allow
embedded step and repeat codes to deflate the size of files that contain the same information
multiple times. If a session includes Step & Repeat codes, only the original image will be fully
displayed in the Design Window. It will be framed by a white rectangle, and the projected copies
will appear only as blank frames. The lowest and left-most object in the original image will act as
the reference point for the Step & Repeat array.

Grids of information using Step & Repeat codes may be exploded (having each copy written out in
its entirety) or modified. To stop using Step & Repeat codes for a panel or array, select Bonus »
Step/Repeat » Explode S/R. Then click the pickbox upon the reference point (see above) in the
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original frame. All subsequent frames will fill with copied images while the frames themselves will
disappear.

To modify the characteristics of a Step & Repeat panel or array, select Bonus » Step/Repeat » Modify
S/R, then click the pickbox upon the reference point for the array. This will open the Modify Step &
Repeat dialog shown below.

These options are all identical to those explained with the Array feature; see the Basic Editing
section of this chapter for details. The spacing method is automatically calculated in Distance
mode, but it may be changed to Gap and resized. The number of columns and rows may be
changed if desired. A preview of the spacing is available, and choosing OK will apply the new
settings to the entire array.

Objects may be added to or removed from existing arrays using Step & Repeat information. To add
a new item to an array, select Bonus » Step/Repeat » Add Objects to S/R. This puts the cursor in
general selection mode, allowing you to choose all new objects with the left mouse button. Right-
click when finished, then left click upon the reference point for the array. This will add the new
object to each frame in the array.

If new objects exist outside the original frame, spacing will not be automatically adjusted, and you
may find your copied images overlapping one another. Modify the Step & Repeat as explained
above to fix any spacing problems.

To remove items from an array using Step & Repeat codes, select Bonus » Step/Repeat » Remove
Objects from S/R. The cursor is placed in general selection mode. Right-clicking when the selection
is complete will remove all indicated objects from each frame in the array.
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Additions to or removals from existing Step & Repeat arrays are, of course, invisible until the array
is exploded. This may be done for verification, then undone immediately by selecting Edit » Undo.

Teardrops
Teardrops may be added making between tracks and pads on all enabled layers, making their
junction less abrupt. Selecting Tools » Teardrops will put the cursor in selection mode, ready to
select flashes. Right-clicking when the selection is finished will open the dialog shown below.

• Pad:  Places a small pad (half the size of the original pad) at the trace/pad intersection.

• Line:  Places two lines (tangent to the pad) to fill in the trace/pad intersection.

• Line Offset Factor:  Accepts a ratio length to use for the teardrop lines. (The larger the factor,
the longer the teardrop.) This factor is only applicable when the Line method is selected.

Choosing OK will apply the Teardrop settings to the entire selection.

Trim Silkscreen
Silkscreen images may be trimmed away from the soldermask layer pads in CAMtastic!® 2000
Designers’ Edition. Selecting Tools » Trim Silkscreen will open the dialog shown below.

• Clearance:  Accepts additional clearance spacing (beyond the edge of the pad) required for
the soldermask. Negative numbers are also accepted.

• Min. Segment Length:  Defines the minimum length for any trimmed silkscreen object.
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• Copy to New Layer:  If selected, saves the original silkscreen layer for your reference with a
.old extension. If not selected, the changes will be made to the silkscreen layer directly.

All infringing silkscreen traces will be clipped to clear soldermask pads.

Both a silkscreen and a soldermask layer must be defined before running this function. This is done
in the Type column of the Layer Table. Choose a Silk type for the silkscreen layer and a Mask type
for the soldermask layer.

Venting
CAMtastic!® 2000 Designers’ Edition allows for a venting pattern to be applied to a PCB panel. If the
panel has already been panelized, selecting Tools » Venting will open the dialog shown below.

Signal layers (Top, Bottom, and Internal types) and power/ground planes are detected from the
Layer Table and listed. By default, they are all selected for venting, but any layer can be deselected
with a single click.

The venting pattern operates exactly like the copper pour pattern described earlier in this section.
Choosing OK will fill the gaps and borders of the sheet with the venting pattern indicated.

The PCB must be panelized (either normally or with Step & Repeat codes) before running this
function.
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CHAPTER 6

Reference Tools

Aperture List Wizard
The Aperture Wizard creates a specific template that CAMtastic!® 2000 Designers’ Edition will use to
recognize the apertures in imported files, then build an accurate Dcode list. You may modify an
existing template, or create new ones of your own.

Selecting Bonus » Aperture Wizard will open the dialog shown below.
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• Wizard Name Pull-Down:  Accepts a new name, or any preset from the pull-down list.
CAMtastic!® 2000 Designers’ Edition includes 50 aperture wizards, but any number of custom
wizards may be added.

• Aperture File Extension:  Associates this wizard with any three character extension. Any Gerber
imports with this extension will automatically use this wizard to read their aperture data.

• Move To:  Indicates the text line after which the aperture definitions begin. Many aperture
files begin definitions on the first line, in which case no value should be entered in this field.

• + Skip Additional Lines:  Steps any number of lines forward beyond the line following the
Move To target

• Stop At:  Indicates a text entry that will only appear after all aperture definitions are read. If
definitions extend to the end of this file, then no value is required in this field.

• Multiple Definitions per Line:  If selected, Searches for more than one aperture definition per
line.

• Units:  Accepts definition values to be written in inches, mils, or millimeters.

• Scale:  Allows non-standard units to be read. Choosing millimeters, then entering a Scale of 10,
for instance, will read a design written in centimeters.

• File Menu:  Allows you to open or save an Aperture Wizard Template. This is useful for sharing
templates among other CAMtastic!® 2000 Designers’ Edition users.

Standard Line Formats include all the shapes and data sequences that this wizard will recognize.
From the pull-down list on the left, choose the relevant shape, then fill the line on the right with the
data sequence for that shape.

Every data line must contain:

• An aperture position typecast:  <A> or <D>

• A shape description:  "SQR" , "THERMAL" or "CIRCLE", etc.

• At least one size typecast <I> or <O> or <X> or <Y>

Use the skip typecast <S> to ignore any unnecessary words or groups of characters. Additionally,
characters not enclosed in "quotes" or <angled brackets> will be specifically ignored. Similarly,
extraneous characters that appear in any line may be ignored by typing them in their appropriate
place in the data sequence line. All trailing information on a line will be ignored.

Standard Line Format Typecast:

<A> Aperture Position

<D> Dcode

<I> Inside Diameter

<O> Outside Diameter
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<S> Skip

<X> X aperture size

<Y> Y aperture size

<T> Tie Width

<R> Rotation

<M> Miscellaneous, such as the number of spokes on thermals or rings on targets

Buttons for each of the typecast entries have been added for cut and paste entry method. To use
these buttons, simply copy a sample line for each aperture from the aperture file, and paste it into a
data sequence line of the wizard. Assign the correct shape on the left, then double-click any value
on the sample line to highlight it. Then choose the Typecast button it represents to replace the
highlighted value with the appropriate Typecast. This method can save time when creating new
wizards from aperture files.

CAMtastic!® 2000 Designers’ Edition stores each template in a separate file located in the
CAMtastic 2000 DE\aptwiz folder. If you are distributing aperture wizard files to other users,
copy them to their aperture wizard folder. CAMtastic!® 2000 Designers’ Edition detects the presence
of any new files placed in that folder.

The following examples may help you learn the annotation techniques for the Aperture Wizard. We
have taken a sample line from various aperture formats to show how these are described with
CAMtastic!® 2000 Designers’ Edition typecast.

Example 1:

Sample Line:  D19 RECTANGULAR 20.000 100.000 0.000 MULTI

Aperture Wizard Line:  Rectangle; D<D> "RECTANGULAR" <X> <Y>

Example 2:

Sample Line:  1 D10 DRAW --size 8

Aperture Wizard Line:  Round; <S> D<D> "DRAW" <S> <S> <X>

Example 3:

Sample Line:  14 Donut 0.0500:0.0200 PAD14

Aperture Wizard Line:  Donut; D<D> "Donut" <O>:<I>

Example 4:

Sample Line:  D322 THERMAL OD45.00in. 1.143mm ID25.00in. 0.635mm 10strap
45rotation

Aperture Wizard Line:  Thermal; D<D> "THERMAL" OD<O>in. <S> ID<I>in. <S> <T>strap
<R>rotation
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Film Wizard
If you need to output Gerber layers onto film, CAMtastic!® 2000 Designers’ Edition offers tools to
panelize layers within a single film box. It will automatically align all displayed layers (using center
locations), then create a new layer containing the paneled information within a film box.

If your session contains layers that you do not wish to appear in this panel, turn them off before
proceeding.

To begin, select Bonus » Film Wizard. This opens the dialog shown below. All fields are open to
modification.

• Film Description:  Lists standard film sizes, followed by the number of rows and columns that
will fit on the film, based on the images shown in all active layers.

• Film Size, Array Number:  Shows dimensions of the film and number of rows and columns. If
an existing Film Description is chosen from the pull-down list, then these fields are filled in
automatically.

• Add New Description:  Adds custom values entered into the Film Size and/or Array Number
fields into the Film Description List. This new entry will be available in the pull-down list the
next time you use this feature.

• Individual Film Size:  Calculates the amount of film available for each image in the array based
on film size and the number of rows and columns. This image should be at least as large as the
image extents (shown on the Status Bar). If it is not, you may proceed, but a warning will
appear before you do.
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• Neg./Mirror:  Opens a dialog allowing you to choose which layers should be shown as
negatives and/or in mirror format.

Highlight all layers you wish to appear on the film as negatives and/or in mirror format. At any time
you may restart this process by choosing either the Clear Neg. List or the Clear Mirror List button.

Choosing OK will return you to the Design Window. You will have the option to delete the original
layers before the new layer is created. This action cannot be undone.
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Layer Type Detection Template
Available in the Main View of the Workspace Bar, this dialog is used to help CAMtastic!® 2000
Designers’ Edition determine what Layer Types are being used by the names of the Gerber files.

Note that only one imported layer may be assigned to the Top layer, and only one may be assigned
to the Bottom layer upon import. (Manually, any number of layers may be assigned to any type.) If
multiple imported layers are assigned to, for instance, the top layer, only one will be imported, and
the rest will be ignored. The same holds true for other layer pairs. Multiple layers may, however, be
imported as Internal.

Any modifications to this table will be applied upon all following imports. When making
modifications, follow the same format as shown.  Any part of the file name may be tagged,
including the extension, if applicable.  Separate entries with commas.
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Preferences
Your installation of CAMtastic!® 2000 Designers’ Edition may be customized according to the type of
work you generally do. Defaults may be set to your specifications, while any desired modifications
on individual files remain available. Double-clicking the Preferences folder in the Main View of the
Workspace Bar reveals five subfolders:  General, Import/Export, Film Box, Printer, and Drawing
Modes.

Some preference settings will not take effect until a new session of CAMtastic!® 2000 Designers’
Edition has been started. It is a good idea to restart the program after modifying preferences.

Double-clicking on Drawing Modes, Film Box or Printer will bring up familiar dialogs. The only
difference between these settings and those explained earlier is that any changes you make here
will become the default settings for new sessions. See the Session Management and the Building
Blocks sections of Chapter 3: Basics for a description of the Printer and Drawing Modes dialogs,
respectively. The Film Box dialog is explained in the Viewing Tools section of Chapter 4: Non-
Editing Tools.

The General and Import/Export dialogs, on the other hand, are unique to this section. Double-
clicking on General opens the dialog shown below.
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• Initial Positive Area (inches only):  Decides where to place the origin, or more specifically, how
much initial area will be positive when a new session is started. The extents of CAMtastic!® 2000
Designers’ Edition's working area is 65" x 65" (1651mm x 1651mm), so any initial positive area
between zero and the full extents will be accepted.

• Center Image in Database:  If selected, calculates the extents of the entire image loaded, and
centers it within the CAMtastic!® 2000 Designers’ Edition 65"x65" area. In effect, this feature
overrides the Initial Positive Area, as the positive area will depend upon the size of the loaded
data.

• Auto Repeat Functions:  Repeats editing and drawing functions until you either press Esc or
choose Cancel from the right-click menu. This feature can be useful when you require a series
of similar draws or edits, and wish to avoid restarting each function manually. For some
features (DRC, Set Origin, etc.), Auto Repeat functions have been disabled.

• Display Aperture List in MILS:  Displays units in mils (1 mil = 0.001 inch), for aperture sizes
display in various reports.

• Object Snap within pickbox (Fuzzy Mode):  Snaps to any existing endpoints within the
pickbox.

• Translucent Viewing Default:  Begins each new session with the Translucent View enabled.

• Draw Current Layer Last:  Displays the current layer on top of all other layers. This same
change can be made in the View Layer Order dialog, described with the Layer Table in the
Building Blocks section of Chapter 3: Basics.

• Arc Resolution:  Controls the displayed arc resolution that CAMtastic!® 2000 Designers’ Edition
will use on Circular Interpolation (true arcs). Arcs will always retain their true arc information,
but will be displayed as straight line segments to boost display speed. At any time you may
verify that the arc information is preserved by running a query on that arc; the arc information
and center point will be displayed in the Info View of the Workspace Bar.
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• Program Directory Path:  Describes the pathway to the executable file:  CAMTASTC.EXE. The
destination folder will also contain necessary system files, such as font files (*.fnt).

While these preferences apply mainly to the entire design environment, the Import/Export
preferences apply mainly to Gerber files that you read or create with CAMtastic!® 2000 Designers’
Edition. Double-clicking on the Import/Export preferences subfolder in the Workspace Bar will
open the dialog shown below.

• Gerber File Extensions:  Considers all file extensions found in this edit box to be Gerber files.
When you use Import » Gerber, these extensions will be included in your search. This helps
you locate Gerber files quickly, without having to filter through all files in a folder.

• Aperture File Extensions:  Considers all file extensions found in this edit box to be Aperture
files. When you use Import » Aperture File, these extensions will be included in your search.
This helps you locate Aperture files quickly, without having to filter through all files in a folder.

• Gerber Quick Load Max. Size:  Helps Gerber Quick Load determine the format of potential
Gerber files. While Gerber Quick Load is performing its calculations, it will detect Gerber
layers over the defined size that must be scaled down.

• Optimize Exported Gerber, Drill, and Rout file size:  Controls the optimization of Gerber, Drill,
and Rout files. By default, identical X, Y, or D values may be omitted on the following line of
code (this is called modulation). Some older, less robust software programs cannot handle data
modulation during import. These packages may crash or interpret incorrectly the data loaded.
If selected, all files exported will be modulated, resulting in smaller and more efficient data. If
not selected, the exported will not be modulated. Every repetitive X, Y, and D values will be
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included on the following line. This improves the potential for older software programs to
interpret the data correctly.

Other buttons in this dialog provide defaults for settings described in the Session Management
section of Chapter 3: Basics (Importing and Exporting).
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APPENDIX A

Toolbars

Ten prepared toolbars are available for use in CAMtastic!® 2000 Designers’ Edition. They may be
displayed or hidden, modified or restored to their original defaults. Each toolbar will be shown
below, with references to the portions of the manual in which its functions are described.

Aperture

Both of these features are described in the Building Blocks section of Chapter 3: Basics.

Coordinate

All of these features are described in the Building Blocks section of Chapter 3: Basics.
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Draw

All of these features are described in the Drawing section of Chapter 5: Editing Tools.

Edit

All of these features are described in the Basic Editing section of Chapter 5: Editing Tools.
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Export

All of these features are described in the Session Management section of Chapter 3: Basics.

File

• New, Open, Save, Imports, Print/Preview: Session Management section of Chapter 3: Basics.

• Query, Measure: Inspection Tools section of Chapter 4: Non-Editing Tools.

• Build PCB Report/Quote: Reports section of Chapter 4: Non-Editing Tools.
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Layers

• Layer Control, Add Layer, All Layers ON, All Layers OFF: Building Blocks section of Chapter 3:
Basics.

• Redraw: Viewing Tools section of Chapter 4: Non-Editing Tools.

Select

All of these functions are described in the Workspace Management section of Chapter 3: Basics.
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Tools

All of these features are described in the Advanced Editing section of Chapter 5: Editing Tools.

View

• Zooms, Dynamic Pan: Workspace Management section of Chapter 3: Basics.

• View Toggles, Highlight Dcode, View Origin: Viewing Tools section of Chapter 4: Non-Editing
Tools.
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APPENDIX B

Shortcut Keys

As described in the Workspace Management section of Chapter 3: Basics, shortcut keys may be
added, modified, deleted, or restored to their original default values at any time. In general, the
existing keys have been assigned under the following framework: non-editing features use a
single—often obvious—letter; editing features will usually use the Ctrl key; and the Alt key has
been reserved for selection commands.

The following lists show the functions with their preset shortcut keys, and any equivalent toolbar
buttons. CAMtastic!® 2000 Designers’ Edition is not case-sensitive when entering shortcut keys.

Viewing Tools
Zoom In: +

Zoom Out: -

Zoom Window: W

Zoom Previous: V

Zoom All: Home

Zoom Film Box: Ctrl+Home

Zoom to Current Dcode: Alt+Home

Scroll (half screen): Arrow Keys

Pan: P
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Redraw: R

Display Film Box: B

View Extents Box: E

Toggle Fill View: F

Toggle Negative View: N

Toggle Translucent View: T

Toggle Object/Grid Snap: S

Toggle Ortho Mode O

Display Drawing Modes: G

Highlight Current Dcode: H

Query: Q

Measure:  Point to Point: M

Open Aperture Table: A

Open Layer Table: L

Begin New CAM Session: Ctrl+N

Print Current Display: Ctrl+P

Cancel: Esc
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Editing Tools
Array: Ctrl+A

Modify: Ctrl+D

Erase: Ctrl+E

Align Layers: Ctrl+L

Mirror: Ctrl+M

Set User Origin: Ctrl+O

Rotate: Ctrl+R

Scale: Ctrl+S

Move: Ctrl+V

Explode: Ctrl+X

Redo: Ctrl+Y

Undo: Ctrl+Z

Selection Tools
Select All: Alt+A

Select Window: Alt+W

Select Crossing Window: Alt+C

Select Display: Alt+D

Selection Filter: Alt+F
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Previous Selection Set: Alt+P
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align layers ................................................ 76
automatic............................................... 76
selecive .................................................. 76

aperture reports
aperture files................................... 53–54
custom aperture library files........ 53–54
dcodes, layers....................................... 55

apertures ............................................. 37–39
importing aperture files...................... 29
importing custom aperture libraries 29
list wizard ...................................... 99–101
toolbar ................................................. 109
view Dcode ........................................... 46

arc
drawing............................................ 63–64

array...................................................... 68–69
assembly utilities................................ 76–78

creating groups .............................. 76–77
parts table........................................ 77–78
reference designators ......................... 77

AutoCAD files..................... See DXF/DWG

-B-
bed of nails....................See netlist, export
bevel.........................................See chamfer
bitmap

create ............................................... 34–35
break .......................................................... 69

-C-
calculate copper area .............................. 52
chamfer...................................................... 69

change object/layer ........................... 72–73
circle

drawing .................................................. 64
close database .......................................... 19
closure........................................................ 61
combine layers……See composite layers

or merge layers
composite layers ................................ 79–81
conversions ......................................... 82–84

draw to flash, automatic.................... 119
draw to flash, selective.................. 83–84

coordinate
toolbar.................................................. 109

copper area .....See calculate copper area
copper pour ........................................ 81–82
copy ...................................................... 69–70

mutliple.................................................. 69
single ...................................................... 69
to specific layer(s) ................................ 70

-D-
Dcodes .................................. See apertures
delete ............................................See erase
Design Rules Check........................... 50–52
DFM .................... See Design Rules Check
differences view ....................................... 46
dimensions

placing.............................................. 66–67
drawing

modes............................................... 42–43
toolbar.................................................. 111
tools.................................................. 61–67

DRC..................... See Design Rules Check
DRC Errors
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report ......................................................55
drill

adding drill points ................................84
creating...................................................84
export......................................................30
files, import..........................................119
layer.........................................................84
report ......................................................56

DWG .................................... See DXF/DWG
DXF/DWG

export................................................30–31
import files.......................................22–25

-E-
editing

toolbar ..................................................110
tools ..................................................67–75

ellipse
drawing...................................................64

erase............................................................70
explode.......................................................70
export

bitmap...............................................34–35
drill ..........................................................30
DXF/DWG.........................................30–31
gerber ...............................................31–32
IPC-D-350 ...............................................34
netlist ................................................33–34
routing ....................................................33

exporting
toolbar ..................................................111

exporting files .....................................30–35
extend...................................................70–71
extents

box...........................................................47
image ................................................12–13

extract netlist ...........................................119

-F-
fabrication drawings.................................85
file toolbar................................................109
fill .............................. See also copper pour

boundaries.......................................85–86
copper ......................... See copper pour

fill view........................................................45
fillet .............................................................71
film

box.......................................................... 46
wizard............................................... 101–4

flash
placing ................................................... 62

-G-
generate outlines.…………..See outlines,

generate
Gerber

export............................................... 31–32
import files...................................... 25–28

-I-
import

drill files........................................... 20–21
DXF/DWG files................................ 22–25
Gerber files ......................................... 119
HPGL/HPGL2 files ................................ 28
routing files......................................... 119

importing files .................................... 19–29
IPC-D-350

export..................................................... 34

-J-
join (and fix polylines) ...................... 71–72

group................................................ 71–72
single...................................................... 71

-L-
layer

table.................................................. 40–41
layers .................................................... 39–41

composite........................................ 79–81
merge............................................... 78–79
toolbar ................................................. 112

lines
drawing polylines .......................... 62–63
drawing standard lines...................... 119

-M-
measure ..................................................... 48
merge layers........................................ 78–79
milling ....................................... See routing
mirror ......................................................... 72
modify object/layer............................ 72–73
mouse

general use............................................ 13
move........................................................... 73
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-N-
negative image view ................................ 45
netlist

export............................................... 33–34
extraction ........................................ 49–50

new database ............................................ 19

-O-
offset .......................................................... 74
open database .......................................... 19
origin.......................................................... 47
outlines

generate........................................... 86–87

-P-
pad removal .............................................. 87
panelize PCB....................................... 87–89
PCB

panelize ........................................... 87–89
report for quotation ...................... 56–58

polygon
drawing.................................................. 64

polygon void
drawing.................................................. 64

pour.................................. See copper pour
preferences ......................................... 104–8

general ............................................. 105–7
import/export ................................. 107–8

print ...................................................... 35–36

-Q-
query .................................................... 48–49
quotation for PCB

report ............................................... 56–58

-R-
rectangle

drawing.................................................. 63
redo ............................................................ 61
remove isolated pads .............................. 87
reports.................................................. 52–59

aperture file .................................... 53–54
custom aperture library file ............... 54
dcodes, layers....................................... 55
DRC Errors............................................. 55
drill ......................................................... 56
quotation for PCB .......................... 56–58

rout/mill ................................................. 58
system status......................................... 59
XY coordinates...................................... 59

rotate .......................................................... 74
routing.................................................. 89–91

create, modify................................. 90–91
export ..................................................... 33
PCB border............................................ 89
report ..................................................... 58

routing files
import................................................... 119

-S-
save database ............................................ 19
scale

layer(s).................................................... 91
object(s) ................................................. 74

selection .............................................. 16–18
toolbar.................................................. 112

settings................................................. 19–20
shortcut keys......................... 14–15, 113–18
silkscreen

trim ................................................... 96–97
silkscreen manufacture…………See SMT

Utilities
SMT Utilities............................................ 119

epoxy bars ........................................... 119
Homebase Pads.............................. 92–93

spread/reduce..................................... 91–92
Status Bar ............................................. 12–13
Step & Repeat ..................................... 94–96

add, remove objects ...................... 95–96
explode ............................................ 94–95
modify .................................................... 95

-T-
teardrops ................................................... 96
text

editing .................................................... 74
placing.............................................. 64–66

toolbars ...................................... 8–9, 109–13
tools

table.................................................. 43–44
toolbar.................................................. 113

total box ............................................... 12–13
translucent view ....................................... 45
trim silkscreen .................................... 96–97
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-U-
undo............................................................61

-V-
venting........................................................97
vertexes ................................................74–75
vertices ....................................See vertexes
view

Dcode .....................................................46
differences .............................................46
fill.............................................................45
negative ..................................................45

toolbar ........................................... 113–15
translucent ............................................ 45

-W-
workspace bar ...................................... 9–12

-X-
XY Coordinate Box ............................ 12–13

-Z-
zoom

basic zooms .................................... 15–16


	CAMtastic!® 2000 Designers’ Edition User’s Guide
	Table of Contents
	Chapter 1:  Introduction
	CAMtastic!® 2000 Designers’ Edition Features
	Guide Overview

	Chapter 2:  Installation and Setup
	System Requirements

	Chapter 3:  Basics
	Workspace Management
	Session Management
	Building Blocks

	Chapter 4:  Non-Editing Tools
	Viewing Tools
	Inspection Tools
	Reports

	Chapter 5:  Editing Tools
	Basic Concepts
	Drawing
	Basic Editing
	Advanced Editing

	Chapter 6:  Reference Tools
	Aperture List Wizard
	Film Wizard
	Layer Type Detection Template
	Preferences

	Appendix A:  Toolbars
	Aperture
	Coordinate
	Draw
	Edit
	Export
	File
	Layers
	Select
	Tools
	View

	Appendix B:  Shortcut Keys
	Viewing Tools
	Editing Tools

	Index
	Index



