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Important Information

Warranty

The media on which you receive National Instruments software are warranted not to fail to
execute programming instructions, due to defects in materials and workmanship, fora period of90
days from date of shipment, as evidenced by receipts or other documentation. National
Instruments will, at its option, repair or replace software media that do not execute programming
instructions if National Instruments receives notice of such defects during the warranty period.
National Instruments does not warrant that the operation of the software shall be uninterrupted or
error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly
marked on the outside of the package before any equipment will be accepted for warranty
work. National Instruments will pay the shipping costs of returning to the owner parts which
are covered by warranty.

National Instruments believes that the information in this document is accurate. The document
has been carefully reviewed for technical accuracy. In the event that technical or typographical
errors exist, National Instruments reserves the right to make changes to subsequent editions of
this document without prior notice to holders of this edition. The reader should consult
National Instruments if errors are suspected. In no event shall National Instruments be liable for
any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO
WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS
ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE.

CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR
NEGLIGENCE ON THE PART OF NATIONAL INSTRUMENTS SHALL BE
LIMITED TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER.
NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR DAMAGES
RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR
INCIDENTAL OR CONSEQUENTIAL DAMAGES,EVENIF ADVISED OF THE
POSSIBILITY THEREOF.

Thislimitation of the liability of National Instruments will apply regardless of the form of
action, whether in contract or tort, including negligence. Any action against National
Instruments must be brought within one year after the cause of action accrues. National
Instruments shall not be liable for any delay in performance due to causes beyond its
reasonable control. The warranty provided herein does not cover damages, defects,
malfunctions, or service failures caused by owner’s failure to follow the National Instruments
installation, operation, or maintenance instructions; owner’s modification of the product;
owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, flood, accident,
actions of third parties, or other events outside reasonable control.

Copyright

Under the copyright laws, this publication may not be reproduced or transmitted in any form,
electronic or mechanical, including photocopying, recording, storing in an information retrieval
system, or translating, in whole or in part, without the prior written consent of National
Instruments Corporation.

National Instruments respects the intellectual property of others, and we ask our users to do the
same. NI software is protected by copyright and other intellectual property laws. Where NI
software may be used to reproduce software or other materials belonging to others, you may use
NI software only to reproduce materials that you may reproduce in accordance with the terms
of any applicable license or other legal restriction.
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End-User License Agreements and Third-Party Legal Notices
You can find end-user license agreements (EULAs) and third-party legal notices in the
following locations:

+  Notices are located in the <National Instruments>\ Legal Information and
<National Instruments> directories.

»  EULAEs are located in the <National Instruments>\Shared\MDF\Legal\license
directory.
+ Review <National Instruments>\ Legal Information.txt for more information on
including legal information in installers built with NI products.
Trademarks

Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for more
information on National Instruments trademarks.

ARM, Keil, and pVision are trademarks or registered of ARM Ltd or its subsidiaries.
LEGO, the LEGO logo, WEDO, and MINDSTORMS are trademarks of the LEGO Group.
©2013 The LEGO Group.

TETRIX by Pitsco is a trademark of Pitsco, Inc.©2013

FIELDBUS FOUNDATION™ and FOUNDATION™ are trademarks of the Fieldbus

Foundation. EtherCAT® is a registered trademark of and licensed by Beckhoff Automation
GmbH.

CANopen® is a registered Community Trademark of CAN in Automation e.V.
DeviceNet™ and EtherNet/IP™ are trademarks of ODVA.

Go!, SensorDAQ, and Vernier are registered trademarks of Vernier Software & Technology.
Vernier Software & Technology and vernier.com are trademarks or trade dress.

Xilinx is the registered trademark of Xilinx, Inc.
Taptite and Trilobular are registered trademarks of Research Engineering & Manufacturing Inc.

FireWire® is the registered trademark of Apple Inc.

Linux®is the registered trademark of Linus Torvalds in the U.S. and other countries.
Handle Graphics®, MATLAB®, Real-Time Workshop®, Simulink®, Stateflow®, and xPC
TargetBox® are registered trademarks, and TargetBox™ and Target Language Compiler™ are
trademarks of The MathWorks, Inc.

Tektronix®, Tek, and Tektronix, Enabling Technology are registered trademarks of Tektronix,
Inc.

The Bluetooth® word mark is a registered trademark owned by the Bluetooth SIG, Inc.

The ExpressCard™ word mark and logos are owned by PCMCIA and any use of such marks
by National Instruments is under license.

The mark LabWindows is used under a license from Microsoft Corporation. Windows isa
registered trademark of Microsoft Corporation in the United States and other countries.

Other product and company names mentioned herein are trademarks or trade names of their
respective companies.

Patents

For patents covering National Instruments products/technology, refer to the appropriate
location: Help»Patents in your software, the patents. txt file on your media, or the National
Instruments Patent Notice at ni.com/patents.

Export Compliance Information

Refer to the Export Compliance Information at ni .com/legal/export-compliance for the
National Instruments global trade compliance policy and how to obtainrelevant HTS codes,
ECCNs, and other import/export data.
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WARNING REGARDING USE OF
NATIONAL INSTRUMENTS PRODUCTS

NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH
COMPONENTS AND TESTING FOR A LEVEL OF RELIABILITY SUITABLE
FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS
CRITICAL COMPONENTS IN ANY LIFE SUPPORT SYSTEMS WHOSE
FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE
SIGNIFICANT INJURY TO A HUMAN.

IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF
OPERATION OF THE SOFTWARE PRODUCTS CAN BE IMPAIRED BY
ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN
ELECTRICAL POWER SUPPLY, COMPUTER HARDWARE MALFUNCTIONS,
COMPUTER OPERATING SYSTEM SOFTWARE FITNESS, FITNESS OF
COMPILERS AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN
APPLICATION, INSTALLATION ERRORS, SOFTWARE AND HARDWARE
COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF
ELECTRONIC MONITORING OR CONTROL DEVICES, TRANSIENT
FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE),
UNANTICIPATED USES OR MISUSES, OR ERRORS ON THE PART OF THE
USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS
THESE ARE HEREAFTER COLLECTIVELY TERMED “SYSTEM FAILURES”).
ANY APPLICATION WHERE A SYSTEM FAILURE WOULD CREATE A RISK
OF HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY
INJURY AND DEATH) SHOULD NOT BE RELIANT SOLELY UPON ONE
FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE.
TO AVOID DAMAGE, INJURY, OR DEATH, THE USER OR APPLICATION
DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO PROTECT
AGAINST SYSTEM FAILURES, INCLUDING BUT NOT LIMITED TO BACK-UP
OR SHUT DOWN MECHANISMS. BECAUSE EACH END-USER SYSTEM IS
CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS' TESTING
PLATFORMS AND BECAUSE A USER OR APPLICATION DESIGNER MAY
USE NATIONAL INSTRUMENTS PRODUCTS IN COMBINATION WITH
OTHER PRODUCTS IN A MANNER NOT EVALUATED OR CONTEMPLATED
BY NATIONAL INSTRUMENTS,

THE USER OR APPLICATION DESIGNER IS ULTIMATELY RESPONSIBLE
FOR VERIFYING AND VALIDATING THE SUITABILITY OF NATIONAL
INSTRUMENTS PRODUCTS WHENEVER NATIONAL INSTRUMENTS
PRODUCTS ARE INCORPORATED IN A SYSTEM OR APPLICATION,
INCLUDING, WITHOUT LIMITATION, THE APPROPRIATE DESIGN,
PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.
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About This Manual

Use this manual to learn how to run measurements and how to display
measurement data with DASYLab.

Chapter 1 explains how to select a module for each function. You connect
the modules in the worksheet and configure each module for your
measurement. Each exercise contains diagrams that illustrate the steps
involved.

Chapter 2 explains how worksheets are organized and how to configure
modules. Use black boxes to create sub-worksheets, to integrate partial
solutions, and to increase the number of possible modules in the
worksheet.

Chapter 3 explains how to use the display window and the input
instruments. In the layout you can create display screens and measurement
records.

Chapter 4 explains standard drivers and DLL drivers of the installed
measurement hardware. Use DASYLab supported interfaces to access
external devices and programs.

Chapter 5 explains actions that execute module-related functions event-
driven, and variables and strings that transport information.

Chapter 6 explains the Script module with which you create a module
with the functions and settings you need for your task.

Chapter 7 explains the characteristic values of data flow in DASYLab:
Sampling rate and block size.

The appendix introduces the module groups and provides tips and tricks
for creating worksheets.

© National Instruments Ireland Resources Limited
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Conventions

The following conventions are used in this manual:

<>

»

bold

italic

Angle brackets indicate a key you press to perform a function, for
example, <Ctrl> for the control key.

The » symbol leads you through nested menu items and dialog box
options to a goal. File»Page Format instructs you to open the
menu item File and to select Page Format.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important
information.

Bold text denotes items that you must select or clickin the
software, such as menu items and dialog box options.

Italic text denotes emphasis, new terms, a cross reference,or an
introduction to a key concept.

mono-space Youenter text or letters in this type with the keyboard, for

example, formulas or code extracts. This font is also used
for the names of drives, paths, folders, programs, sub-
programs, sub-routines, device names, functions,
operations, commands, variables, control elements,
events, methods, filenames, filename extensions as well as
for comments extracted from the code.

mono-space Bold Bold text in this font denotes the messages and

responses that the computer automatically outputs to
the screen.Related Documentation

dasylab.com
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For more information on DASYLab, refer to the following
documentation:

* DASYLab Help, which you open by selecting Help»Contents, or by
pressing <F1>.

The DASYLab help offers dialog box help for each module and for each
function. If you select Help»Examples, you can load example
worksheets. The examples demonstrate worksheets of varying
complexity.

* DASYLab Extension Toolkit

Use the Extension Toolkit to create your own DASYLab modules. The
Extension Toolkit contains the description of DASYLab interfaces and
the program code of some DASYLab modules. If you work with the
Extension Toolkit, you need C-programming and Windows programming
skills.

The shipped data medium or download comprises the documentation and
example files. However several additional files are missing. You cannot
create your own extensions with these files and therefore you also need
the DASYLab Extension Toolkit.

© National Instruments Ireland Resources Limited
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Creating Worksheets

Getting Started with
DASYLab

With DASYLab you can complete measurement, control, and simulation
tasks interactively on your screen. Select a module for each function and
position the module in the worksheet. The task determines how you
connect and configure the modules. To acquire data, DASYLab supports
many standard measurement and control boards and various interfaces in
order to communicate with external devices.

DASYLab has a number of measurement, control, and analysis modules:
* Analog and digital inputs and outputs
+ Trigger functions
* Mathematics and statistics functions
* FFT and digital filters
Use the respective modules to create logical switches, and open and
closed loop controllers, or use the sequence generator to create exact,

time- dependent controls with complex control signals. You can save the
measurement data for later off-line analysis in different file formats.

The diagram, Chart Recorder, the Y/t Chart, and the X/Y Chart display
your measurement data as curves. The Diagram and the Digital Meter
display your data in numeric form. Freely scalable analog instruments, bar
displays, and Status Displays help with process controls and test controls.

Tip Appendix A, The Module Groups, lists all available modules.
The Configurator section of chapter 4, Hardware Setup, describes
the configuration of your installation.

© National Instruments Ireland Resources Limited 1-1
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Creating a Simple Worksheet

When DASYLab starts, the DASYLab worksheet window opens with the
menu bar at the top of the window, the function bar underneath, and the
browser on the left side of the window.

Complete the following steps to create a worksheet with a data source and
a display module:
1. Click the Modules tab in the browser.
a. Click the Plus [*sign next to the Control module group.
b. Select the Generator module and drag and drop the module
into the worksheet.

Specify the generator type in the dialog box that opens:

Figure 1-1. Generator Selection Dialog Box

Select module ype
() Read global variable
(@) 'without modulation Cancel
(O with modulation
Amplitude modulation [A4)

0K

Help

Frequency modulation [Fhd]

Fulse width modulation

c. Click OK to confirm the default setting. DASYLab inserts the
generator into the worksheet.

Use the generator module to create a hardware-independent worksheet
that you can use on every computer with a DASYLab installation. You
replace the Generator module later with the module of the installed
hardware, for example, the analog input of the NI-DAQmx driver.

2. Double-click the Generator module to open the dialog box. The
first channel outputs a rectangular waveform signal.

M a. Click the Plus button next to the channel bar to activate a
second signal.

@ b. Ifyou click the button of channel 1, the channel outputs a sine
waveform signal.

c. Click OK. DASYLab adds a second output to the generator.
3. Click the Plus sign * next to the module group Display in the

browser.

1-2 dasylab.com
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Select the Chart Recorder module and drag and drop the
module into the worksheet.

Double-click the Chart Recorder module to open the dialog
box.

Click the Plus button next to the channel bar to activate a
second input.

Click OK. DASYLab adds another input to the Chart
Recorder.

If you use display modules such as the Chart Recorder
module, DASYLab creates an additional display window
which appears minimized at the bottom of the screen.

You must connect the modules with data channels to let the data flow.

4.

5.

To do so, click and hold the Chart Recorder module and drag the
display module to the Generator module until the Chart Recorder
inputs touch the generator outputs.

When you release the mouse button, DASYLab automatically
connects the modules.

Click Start on the function bar to start ameasurement. #

If you start a measurement and you want to see the display, you must
open the display window.

6.

&

Click Restore All Windows on the function bar. The Chart
Recorder display window opens and you can view the signals that
the Generator module generates, similar to Figure 1-2.

© National Instruments Ireland Resources Limited 1-3
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Figure 1-2. Displaying Generated Signals
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7. Right-click the Chart Recorder display window workspace to
change the display during the measurement.

a.  Select Display»Window»Colors and Lines from the context
menu.

b. Click Drawing area in the Display elements list.

c.  Click the Color button and select light yellow as new color for
the drawing area.

d.  Click OK.

Figure 1-3 shows the colors and lines dialog box.

1-4 dasylab.com
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Figure 1-3. Color and Line Display of a Display Window

Display elements Selected colar
Ok
Backiround
# urit Cancel
Coordinate system e
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Line style Marker
i Interval : Color...

e. Click OK. The drawing area of the Y/t Chart display window
changes to the new color.

8. Click Stop on the function bar to stop the measurement.

Tip You also can press <F5> to start the measurement,

<Ctrl-F6> to pause the measurement, and <Ctrl-F5> to stop the
measurement.

© National Instruments Ireland Resources Limited 1-5
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Calculating Online

Complete the following steps to run calculations with the Formula

Interpreter during the measurement.
1.

ol

1-6

Click the Plus sign [+ next to the module group Mathematics

in the browser.

a. Select the Formula Interpreter module and drag and drop

the module into the worksheet.

b. Double-click the Formula Interpreter module to open the

dialog box.

Click the Plus sign under Input channels to create a second
channel input.

Note Do not click the Plus button next to the channel bar. That

creates a second channel output.

Click the input field Formula and enter the following formula:

IN(O)-IN(1)

The formula subtracts the values of the second input channel from
the values of the first input channel. Figure 1-4 shows the dialog box
of'the Formula Interpreter:

Input channels

Inputs;

[

Farraula0d

W Ee g A S w0 AR e e 95

NS EERAEAL R ECERE R

Channel name:

|Fo|mula 0

‘ Ok

Cancel

Help

L
Farmula
IN[OHN[T)
Functions. Operators... Inputs. .
Trigonometry. Constants. Yariables

Figure 1-4. Online Calculation with the Formula Interpreter
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You also can use the buttons underneath the input field to enter terms and
operators. DASYLab inserts the selected terms into the formula at the
cursor position.

3. Click OK. DASYLab adds a second input to the Formula
Interpreter.

For the online calculation, the Formula Interpreter must receive the
generator signals from two inputs and must output the results to the Y/t
Chart.

4.  Click the top data channel that connects the Generator andthe Y/t
Chart. The mouse pointer now changes shape to a hand holding a
plug.

a.  Drag this plug to Input 0 of the Formula Interpreter.
b.  When the color of the Formula Interpreter input terminal

changes color, click Input 0 to connect the top data channel to
the Formula Interpreter.

5. Repeat these steps to connect the bottom data channel to Input 1 of
the Formula Interpreter.

6.  Double-click the Y/t Chart module to open the dialogbox.

M a.  Click the Plus button next to the channel bar to create a third
input.
b. Click OK. DASYLab adds another input to the Y/t Chart.
7. Click Output 0 of the Formula Interpreter and connect this output
to Input 2 of the Y/t Chart.

Tip To delete a data channel, right-click the data channel twice with
the right mouse button (not a double click).

- oD

Start a measurement.

p  The Y/t Chart display window now shows three curves: the sine
signal, the rectangular signal, and the calculated signal.

© National Instruments Ireland Resources Limited 1-7
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Figure 1-5. Displaying Generated and Calculated Signals
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m 9. Stop the measurement after some time.

Inserting Digital Instruments

Complete the following steps to include a digital instrument in the
worksheet.

1. Click the Plus sign next to the module group Display, in the
browser.

a.  Select the Digital Meter module and drag and drop the module
into the worksheet.

b.  Double-click the Digital Meter module to open the dialog box.

M c.  Click the Plus button next to the channel bar twice to create
two additional inputs.

d. Click OK. DASYLab creates three inputs in the Digital
Meter module.

2. Double-click the Y/t Chart module to open the dialogbox.
a.  Click the Copy inputs check box.
b. Click OK.

1-8 dasylab.com
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DASYLab creates three outputs in the Y/t Chart module which
output the incoming data unchanged.

3. Drag the Digital Meter module to the Y/t Chart module until the
chart outputs touch the digital inputs.
When you release the mouse button, DASYLab automatically
connects the two modules with three data channels.

4. Click Restore All Windows on the function bar to open both
display [#] windows.

5. Arrange the two display windows as shown in figure 1-6.

6. Start ameasurement. e

Figure 1-6. Displaying Numeric Data in the Digital Meter
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7. Stop B the measurement after some time.

Saving Measurement Data

Complete the following steps to save the measurement data in a file.

1. Click the Plus sign next to the module group Files in the browser.

a. [# Select the Write Data module and drag and drop the
module into the worksheet.

© National Instruments Ireland Resources Limited 1-9
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b. Double-click the Write Data module to open the dialog box.

2' c.  Click the Plus button next to the channel bar twice, to create
two additional inputs.

d. Click File and enter MyData .ddf as the file name.
Click Save to close the file dialog box.

f.  Click OK. DASYLab creates three inputs in the Write Data
module.

2. Double-click the Digital Meter module to open the dialogbox.
a.  Click the Copy inputs check box.

b. Click OK. DASYLab creates three outputs in the Digital
Meter module.

3. Dragthe Write Data module next to the Digital Meter module until
the Digital Meter outputs touch the inputs of the Write Data
module.

When you release the mouse button, DASY Lab automatically
connects the two modules with three data channels. The worksheet
looks similar to Figure 1-7.

4.  Start ameasurement. b
Figure 1-7. The Worksheet Displays and Saves Data
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5. Stop ™ the measurement after some time.

Note You can examine the contents of every data channel

during a measurement. If you click a data channel, DASYLab,
shows various parameters of this data channel in the FIFO list such as the
sampling rate, the block size, and the current value. In the FIFO graph
DASYlab displays the data flow of this data channel as a curve in the of
the information block.

Because in the shown example blocksize is 1 there is no curve and min
and max values are the same!

Saving Worksheets

Complete the following steps to save the worksheet and all the settings:
1. Click |5 Save on the function bar.
2. Enter MyWorksheet as the filename.
3. Click Save to close the file dialog box.
DASYLab saves the worksheet with the name MyWorksheet .dsb
in the DASY Lab default folder which you specify under
Options»Default Folders. DASYLab automatically adds the

filename extension .dsb. The DASYLab window title bar now
shows the new filename.

© National Instruments Ireland Resources Limited 1-11






Defining Measurements

Defining Measurements

Use a worksheet to describe measurement, control, and display tasks.
Select a module for each function and connect the modules according to
the task. Double-click a module to configure the module. DASYLab
transports data in blocks from module to module. DASYLab does not
output a new data block until the current data block is completely filled
with data. The data flow in the worksheet goes from left to right.

Creating Worksheets

42 Whenyoustart DASYLab, the DASYLab worksheet window opens
< as shown in Figure 2-1. You drag modules from the browser, drop
the modules in the workspace, and connect the modules according to the
task. You open measurement settings and start the measurement from the
function bar. During the measurement, the info block displays the data flow
of'the data channel you click and the state of the internal buffer.

Figure 2-1. The Worksheet Window with Browser and Info Block
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The data flow starts on the left with a data source such as the input

© National Instruments Ireland Resources Limited 2-1



DASYLab 2016

modules of the installed hardware, the generator, or the input instruments.
Scaling modules and evaluation modules follow. On the right, the data flows
into data sinks such as the display modules and the file modules for saving
data.

For example, if you want to acquire data from the installed plugin board
from National Instruments, select the data source Inputs/Outputs»NI-
DAQmx» Analog Input on the Modules tab of the browser and drag and
drop the module into the worksheet. Select Display»Chart Recorder and
drag and drop the module to the right of the Analog Input. To connect the
two modules, drag the Chart Recorder against the Analog Input until the
Chart Recorder inputs touch the outputs of the analog input. When you
release the mouse button, DASYLab automatically connects the modules.
Click Start on the function bar and double-click the title bar at the bottom
of the screen to open the Chart Recorder.

If you want to color and label sections of the worksheet, you can insert
documentation frames into the worksheet. Documentation frames are
permanently visible in the background of the worksheet. They do not
influence the worksheet behavior. Right-click the workspace and select
Create Documentation Frame from the context menu. The cursor
changes its appearance to a cross with a sheet of paper. Click and drag
open a frame in the workspace. Double-click the documentation frame to
enter comments and to change the background color. If you want to create
another documentation frame, select Create Documentation Frame from
the context menu. To finish editing the documentation frame, disable Edit
Documentation Frame in the context menu.

Inserting and Connecting Modules

You can move one or several selected modules in the worksheet in order
to place each module at an appropriate position in the worksheet. If the
connecting data channels have nodes, you must first move the modules
individually and then move the nodes. Avoid long connections. Use the
setting Copy inputs in the display and other data sink modules to transfer
data unchanged to subsequent modules.

Activate the grid display in Options»Global Setup to make it easier to
arrange the modules. The grid interval determines the minimum distance
between neighboring modules and should be greater than 16 points. You
can change the background color and the grid color in the context menu of
the worksheet.

If you want to delete a module, select the module and press <Del>. If you
want to copy a selected module from the worksheet, including the
settings, click Copy on the function bar and then Paste.
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To replace a module with a different module — such as a generator with a
hardware input —right-click the Generator and select Replace Module
from the context menu. DASYLab lists all available data sources that you
can use to replace the generator. For example, select Inputs/Outputs\NI-
DAQmx\Analog Input for an NI-DAQmx Analog Input. The module
connections and the module name remain the same after the replacement.

You can connect modules semi-automatically or manually. If you want to
connect several data channels simultaneously, use the semi-automatic
connection method. To do so, move the module inputs to the outputs of
the neighbor module on the left. DASYLab connects the data channel
terminals that are exactly opposite each other. You also can use this
method if the number of inputs of the module receiving data is not the same
as the number of outputs of the modules providing data, or if you do not
want to connect all inputs. You can connect other modules to the
remaining free connections.

Use the manual connection method if you want to branch a
e data channel. To do so, click a data channel. The cursor
~ ¥ | changes its appearance to a hand with a plug symbol. Move
== | this plug, for example, to the input of a scaling module to

convert the acquired raw data. If you connect modules
manually, the direction of the new data channel is important: You connect
a module input with another module output, or you branch a data channel
to a module output, or you connect a module input with a data channel.
Every data channel can have up to 15 nodes.

If you clicked the input or the output of a module without wanting to
establish a connection, you can chancel the action by clicking anywhere
in the worksheet.

If you want to delete a data channel right-click the data channel twice.
With the first click the data channel changes its color and with the second
click DASYLab deletes the data channel. To delete all the module data
channels, right-click the module and select Delete Input Connections or
Delete Output Connections.

DASYLab does not permit open inputs, and in DAP boxes DASYLab
does not permit open outputs or open inputs. The Read Variable module
ensures that the worksheet always meets this requirement before the
measurement starts. For example, if you have a module with the same
number of inputs and outputs and you do not want to use one of the inputs
in the worksheet, you can read the data for this input from a variable.
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Using the Browser and the Module Bars

The Modules tab on the browser on the left side of the screen provides all
modules that you installed with DASYLab and the selected drivers. The
modules are arranged thematically in a tree structure — for example, inputs
and outputs with the hardware and interface modules, trigger functions,
mathematics, and display instruments.

The Navigator tab of the browser lists all the modules that the worksheet
contains. The navigator lists the modules in the order in which you
inserted the modules into the worksheet. In order to find and to select a
module in a complex worksheet, select the module on the Navigator tab
and select Go to Module from the context menu. DASYLab selects the
module and displays it in the center of the worksheet. To configure a
module, select Open Dialog Box from the context menu.

Ifyou select View»Module Bar, you can display a module bar with the
most frequently used modules. DASYLab displays the module bar on the
left side of the screen. Double-click the module symbol to insert the
module automatically in the workspace.

You can specify which modules to include on the module bar. Right-click
a module bar button and select New to open the selection dialog box.
Scroll through the list of available modules, select a module, and click
OK to confirm your selection. The button in the module bar now displays
the symbol of the new module. You can combine various task-related
module bars which you load according to the measurement task. Select
Edit»Module Bar to save the current module bar, to load a module bar, or
to create a new module bar.

Configuring Modules

The module inputs are on the left side and the module outputs are on the
right side of the module. Depending on the function of the module, the
module might only have inputs or only outputs. Modules that generate or
acquire data have only outputs. Modules that process data have inputs and
outputs. Modules that display, save, or output data to the hardware by
default have only inputs.

b You can change the number of terminals in the module dialog box
which opens when you double-click the module. For example,
double- click the generator module to open the module dialog box and
specify that the generator generates three signals. Figure 2-2 shows the
channel bar. Click the Plus button on the right next to the channel bar to
create additional channels . The channel bar denotes one orange plug
symbol for each channel. Click the Minus button to delete channels. In
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most modules you cannot delete the first channel, but in some modules
you cannot delete the first two or three channels.

Figure 2-2. Generator Dialog Box Displays Three Data Channels
on the Channel Bar
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For example, to create seven data channels, press <Ctrl> while double-
clicking channel 6. DASYLab creates seven channels. In order to disable
data channels down to the third data channel, right double-click channel 3
while pressing <Ctrl>. DASYLab disables all channels above channel 2.

To configure a channel, click the orange plug symbol on the channel bar.
The selected channel now denotes a green plug symbol. Use the settings
underneath the channel bar to configure this channel. The channel
configuration comprises the channel name, the unit, and all function-
specific settings. Channel 1 of the generator in Figure 2-2 generates a sine
curve with an amplitude of 4 volts and a frequency of 10 hertz.

If you want to configure several channels in one module in the same way,
you can copy the settings. Press <F8> to copy all the settings of the
current channel to the other channels. Press <F7> to copy only the selected
setting to other channels.

If you use a certain module configuration regularly, for example, the
hardware input Task AD, you can save the module settings as default
settings. Select Default Module Settings from the context menu. If you
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insert an analog input of the NI-DAQmx driver into a worksheet, this
Task AD analog input now has the changed settings.

You cannot change the number of hardware inputs and hardware outputs
because the installed driver determines the settings. The module dialog
box shows as many plug symbols as the hardware module has inputs or
outputs. If a hardware device has analog and digital inputs, you must refer
to the description of the driver to find out how the channels are assigned
to the analog inputs and digital inputs.

#| If a hardware channel is disabled , the channel bar of the hardware
module depicts a blue plug symbol. To activate the channel, double-
click the blue plug symbol with the left mouse button. To disable an
active channel, double-click an orange or a green plug symbol with the
right mouse button.

Creating Partial Solutions in Black
Boxes

Use black boxes to create sub-worksheets in order to combine partial
solutions in a complex worksheet. At the same time, you increase the
number of possible modules the worksheet can contain by 255 with each
black box. A worksheet without a black box can contain a maximum of
256 modules. You can insert up to 256 black boxes in one worksheet on
the same worksheet level or in a hierarchy in black boxes. This way you
can arrange partial solutions horizontally andvertically.

To insert a black box in the worksheet, select Special»Empty
Black Box on the Modules tab of the browser and drag and

drop the module into the worksheet. Double-click the black
box to open the workspace of the sub-worksheet. The empty sub-worksheet
takes up the entire workspace of the worksheet screen. You work in a black
box in the same way as you work in the main worksheet: you drag and
drop modules from the browser and connect and configure the modules.

You establish a connection to the main worksheet or to the higher-ranking
black box with import and export modules. You must open a black box
before you can select the Export/Import module from the Special
modules group on the Modules tab in the browser. If you drag and drop
an export/import module into the black box, DASYLab opens a selection
dialog box. Select Import Data to create inputs to the black box. Select
Export Data to create outputs from the black box.

You can use only one import module and one export module with a
maximum of 16 channels each in every black box. The number of outputs
does not depend on the number of inputs. The block length and the data
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rate of the inputs and outputs are also independent. If you need more than
16 inputs and outputs in a black box, add the Multiplexer/Demultiplexer
module. Use the multiplexer to combine data from different data channels
into one data channel and the demultiplexer to distribute data from one
data channel onto several data channels.

@ To close a black box, click Close Black Box on the function bar.
You return to either the main worksheet or the higher-ranking
black box.

Black boxes divide complex worksheets into functional sub-worksheets,
which you can export and import as partial solutions into other
worksheets. Before you can export a black box, you must open the black
box and open the properties dialog box via Edit»Black Box»Black Box
Properties. Enter a name and a unique three-figure code in the ID tag box
to identify the module on the module bar.

To save the open black box, open the Black Box tab of the browser. The
Black Box tab displays all the black boxes stored in the default folder, in
a tree view. Right-click this tree structure and select Save Open Black
Box from the context menu. Enter a filename such as MyBlackbox.
DASYLab saves all black boxes with the filename extension . dbb in the
default folder for black boxes under (Windows 10 / Windows 8 /
Windows 7 —
C:\User\Public\Documents\DASYLab\<Version Number\
<Language>\Blackbox .

To insert an already saved black box into a worksheet, select
MyBlackbox on the Black Box tab of the browser and drag and drop
the black box into the worksheet. You can create sub-folders on the Black
Box tab with the context menu in order to sort your black boxes
thematically.

The DAP box is a special black box which offers an
L individual user interface to the processing functions of the
DAP driver. If the DAP hardware driver from Microstar
Laboratories is installed on your computer, you can select
Inputs/Outputs»DAP»DAP Box»New on the Modules tab of the browser
and drag and drop a DAP box into the worksheet. You can use one DAP
Box in the worksheet for each installed DAP board.

In DAP boxes you create a worksheet solely with DAP modules. The
DAP board and not the computer processes the functions and data used in
the DAP box. Therefore you cannot use any other DASYLab modules in a
DAP Box. Youestablish a connection between the DAP board and the
computer, that is, between the DAP Box and the DASY Lab worksheet via
DAP export/import modules.
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You cannot use a DAP box or a black box to nest DAP boxes. Unlike a
Black Box you only can save a DAP box with the worksheet and cannot
export it.
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Visualizing Measurements

DASYLab offers various modules for visualizing acquired and processed
measurement data. The Diagram, the Chart Recorder, the Y/t Chart, the
X/Y Chart, and the Polar Plot display your measurement data as curves.
The List and the Digital Meter display data in numeric form. Freely
scalable Analog Meter instruments, Bar Graph displays, and Status
Displays help with process controls and test controls.

Use the input instruments Switch, Slider, and Coded Switch to input
values, generate pulses, or trigger actions during a measurement. Display
modules and input modules have windows which you can position freely on
the screen and which you can configure during a measurement.

Use the DASYLab layout window to create the visualization screen. You
position display and input modules in the layout and add text and
graphics. Youalso can create several layouts to document your
measurement. You print out these layouts either manually or event related
during the measurement.

You save the solution, which comprises the worksheet, the display screen,
and the documentation layout, in a file with the filename extension . dsb.
This way you can create solutions for each measurement task on your
computer in order to load the solutions onto the measurement system on
site.

Display Windows and Input Instruments

Every display module and every input instrument which you integrate into
the worksheet has its own window which DASYLab initially minimizes
and displays at the bottom of the screen. When you start a measurement,
the window does not open automatically.

E To open all windows simultaneously, click Restore All Windows
on the function bar. To open one individual window, double-click the
title bar of the window.

When you finish a measurement, the display windows and the input
instruments are visible in the foreground and cover the worksheet. To edit
the worksheet, click Minimize All Display Windows on the function bar.

© National Instruments Ireland Resources Limited 3-1



DASYLab 2016

DASYLab displays only the title bars at the bottom of the screen. To hide
the windows from the screen completely, click Hide All Display
Windows on the function bar. If you start a measurement now, you must
click Show All Windows to make the display windows and input
instruments visible again.

Before, during, and after a measurement you can move and resize display
windows and input instruments. DASYLab saves the arrangement and the
size of the windows together with the worksheet. In each worksheet you
can save up to eight different arrangements in order to display other
windows during a measurement or to resize individual windows. To save
the current window arrangement select View»Save Window
Arrangement. For example, enter MyScreen as the name and specify
the position in the selection list of the function bar. To select this saved
window arrangement at a later time, select MyScreen in the selection list.
You also can use the key combination <Alt> and the number of the window
arrangement, for example, <Alt—1> for MyScreen. To input the numbers,
use the numbers at the top of your keyboard because DASYLab
distinguishes these from the number pad. To delete the current
arrangement, select View»Delete Current Window Arrangement.

The display windows of the Chart Recorder, the Y/t Chart, the X/Y Chart,
the Polar Plot, and the list have a menu bar and a function bar in order to
change the display during a measurement. You can display all connected
data channels in one axis system or each data channel in a separate axis
system, and you can change the axis scaling. You can zoom, scroll, and
measure areas in the display, and you can freeze the display and copy it to
the clipboard and print it.

If you connect several data channels to these display instruments, which
display measurement data as curves, the data channels must provide data
of the same type. You only can display continuous, triggered, spectral, or
histogram data in a display window. Triggered data has gaps between the
consecutive data blocks. Spectral data are results, for example, of an FFT
and histogram data is the result of a classification. Use several modules to
display different data in a worksheet. The Chart Recorder and the diagram
are exceptions because they can process continuous data and triggered
data together in one module.

You configure input instruments, diagrams, analog and Digital Meters,
Status Displays, and bar displays in the module dialog box. For example, if
you want to integrate a rotary switch, select Control»Coded Switch on
the Modules tab of the browser. Click Options in the module dialog box
and select Rotary Switch.
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Selecting Display Modules

The following descriptions provide an overview of the functions of the
display windows and help you choose the right module for a certain task.

Diagram

Use the Diagram to display data channels as curves in 2D axis systems.
You can use the diagram like the Chart Recorder, which plots the curves
from right to left, or like the Y/t Chart, which plots the curves from left to
right, or you can use the diagram like the X/Y Chart, which plots the
relationship between channel pairs.

The Diagram cannot only display all data channels in one axis system or
every data channel in a separate axis system, but can also combine
selected data channels in axis systems. DASYLab plots all curves over the
same x-axis so that you can compare the curves with each other. To display
a further channel in an axis system, right-click the axis system and select
Add Channel from the context menu and then select the data channel, for
example, Temperature. To remove a channel from an axis system, select
Separate Channel from the context menu. The Diagram displays the
separated channel in a new axis system. You also can add and separate
data channels during a measurement. Before you start a measurement, you
can change the heights of the individual axis systems by moving the
individual x-axes in the display window. You scale the axes in the module
dialog box.

To inspect the curve sections in detail and to review already displayed

measurement values, you must stop the display while the measurement

continues. To do so, right-click the display window and select Freeze.

When you freeze the display, you can move and zoom the curves.

Use the mouse wheel to zoom the curves horizontally

Press <Ctrl> and use the mouse wheel to zoom the curves vertically

Press <Shift> and use the mouse wheel to zoom in both directions

Use the left mouse button to move thecurves horizontally

Press <Ctrl> and the left mouse button to move the curves

vertically

f.  Press <Shift> and the left mouse button to move the curves in both
directions.

g. In horizontal direction you zoom and move all curves in all axis
systems because the curves all refer to a mutual x-axis.

h. Invertical direction you zoom and move curves only in the selected
axis system.

i.  Use the buttons on the toolbar to shift the curves in all axis systems

o a0 o
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step by step in order to review already acquired data.

In the freeze mode you also can measure the curves. To do so, select
Cursor Mode from the context menu of the display window. The diagram
displays two movable cursor lines in all axis systems. In Figure 3-1 the
legend displays the values of the individual curves below the cursor lines.
As soon as the measurement restarts, the cursor lines disappear.

Figure 3-1. Measuring the Curves in the Diagram in Freeze Mode
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Chart Recorder

Use the Chart Recorder to display data channels as curves in 2D axis
systems over time. The Chart Recorder plots the curve from right to left
and is suitable for recording slow long-term measurement data that has low
sampling rates. In the Chart Recorder, you can zoom the curves during a
measurement, like in the Y/t Chart, in order to inspect curve sections in
detail. Use the magnifying glass on the toolbar of the display window to
zoom in or out of the section repeatedly. DASY Lab displays a scroll bar
below the zoomed section with which you can move the section.

In the Chart Recorder you can inspect one curve or all curves for a certain
event. You describe an event with a level and the level duration. For
example, DASYLab searches for an event with a level that exceeds 5 volt
for at least 10 seconds. If the event search is successful, a green diode
lights up and displays the value. DASYLab zooms the curve section with
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the peaks in the display window. If you search during the measurement,
DASYLab freezes the display. Click the buttons in the dialog box to
search for and to display the next peaks. As soon as you close the dialog
box for the event search, the Chart Recorder displays the curve with the
specified sampling rate, however, still zoomed. Click Zoom In to restore
the original display.

Y/t Chart

Use the Y/t Chart to display fast data acquired in kilohertz as curves over
time in 2D axis systems. Unlike the Chart Recorder, the Y/t Chart plots
the curve from left to right. Like the Chart Recorder, the Y/t Chart can
refresh the display continuously or after a specified number of data blocks.
Then the curves can be viewed unchanged for some time on the screen. In
the wiper display, the Y/t Chart plots the curves continuously with a
vertical line and overwrites the old curves when the wiper has reached the
end of the axis system. The wiper mode provides an overview over the
development of the measurement values.

You also can use the Y/t Chart to display data channels as a 3D waterfall
display or as a 3D color sonogram. You enable and configure the 3D
display in the menu of the display window. If you enable the waterfall
diagram, you must select which connected data channel the Y/t Chart is to
display in 3D. The waterfall display shows the last plotted curves for this
data channel in a cascaded display. The curve in the foreground shows the
current data. The z- axis reflects the data history that you can track with
the measurement time or the block number. Figure 3-2 shows the last ten
results of a Fast Fourier analysis with hidden-line calculation that deletes
all hidden lines.

Figure 3-2. Waterfall Display of an Online FFT
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The color sonogram, which is similar to the temperature maps of the
meteorologists, displays the first data channel that is connected to the

Y/t Chart in a color sonogram. To do so, the Y/t Chart divides the data into
256 classes so that each class covers a specific value area. The Y/t Chart
assigns a color to each class. In Figure 3-3, high values are red and the low
values are blue. The color sonogram plots the color values for each data
block row wise from bottom to top, so that the current color values are at
the bottom and the oldest color values are at the top.

Figure 3-3. A Color Sonogram Displays Data as Colors. The
Bottom Row Displays the Current Data Block.

&

Use the X/Y Chart to display several data channel pairs as xy-curves or as
vectors in 2D axis systems. To display an oscilloscope with the X/Y
Chart, enable the setting Circular grid. Select a high number of data
blocks after which DASYLab refreshes the display, so that DASYLab
plots a curve and not the last data pair as a point.

Every data channel of a channel pair and also the data channel pairs of a
module must always contain the same type of data. You can display
several data channel pairs in one axis system or in separate axis systems.

Polar Plot

Use the Polar Plot to display a data channel pair in one polar axis system.
If you select the X/Y coordinates display, DASYLab plots an xy-curve, if
you select Draw source vector, DASYLab plots the vector of the last
data pair. The two data channels must always contain the same type of
data. Label the curve or the top of the vector in regular intervals with the
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values of the third data channel to be connected. Figure 3-4 displays the
sampled surface of a shaft as an xy-coordinate.

Figure 3-4. Display of the Surface of a Shaft in the Polar Plot

Digital Meter

Use the Digital Meter to display the values of the connected data channels
numerically. By default the Digital Meter displays the current value.

However, the Digital Meter also can display the mean value, the root
mean square, the minimum, or the maximum of'the current data block. You
canadd a trend display, which shows whether the last value was greater or
smaller than the previous value, to the Digital Meter. DASYLab displays if
the upper limit is exceeded or the lower limit is undershot, with color
changes. If several data channels are connected, each data channel has its
own Digital Meter in the display window.

List

Use the List module for the numeric display of data channels in a table.
The table displays one column for each data channel. The first column can
display the measurement time, the time, or the measurement numbers.
Whereas the Digital Meter always displays the current value, you can look
back at previous measurement values with the scroll bar in the listmodule.
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Analog Meter

Use the Analog Meter to display the values of the connected data
channels in a gauge display. By default the Analog Meter displays the
current value.

However, the Analog Meter also can display the mean value, the root
mean square, the minimum or the maximum of the current data block. If
several data channels are connected, each data channel has its own
Analog Meter in the display window. The scale can comprise a quarter
circle or a three-quarter circle like a tachometer. You can highlight the
upper or the lower limit range of a scale in color, you can enable the trend
display, and you can select the greatest and the smallest measured value
with a dragindicator.

Bar Graph

Use the Bar Graph to display values of the connected data channels as
bars, triangles, thermometers, or as LEDs. By default the Bar Graph starts
at the smallest value on the scale. For example, if the value range is -10
to +10, you can set the start point to zero at the center of the value range.
Therefore you can see during the measurement whether the bar is in the
positive or in the negative range. If the upper limit is exceeded or the
lower limit is undershot, DASYLab displays this with color changes so
that, in the LED display, for example, red diodes light up in the upper
limit range and blue diodes light up in the lower limit range.

By default the Bar Graph displays the current value. However, like the
Digital Meter or the Analog Meter, the Bar Graph also can display the
mean value, the root mean square, the minimum, or the maximum of the
current data block.

Status Display

Use the Status Display to display states and not values. By default the
Status Display shows two states: OFF, the lamp is red, and ON, the lamp
is green. The threshold value is 1. 5. You can increase the number of
states if you display graphics instead of lamps. To do so, assign a graphic
to every value range. For example, if you have three graphics of a valve,
the Status Display shows a closed valve in the range 0 to 1, a half-open
valve in the range 1 to 2, and an open valve in the range above 2.

You also can use the Status Display as a bit display that converts every
value into 16 bit integer values and displays an LED for each of the 16
bits.
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Selecting Input Modules

The following descriptions provide an overview of the functions of the
input instruments and help you choose the right module for a certain task.

Switch

Use the Switch to output TTL signals manually during a measurement and
to enable triggers, actions, or modules that have a control input. A TTL
signal has either the value 0 or 5. The Switch types On/Off Switch and
Switch output a signal with a constant value of 5 until you click the button
again. The Push button outputs the TTL signal only as long as you press
this button and the One shot Switch outputs the signal after you click for
the length of a data block. If you enable several data channels in the
module, you can create several different switches side by side or on top of
each other.

The switches Start/Stop and Pause/Continue are different from the other
switch types. These switches have no outputs because they affect the
whole worksheet. You can use these switches to stop or to pause a
measurement and to restart a measurement. Use these switches, for
example, in the layout to control a measurement in the full-screen mode.

Slider

Use the slider to generate varying signals manually with a Scroll bar, a
Slider or a Rotary Switch during a measurement. The value range
specifies the smallest and the greatest value and the resolution specifies
the intervals between the individual values. If you enable several data
channels in the module, you can create several varying sliders side by side
or on top of each other. However, you can use only one slider type in a
module. Move the slider with the mouse to the value that the manual
slider outputs. Use the slider to change the settings of other modules
during a measurement, for example, the amplitude of the generator.

Coded Switch

Use the Coded Switch to manually output one of several values
previously entered during a measurement. Turn the Rotary Switch
stepwise to the value, and DASY Lab outputs this value as soon as you
release the rotary switch. If you use the Button Switch, click the
respective button and for the List box select the value from a list. You can
create four coded switches side by side or on top of each other. However,
you can only use one switch type in a module. Use the Coded Switch, for
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example, to control an actuator with up to 16 positions. You specify the
positions in the Coded Switch and can then accurately approach each
position.

Creating Layouts

Create layouts to visualize and to document your measurements. In a
layout you combine display windows with text and graphics to design
visualization screens. You can create multiple customized layouts for
visualization and documentation. You use actions driven by events to
exchange the layout displayed on the screen or to print out measurement
reports.

- Tocreate alayout, click Layout on the function bar. DASYLab
2+ creates a new layout in the layout window if you have not yet created
alayout.

In the layout window you work with an additional toolbar to place layout
elements in the workspace. Layout elements are graphic links to display
windows and input instruments, texts, logos, frames, and lines. To edit
sections of the layout in more detail, right-click and select Zoom from the
context menu.

Figure 3-5. Screen Layout with Display Windows and Switches
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E To create a display window like the Y/t Chart in the layout, click
u Link Graphic on the toolbar and drag open the rectangle anywhere
in the layout. Double-click the empty rectangle and select the Y/t Chart
from the module drop-down list. When you start a measurement,
DASYLab displays the values in the layout just like in the display
window of the Y/t Chart.

== | Toinsertalogo, click Bitmap on the toolbar and drag open a
rectangle. Double-click the rectangle and select the logofile.

For each worksheet you can create up to 200 layouts with Window»New
Layout. To delete the layout, select Window»Delete Layout Page.
During a measurement you can use the selection list in the layout
window function bar to change the layout, or you can use event-driven
actions. Refer to Controlling with Actions in Chapter 5, Controlling
Measurements, for more information about actions.

Specify the size of the workspace in the Layout Page Setup dialog box
which you access from the context menu. You can specify the page size,
the screen display, and various paper formats for the online
documentation. You also can enter a name for the layout which
DASYLab displays in the selection list on the function bar. Select Layout
Settings from the context menu to limit mouse operation to input
instruments or to enable the full- screen mode when a worksheet is
loaded.

Press <Ctrl-F> to enable the full-screen mode during the measurement.
DASYLab hides all worksheet elements such as the function bar, the title
bar, the module bar, the browser, and the info block. In full-screen mode
you start a measurement with <F5> and stop the measurement with
<Ctrl>-F5. Press

<Ctrl-F> to leave full-screen mode and to return to the layout window.

If you insert an action module in the worksheet and, for example, connect
it to a button, you can trigger an action in the layout with this button. For
example, you can change the layout, save it as a graphic, or print out
specific layouts for specific measurement situations.

Active and Passive Layout Elements

In the layout you position the layout elements in the workspace, specify
the size, and align the layout elements to each other. DASYLab
differentiates between the active layout elements such as graphic links
and text links, and the passive layout elements such as text, logos, frames,
and lines.
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@| [U J| DASYLab inserts the active layout elements as a link in the
ST Tayout. You can include every display module and input
module that the worksheet contains in a graphic link. In text links you
only can include digital instruments to display measurement values
numerically.

You can zoom in on diagrams, Y/t Chart displays, X/Y Chart displays, and
Chart Recorder displays in the layout during a measurement. Press the
<Ctr]> key and drag open the area with the mouse button. You can zoom
multiple times. To undo the last zoom, press the <Ctrl> key and right-click
the zoomed area.

You can operate input instruments such as the Switch or the slider in the
layout, for example, to execute selected functions in the full-screen mode.

Passive layout elements are layout labels or decorations and are not linked
to the modules in the worksheet. Passive layout elements are graphical
objects such as lines, circles, ellipse outlines, rectangles, filled ellipses, or
texts. You can use figures in BMP format or WMF format as a background
picture or as alogo. DASYLab creates a reference to the graphic file but
does not integrate the file in the layout. If you copy a worksheet with a
layout to adifferent computer, you must also copy the graphic files into
the respective folder. If you select Options»Default Folders, you can find
the name and the path of the folder Other.

Use the Text line layout element to include simple titles or comments in
the layout. You can rotate a text line, for example, to position the text
vertically next to a display window. Use the layout element Text block to
create multiline continuous text. Use variables and strings to display the
current time, the date, or other system information in the layout.
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Hardware Setup

DASYLab supports many standard measurement and control boards and
various interfaces in order to communicate with external devices. When
you install DASYLab, you select the DASYLab driver for your
measurement acquisition board.

DASYLab distinguishes between DLL drivers that you can use in a
worksheet with other hardware drivers and default drivers that you cannot
use with other hardware drivers. The sound driver is a default driver. The
NI-DAQmx driver is a DLL driver you can combine with other drivers in
a measurement.

Specify in the configurator the hardware driver for the device you are
using. The configurator displays the first time when the installation is
complete in order to, for example, request the license number.

The Configurator

Use the configurator to configure the DASYLab installation according to
your tasks. You can call the configurator any time from the Windows start
menu, for example, to register the driver for a new hardware, to activate
the evaluation version with a valid license number, or to execute an
upgrade.

The configurator in Figure 4-1 lists all packages available on your
computer. The list includes different hardware drivers and field bus
systems. The status indicates whether a package already belongs to the
DASYLab installation and the version number indicates how recent the
package is. Click Enable to use the selected package in DASYLab. Click
Disable to remove the selected package from DASYLab. The package is
not disabled or enabled until you click OK.
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Figure 4-1. Available Packages in the Configurator
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You can import packages which you receive from the manufacturers or
which you download from the DASYLab website. Packages contain, for
example, all files for a driver or for a function extension, or special
worksheet collections. You also can update packages because a package
with a higher version number can replace the earlierpackage.

The DASYLab developer can also use the configurator to create his own
packets. Use the packet definition where you define files and the actions
you need for the installation of your functions.

DLL Driver

DLL drivers have their own interface and can run parallel with other
hardware drivers. Apart from a few exceptions, the hardware drivers for
all DASYLab supported hardware are DLL drivers. After installation,
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the modules for National Instruments hardware are on the Modules tab
of the browser under Inputs/Outputs»NI-DAQmx. Open
Measurement» Hardware Setup»NI-DAQmx to configure the
hardware. If you want to configure individual tasks, open
MeasurementyMeasurement Setup»NI-DAQmx»Measurement
Setup.

The NI-DAQmx driver accesses a configuration program from the
hardware manufacturer. Before you can install the NI-DAQmx driver, you
must install the Measurement Automation Explorer (MAX). The driver
software is supplied with the measurement hardware.

Default Driver

Default drivers use the DASYLab default driver interface because these
drivers do not have their own interface. If you install several default
drivers, you only can use one default driver at a time. For example, if you
want to measure with the sound card, select Measurement»Driver
Selection» Sound Card (Figure 4-2). Then you must end and restart
DASYLab so that DASYLab stores the driver settings.

Figure 4-2. Default Driver for Sound Cards

Installed drivers
oK

Sound Card Cancel

Help

Select the driverthat DASYLab is to load when the program starts
next

Everywhere in DASYLab where you can select a Driver or Hardware,
you now find the settings and the modules of the sound card. The sound
card modules are on the Modules tab of the browser under
Inputs/Outputs» Driver.

Open MeasurementyHardware Setup»Driver to configure the
hardware.

Open Measurement»Measurement Setup»Driver to configure the
measurement. To open the help for the default driver open Help»
Hardware.
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Interfaces

In DASYLab you also can request data over the DDE, TCP/IP, OPC,
ODBC, RS232 and IEEE interface from other programs or external
devices.

Using Online DDE

You can exchange data with other programs that run parallel on the same
computer via the DDE interface (Dynamic Data Exchange). The modules
for these interfaces are on the Modules tab of the browser under Inputs/
Outputs»DDE. DASYLab can request data as a DDE client or, as a DDE
server, can provide data and execute commands.

If DASYLab acts as a DDE server, you must enter the address in the
module:

* Application: Name of the DDE server or of the executing program.
Enter DASYLAB.

* Topic: Data area the client accesses. Enter SetData.

* Name: Module name of the DDE input module.

To establish the communication, the server must start first and then the
client. DASYLab transfers the data in ASCII format.

Exchanging Data over TCP/IP

TCP/IP stands for Transmission Control Protocol / Internet Protocol and
is the basis for the internet and also the intranet. The data source (server)
can be a DASYLab installation that provides data to a higher-ranking
application (client). The modules for these interfaces are on the Modules
tab of the browser under Inputs/OQutputs»ICOM.

The Host IP address specifies the communication partner in the network.
You can enter the IP address as a number, suchas 111.100.101.111,or
as the name of the client such as the computer name or web address. The
transport protocol, such as Www, POP3, or FTP, determines the port address.
DASYLab appends the value of the port address to the IP address with a
colon. For example, if you select www, DASYLab displays the IP address
as111.100.101.111:80.
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Using the OPC-DA Client

Use the OPC interface (OLE for Process Control) to connect DASYLab
as a client with field bus systems and other hardware, provided OPC
servers are available as external drivers. DASYLab receives data from
registered OPC servers only. OPC modules are on the Modules tab of the
browser under Inputs/Outputs»OPC-DA Client. DA stands for Data
Access.

During a measurement DASYLab requests data from an OPC server or
outputs data to this OPC server. For DASYLab as the client, it is
irrelevant where the OPC server is located. The following situations are
possible:

» The server is located on the same computer as the client. In this case
the server is called a local server which runs locally on a computer but
in a different address space than the client application. The
communication between the OPC client and the OPC server runs
slower than with an InProcess server, because Windows must transfer
the data from the server process to the client process.

» The server is located on a remote computer and can be accessed over
the network. This is a remote server. The communication between the
OPC client and the OPC server runs slower because Windows must
transfer the data from the server computer to the client computer over
anetwork.

Reading and Writing ODBC Databases

DASYLab reads and writes data and additional information to ODBC
(Open Data Base Connectivity) databases via the ODBC interface.
DASYLab can access every database that is registered as a data source,
via the Windows ODBC administrator. The modules for these interfaces
are on the Modules tab of the browser under Files.

The ODBC modules do not have inputs or outputs because DASYLab
uses variables and strings to exchange data. Actions control the data
exchange event-driven.

The RS232 Interface

Via the RS232 interface DASYLab receives data and text from external
measurement devices or sends data and control commands to
measurement devices that are connected to the serial interface. The
received character strings can contain measurement values and any text to
which DASYLab assigns strings. The RS232 Input module can receive
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measurement values and texts on one data channel or on separate data
channels. The RS232 Output module outputs values or character strings
which the module reads from strings and variable. The modules for these
interfaces are on the Modules tab of the browser under
Inputs/Outputs»RS232.

Use the RS232 monitor to configure an external device. You can send
strings and read in measurement values to see immediately whether the data
contains control characters.

The IEEE-488 Interface

DASYLab receives data from hardware connected to IEEE boards via the
IEEE-488 interface or DASYLab outputs data via this hardware. The
modules for these interfaces are on the Modules tab of the browser under
Inputs/Outputs»IEEE 488.

You can operate up to 15 measurement devices on one IEEE board. If you
output data to several devices, you must insert a separate IEEE Output
module for each measurement device and in the worksheet each device
must use a different device number.

The IVI Interface

DASYLab receives data from hardware devices, which support the IVI
interface (Interchangeable Virtual Instrument). The modules IVI
Counter, IVI DCPower, IVI Digital Multimeter, IVI Switch, and IVI
Scope are on the Modules tab of the browser under
Inputs/Outputs»IVI.
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Controlling Measurements

The data flow and the sequence of the modules in the worksheet
determine the measurement process. You use triggers, input instruments,
controllers, and actions to control the measurement. You use actions to
execute module- specific functions when an event occurs. DASYLab
executes these actions in the background without data channels, unlike
other control modules. During a measurement you can read in, process, and
output characteristic values and text from variables and strings.

A sequence control is a sequence of worksheets that you link via actions.
You use variables and strings to transfer results from one worksheet to the
next worksheet.

Triggering over Control Inputs

[ Felay_| Some modules have a control input with which you can

o Ko trigger the module or control a function in the module. The

- o control input is always at the first position in the connection
bar of amodule and displays an X with a yellow background.

In the Relay the signal at the control input determines the output of the
data at the inputs. As long as there is a TTL High signal, the relay outputs
the data. The value 0 corresponds to TTL Low and the value 5
corresponds to TTL High. The threshold between TTL Low and TTL High
is 1.5, which means that the relay does not output data as long as the
value at the control input is smaller than 1. 5.

The Differentiation/Integration module does not expecta TTL signal at
the control input but evaluates the data signal. You can specify different
conditions for starting and ending mathematical calculations in this
module. Other modules such as Switch, Signal Router, and Select
Values use the signal at the control input as an index to specify the input
or the output.

Controlling with Actions

The Action module executes event-related, module-specific
] % functions such as resetting mathematical calculations,
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changing the display screen, or stopping the measurement. Like a trigger
module the action module monitors whether the connected input channels
meet the specified conditions. However, when a condition is met, the
action module does not output a TTL signal which influences the data
flow in the worksheet, but activates a module-specific function which
runs in the background. Therefore, the action module has only inputs but
no outputs, unlike trigger modules.

For example, you can use an action to print the Chart Recorder display of
a temperature measurement when the temperature exceeds a certain value.
To do so, select Special»Action on the Modules tab of the browser and
connect the input of the Action module with the monitored data channel
Temperature. Open the dialog box to specify the action. First select the
receiver Recorder, then the module specific action Print, and finally the
trigger event Threshold value exceeded. Enter 50 as the Threshold
value. When you start the measurement, DASY Lab prints the current
recorder display as soon as the temperature exceeds 50 °C.

You can monitor up to 16 different data channels with one action module
or one data channel for which you can specify up to 16 different actions.
You can select modules, or individual module channels, or DASYLab as
the receiver if you want to execute actions that affect the entire worksheet.
Many actions require additional information such as the name and the
path of the data file to be created.

To open an overview of all actions defined in the worksheet, select
Options» Overview of Actions. The list contains the names of the action
modules, the actions, the trigger events, and the receivers. You can open a
second list that contains only the actions of one action module via
Options»Action List.

Synchronous and Asynchronous Actions

DASYLab differentiates between synchronous and asynchronous actions.

DASYLab executes synchronous actions at the data block that meets the
condition. To do so, the data block must arrive at the action module and
the module that receives the action synchronously and must have the same
block start time. For example, use synchronous actions to print visualized
data in real-time. The synchronization is like an additional invisible data
channel which uses computing time even when DASYLab is not
executing an action.

DASYLab executes asynchronous actions directly after the condition is
met. Anasynchronous action influences the data block processed by the
executing module. This need not be the data block that triggered the
action. Use asynchronous actions when the action is independent of the
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data to be processed, for example, connecting and disconnecting channels
to display modules.

DASYLab executes asynchronous actions fast. fDASYLab does not
trigger an action, asynchronous actions do not need extra computing time,
except for the monitoring of the input channels.

Control Sequencer

Use the control sequencer as a worksheet test executive. The sequencer
connects worksheets and controls the sequence of worksheets using
actions. For example, use a sequencer to run different tests with different
worksheets in one experiment. The first worksheet generates calibration
settings and transfers these settings to the next worksheet. Then the
second worksheet controls the measurement acquisition and saves the
measurement values in a file. Finally the last worksheet analyzes and
displays the measurement values.

@u To create a sequencer for this test, click Sequencer on the function
bar. DASYLab opens the sequencer program window. Right-click
the Unknown root entry and select New Worksheet from the context
menu. For example, load the Calibration worksheet. Then load the
worksheets Measure and Analyze consecutively. Right-click the first
worksheet Calibrationand select Set Start Worksheet.

Then create the actions that control the worksheet sequence. Right-click
the Calibration worksheet and select New Action from the context
menu. Select the condition that the value of the variable VAR _101 changes
and then select the action Load and start of the Measurement
worksheet. Then create a second similar action which loads and starts the
worksheet Analysis due to a value change of the VAR _2 variable.

If you now start the measurement, DASYLab loads the Calibration
worksheet. The calibration runs until an action in this worksheet assigns a
new value to the VAR 101 variable. Then DASYLab loads the Measure
worksheet and runs the measurement until the variable VAR 102 receives
a new value. DASYLab loads the Analyze worksheet and displays the
measured values in the open display windows.

The sequencer window shows the worksheets and the actions in a tree
display as in Figure 5-1. Use the context menu to enter comments about
each worksheet that explain the sequence and appear with the worksheet
name in the sequencer tree. The worksheet that starts the sequencer is
additionally labeled Start. The condition and the function to execute is
specified behind each action.
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Figure 5-1. Sequencer for Calibration and Analysis
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Move the worksheets in the sequencer window to change the sequence.
Move an action to create a copy of the action. Use the context menu to
delete worksheets and actions and to editactions.

To save the sequence, click Save on the function bar of the sequencer.
DASYLab saves sequences with the filename extension dsq. If you
execute a sequence on another computer, you must copy the current
worksheets into the folder specified on the target computer under
Options»Default»Folders. A DSQ file contains only references to the
worksheets.

Global Strings and Variables

DASYLab provides 999 variables and strings in order to read, to change,
and to transfer individual values and text stings during a measurement.
For example, you can read the number of processed values in the
Statistical Values module, you can specify the number of classes in the
Histogram Classification module, or you can specify the file and path and
change them during a measurement in the Write Datamodule.

You can use a variable or a string for most module settings for which you
usually enter a value or a text. Right-click the input field and select
Global Variable or Global String. DASYLab opens the overview where
you select a variable or a string. When you select the first free variable,
DASYLab specifies the identifier ${VAR 1}. When you select the first
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free string, DASYLab specifies the identifier $ {STR_1}. In addition to
the free variables and strings you can use system variables such as the
measurement time $ {ELAPSED_TIME}, and system strings such as the
currentdate

${DATE}.

DASYLab offers a selection of variable numbers for module settings that
write a value into a variable. Select an index number for the variables to
be used.

Select Options»Global Variables and Strings»Global Variable/String
Overview for an overview of variables and strings. Folders with free and
used variables or strings are listed on the left side of the tree display. If
you click a variable, the table on the right lists the definition of this
variable. If you open the tree on the left further, you find the folder with
the accessing modules and the read and write data channels. If more than
one data channel writes into the same variable, a red folder symbol warns
of write conflicts.

If you want to assign a value manually to a variable during a
measurement, open Options»Global Variables and Strings»Define
Global Variables. To assign a text to a string, open Options»Global
Variables and Strings» Define Global Strings. In these dialog boxes
you also can edit the default configuration of variables and strings before
and after a measurement. For example, you can assign names to variables
and strings, which DASYLab displays instead of the system names. You
can select several variables and strings to assign the same value to these
variables and strings.

DASYLab saves the definitions of the variables and strings together with
the worksheet. For other worksheets to use these configurations, select
Options»Global Variables and Strings»Export Global
Variable/String to export the variables and strings into a file with the
filename extension . var. If you want to import the configuration, select
Options»Global Variables and Strings»Import Global
Variable/String in the target worksheet and enter the same VAR file.
You cannot edit VAR files because these files have a binary format.

If you want to transfer only the value of a variable or of a string from one
worksheet to the next, enable the settings Write to INI file when
measurement stops or Read from INI file when measurement starts in
the global variable or global strings definition dialog box. When the
measurement stops, DASYLab saves the last value of the variable or of
the string in this INI file in order to read them when a new worksheet
starts. To do so, both worksheets must contain these variables and strings.
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Programming Your Own
Modules

In DASYLab, modules are function units. The module is the container in
which the functions are embedded. The worksheet combines several
modules in order to acquire, scale, analyze, and display data. You
configure the modules to tailor the functions to your application.

The script module enables you to program functions yourself. To do so,
the script module offers the container, which has no functions. You create
the functions with a script which can run in this container. For example,
you can create module inputs and module outputs for measurement
hardware not supported by default. You can program mathematical
functions for a processing module in order to analyze data. However, you
cannot create visualization modules as a script module.

Using the Script Module

Seript The script module is in the Special modules group in the

72, [l browser. If you select the module in the browser and drag it
into the worksheet, the dialog box Predefined Settings
opens. The predefined settings specify the number of inputs and outputs
and their connections. This specifies the tasks for which you want to use
the module. Modules that read data from a file and pass this data on to the
worksheet, only need outputs. Modules that receive data from the
worksheet and write this data into a file, only need inputs. Modules that
process data need inputs and outputs.

After you have specified the predefined settings, DASYLab creates a
script module. DASYLab saves the predefined settings as binary data in
the module, which means you cannot view or change the predefined
settings. At the same time the script which you want to create must be
based on these predefined settings. For example, you cannot load a script
for an output module into an input module later on.

In the script module you now specify the type of data to be processed.
Double-click the module and select Channel Properties. In the channel
properties dialog box you specify which data the script module accepts at
its inputs and which data the module outputs. If the module processes
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only continuous time data, you do not need to make any settings. If the
module processes spectral data or histogram data, or if the data has gaps
or data blocks that differ in length, you must change the settings. The
channel properties impact all data channels of the module. Like all
DASYLab modules, the script module can contain up to 16 data channels
which you can specify in the script together with the block size and the
sampling rate of the data.

DASYLab saves the channel properties as binary data in the script
module. However, you can view and change the channel properties while
youdevelop your module. As soon as you export the module and include
it in the application, DASYLab closes this access.

Like all DASYLab modules, the script module has a channel bar where
you select the data channels before a measurement. The settings are on
two tabs: Channel for the channel settings and Module for the module
specific settings. The first time you open the module dialog box, you find
the three parameters a, b, and ¢ on the two tabs . These parameters are
placeholders for the settings which you still have to define in the script.

Programming a Script

You program the functionality of the script module in a script. Click Edit
in the module dialog box to create a script on several tabs. Each tab
represents a specific module function which the module calls at specific
events such as the start of the measurement or opening the module dialog
box. The following overview is a list of the individual module functions:

+ info, pvar — These module functions provide variables which
specify the module properties. In info you initialize the variables
which DASYLab saves with the worksheet. In pvar you create
temporary variables which are only available during the
measurement.

+ DiglInit, DigEvent, DIgOK, DigCancel — These module functions
specify the settings in the module dialog box. In DIgInit you specify
the settings for the module and for each channel. In DIgEvent you
define the dependencies between the settings, for example, in order
to first select the Color and then enable the color selection. In DIgOK
you transfer the values the user entered into the module to the
variables when the user clicks OK. In DIgCancel you reset the
module initializations if the user clicks Cancel.

» SetupFifo — This module function specifies the channel properties
of the data blocks. In SetupFifo you check whether the module can
process the incoming data and transfer the properties of the data to
be output to the subsequent modules. If the module has no inputs, the
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output channels receive the default values. If the module has no inputs,
DASYLab does not call the SetupFifo.

* ProcessData, ProcessValue — These module functions process the
data. DASYLab calls the main function ProcessData regularly
during the measurement in order to read or process data from a
measurement hardware or to write the data into a file, or to output
data to the measurement hardware. ProcessData can call Process
Value in order to process single values.

+ Start, Stop — These module functions refer to the measurement. In
Start you define the measurement preparation and in Stop the
measurement feedback.

* Load, Save — These module functions specify the loading and
saving of the module in the worksheet. In Load you prepare the
module for the measurement. In Save you prepare the module for the
storage.

* Create, Delete — These module functions specify how the script
module is created and deleted in the worksheet. In Create you
specify the number of inputs and outputs and also the channel
assignment. In Delete you define clean up operations such as closing
files or disconnecting hardware.

You program the individual module functions in the Python programming
language. Python has a simple syntax and a complex command structure.
DASYLab provides special script functions for data handling, channel
definitions, and the settings in the module dialog box. During the
programming process, you test the functionality of your module in the
worksheet and save the module with the worksheet.

If you have programming experience, you can also edit the script in an
external editor. In an external editor you can view the complete script and
use the editing functions of the selected editor for programming. Click
Use External Editor in the module dialog box and save the script as a
file.

DASYLab creates a text file with the filename extension . py. In the
module you can no longer edit the script you saved externally. Instead you
must load the script file into the module in order to test the programmed
module functions. If you use the script file in a different script module,
this module must have the same predefined settings and channel settings
as the original script module. You select the external editor in the
configurator.
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Exporting a Script Module

The reason for programming script modules is to have new modules in
DASYLab. Users can select the new modules in the browser and
configure them after inserting them in the worksheet. If you want to share
a script module with another user, you must export the script with the
programmed script. You then generate a script package from one or several
exported script modules and register this script package in DASYLab.

In the first step, you double-click the script module and select Export.
DASYLab opens the export dialog box with the basic settings and the
optional additions. Enter, for example, UserFunction on the Basic
Settings tab as the name for the module and select the module group
Special. Specify the folder in which DASYLab saves all files for the new
module. On the Additions tab you can assign a help file and a graphics
symbol to the module.

é Note Note that entries and filenames are case-sensitive.

Python as well as DASYLab differentiate between names that are
only lower case and those that are also upper case
(newmodules<>NewModules).

In the second step, you open Options»Create Script Package and enter
the name of the script package (MyModule), the source folder with the
exported script modules, and the destination folder for the script package.
In the destination folder, DASYLab creates a script package with the
filename extension .dly (MyModule.dly). A script package is similar
to a function library.

In the third step, you register the generated script package in DASYLab.
Anentry in dasylab.ini inthe [Extend] section is sufficient to test
the script package on the test computer. Enter the name of the package
and the filename extension, for example, DLL5=MyModule.dly. If you
then start DASYLab, the new module UserFunction is in the module group
Special in the browser. If you insert the module in the worksheet and open
the module dialog box, the properties you programmed in the module
function Diglnit are on the tabs Module and Channel. Only the buttons
OK, Cancel, and Help remain from those of the editable script module.
All functions for editing a script have otherwise disappeared.

Use the configurator to install your own modules on a different computer.
Use the action Slot to generate a package definition for the new
module. This action not only copies the script package MyModule.dly
on the destination computer into the DASYLab folder, but also inserts the
required entry into the dasylab.ini ata free position in the

[Extend] section. Finally, create a configurator package with the
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filename extension . d1p. The user then only has to double-click this
configurator package on the destination computer in order to add the new
module to the already installed DASYLab.
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Configuring the Data Flow

DASYLab transports data in the worksheet in blocks from module to
module. DASYLab does not output a data block to the next module until
the current data block is completely filled with data. DASYLab
distinguishes measurement data, which are from the measurement devices
and data sources and which most modules output, spectral data which are
the result of a fast Fourier transform, and histogram data which contain
the count results of a classification. DASYLab outputs a time stamp, the
sampling rate, and the block size with every datablock.

The size of the data blocks and the sampling rate determine the processing
speed, which in turn determines the data flow in the block diagram. The
Block size specifies how many values a data block contains. The Sampling
rate specifies how fast DASYLab generates data or requests the
measurement values from the board. The Response time in the block
diagram depends on the ratio between the block size and the sampling rate.
Table 7-1 lists the response times for some block sizes and sampling rates.

Table 7-1. Response Time

. Sampling rate Response time
Block Size (1/Second) (Second)
1 1 1
1 1000 0,0
1000 1 1000

The response time specifies the period of time in which DASYLab acces-
ses all modules in a worksheet. Depending on the size of the work-sheet
and the computer power, DASYLab cannot undershoot a certain limit.

If, for example, the worksheet comprises 100 modules and the specified
block size to sampling rate ratiois 0. 001 s, DASYLab must process
100 modules in 1 millisecond. This leaves each module 10 microseconds
to process its data. DASYLab aborts the process because the time is too
short.

Note The smaller the ratio between block size and sampling rate
is, the more often the worksheet gets updated. Use a ratio of
0.1 s tols.
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% Click Measurement Setup on the function bar to specify the sampling
rate and the block size. You can specify the sampling rate and the

block size in the measurement settings dialog box or you only specify the
sampling rate and DASY Lab specifies the block size as shown in Figure 7-1.
If you do not have hardware installed, DASY Lab uses the computer clock as
the timer. I[f you specify a default driver under Measurement»Select Driver,
you can use the hardware clock. The settings Driver buffer, Analog output,
and Digital output also refer to the defaultdriver.

Figure 7-1. Measurement Settings of the Default Driver

General settings

Sampling rate: 10000000 -~ Uit Hz ~

Block size 512 Specify automatically Cancel

OK

Synchronization @ Computer clock Hardware Help

Driver settings
Driver buffer:
Sampling mode:
Blocks per series:

Waiting time [s]:

Analog output
Output mode Synchronous Asynchronous
Output buffer: Fill once Fill continuoushy
Output rate:
Output start:

Digital output

Qutput mode Synchronous Asynchronous

Output buffer: Fill ance Fill continuously
Output rate:

Output start:

Disk
Disk streaming streaming
] Enable rile:

re'\Public’Documents\DASYLab\14.0.0eng data\DEFWRITE.DDF

y Depending on the installed hardware, DASYLab provides further
timers apart from the system clock and the default driver clock.

Click Time Base Setup on the function bar to view the tabs of the available
timers and to change them. The DASYLab tab contains the system clock
settings. The Driver tab contains the default driver settings. If you install
DLL drivers with individual sampling rates such as NI-CAN or instruNet,
the time base settings dialog box also contains the tabs NI-CAN and
instruNet.
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Optimizing Processing Time

The overall operating performance of DASYLab depends on the hardware
resources of the computer, on the data acquisition device, and on the
complexity of the worksheet. The following section provides tips on how
to increase the DASYLab operating speed.

* Increase the amount of memory (RAM) on your computer. If you
often write into the Windows swap file, your system slows down.

* The more powerful your computer is, the higher the sampling rates
can be.

* Disable unnecessary display functions, such as the grid display in the
display windows.

* Enable the fixed time base setting in the Axesmenu.

* Ifyoumeasure with a high sampling rate (for example, to process high
frequencies with an FFT), you preserve DASYLab resources if you
use the Separate module. Todo so, insert the Separate module, which
only lets every hundredth data block pass between the modules
Analog Input and FFT. DASYLab calculates an FFT for every
hundredth data block, which includes high frequencies due to the high
sampling rate.

If the measurement does not require an online display, you can first save
the data in a file and later read and evaluate the data off-line.

Significant Digits

The accuracy with which DASYLab process data depends on the
transferred data type. The modules usually work with the 8-byte double
data type. The accuracy of the double data type is altogether 15 places.
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Module Groups

Twelve module groups with related modules contain the DASYLab
functions. The appendix provides an overview of the available modules
and their functions. The installed DASYLab license determines which
modules are available. Modules that are not part of your license are
dimmed in the browser. Refer to your DASYLab vendor to extend your
DASYLab license.

The Input/Output Modules Group

The input/output modules group contains the hardware modules of the
installed hardware driver, and the interface modules for communication
with external devices and programs.

For example, if you have installed the NI-DAQmx driver for National
Instruments hardware, the associated modules are in the sub-folder

NI DAQmx. If you have installed the DAP driver for Microstar
Laboratories hardware, the associated modules are in the sub-folder DAP.
If you have installed the sound driver, you can select the sound driver
under Measurement»Select Driver and access the associated modules in
the sub- folder Driver.

The interface modules are in sub-folders with respective names. The
subfolder OPC DA Client contains the modules OPC Input and OPC
Output to exchange data with OPC servers, which are registered on the
network or the local computer, via the OPC interface.

The sub-folder DDE contains the modules DDE Input and DDE Output
to exchange data and commands with other programs via the DDE
interface.

The sub-folder ICom contains the modules ICom Input and ICom
Output to exchange data and text in a network via the TCP/IP interface.
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The sub-folder ModBus contains analog modules and digital modules to
communicate with PLCs via the ModBus protocol.

The sub-folder RS232 contains the modules RS232 Input and RS232
Outputto exchange data and text with external measurement devices that
are connected to the serial interface.

The sub-folder IEEE 488 contains the modules IEEE488 Input
and IEEE488 Output to exchange data with external measurement
devices connected to IEEE boards.

The sub-folder IVI contains the modules IVI Counter, IVI DCPower,
IVI Digital Multimeter, IVI Switch, and IVI Scope which are based on
the respective class specifications of the IVI foundation.

The Trigger Functions Modules
Group

The trigger functions modules group contains various trigger modules to
control the data flow in the worksheet with conditions. When the
condition is met, trigger modules output a TTL signal.

The Pre-/Post-Trigger module continuously monitors whether data
channels exceed limit values whereas the Start/Stop Trigger module
checks when data channels exceed a limit value the first time. The Combi
Trigger module continuously monitors the start condition and then the stop
condition of data channels.

The Sample Trigger module continuously monitors the duration of
trigger events, whereas the Trigger on Demand module monitors the
increase or decrease of successive measurement values.

The Relay module outputs the connected data channels when a trigger
input or an action meets the condition. Unlike the other trigger modules,
the module does not output TTL signals.

The Mathematics Modules Group

The mathematics modules group contains modules to process data
channels mathematically.

Use the Formula Interpreter to define your own formulas, to calculate
data channels, and to combine several data channels with each other. In
the Arithmetic module, you select predefined functions to calculate one
data channel or to link two channels. The Trigonometry module uses
trigonometric functions for data channels and the Differentiation/
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Integration module differentiates or integrates data channels.

To scale data channels you can use various modules: linear scaling,
scaling with table of reference points, thermocouple linearization,
PT100/NI100 linearization, and offset adjustment.

The Comparator module compares one channel with a constant or two
channels with each other and outputs a TTL level if the values are similar,
equal, or greater. The Logical Operations module links TTL signals to
each other. The Flip Flop module provides the functionality of various
flip flops (D-Flip Flop, JK-Flip Flop, RS-Flip Flop, and Monoflop).

The Bit Mask module converts measurement values into binary numbers
in order to shift bits or to combine bits and to output the new values. The
Gray Code module uses the gray code to decode the angle encoder
signals.

Use the Slope Limitation module, for example, to cut off peaks in a data
channel caused by outliers. The Reference Curve module calculates a
tolerance range for data channels and saves the mean values and the
values of the maximum and minimum curve in a file that the statistics
module Check Reference Curve and the display module Chart
Recorder use.

The Statistics Modules Group

The statistics modules group contains modules for the statistical
evaluation of data channels.

The Statistical Values module calculates characteristic values for each
data block, such as the standard deviation, the variance, the mean value,
the minimum value, and the maximum value. Torecognize and to output
extreme values in data blocks use the Minimum/Maximum module
which, unlike the Statistical Values module, can determine several
extreme values in one data block.

The Regression module calculates polynomials for approximation curves
for the incoming data. The Counter module counts data and events, such
as extreme values or level crossings, and rising or falling edges. The Sort
Channels module sorts values in data channels in ascending or
descending order. The Select Values module filters out single values
based on their position in the datablock.

The Check Reference Curvechecks whether data channels lie
within a tolerance range. The Pulse Analysis module evaluates
pulse width modulated signals statistically.

The Histogram Classification module calculates the single frequencies
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or cumulative frequencies of the measurement values within specified
classes. The Rainflow Classification module runs classifications with one
parameter or two parameters. Use the Two Channel Classification
module for two-dimensional counting procedures, for example, to create a
diagram of bearing load rotational frequencies.

The Signal Analysis Modules Group

The signal analysis modules group contains modules for calculating
frequency components of signals or for analyzing the similarity of signals.

The FFT (Fast Fourier Transform) module transfers signals from the time
domain into the frequency domain. You can calculate real FFTs or
complex FFTs, or you can calculate an inverse FFT to transfer a signal
from the frequency domain into the time domain. The FFT Filter module
filters specific frequency components from the results of an FFT, whereas
the modules FFT Maximum and nHarmonic search for maximum values
inthe FFT results. Use the Data Window module to multiply data
channels with non-periodic signals with a window function to prepare the
data channels for an FFT.

The Third/Octave Analysis module addsup the amplitude values ofthe
FFT in standardized logarithmic frequency intervals in order to determine
the volume in frequency ranges instead of the amplitude of each
individual frequency.

The Digital Filter module filters data channels with digital IIR filters.
The Correlation module uses the cross correlation to calculate the
statistical similarity of two data channels and uses auto-correlation to
calculate how well a data channel matches a time-shifted version of itself.

The Period Check module uses a specified zero line or reference line to
search for the first zero crossing of a signal.

The Harmonic Distortion calculates in the frequency range the
amplitude and the phase of the fundamental frequency and up to 48
harmonic frequencies.

The Electro Technical Characteristics module performs calculations
from two incoming current and voltage data channels for example, the
power, the phase angle, or the input frequencies.

The Polar/Cartesian module converts polar coordinates into cartesian
coordinates and vice versa.

The Resample module converts vibrations at a rotating axis into the
rotation angle, for example, the vibrations of an engine shaft.
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The Control Modules Group

The control modules group contains modules for generating signals, for
controlling the data flow in the worksheet, and for executing control
functions.

The Generator module generates various signals such as rectangular
signals, sine signals, or sawtooth signals. The Sequence Generator
module generates time-dependent, analog set points and digital control
commands with a user-defined program. Use the modules Switch, Slider,
and Coded Switch to enter data manually during ameasurement.

The Time Delay module outputs incoming data channels with a time
delay. The TTL Pulse Generator generates TTL signals time-dependent
in order to control processes. The Stop module terminates the
measurement.

The Latch module outputs the last data value continuously, event-driven,
or after a signal at the control input. The Signal Router module
distributes incoming data values event-driven onto several outputs.

Use the modules PID Control and Two-Point Control to control
processes.

The Write Global Variable module saves the incoming measurement
values in variables. The Write Block Time saves time information in
strings. The Read Global Variable module outputs values of variables to
the worksheet.

The Sate Machine module outputs the last data value continuously,
event-driven, or after a signal at the control input. The Signal Router
module distributes incoming data values event-driven onto several
outputs.

The Display Modules Group

The display modules group contains modules for displaying measurement
values and results as complete blocks in separate display windows or in a
layout. You also can configure the display window during the
measurement.

The modules Chart Recorder, Y/t Chart, and X/Y Chart display data
channels as curves. During the measurement you can zoom, scroll, and
measure these curves with cursor lines.

The Diagram module displays data channels as a Chart Recorder, a Y/t
Chart, or as an X/Y Chart. You can group curves in axes systems as you
like, and zoom and measure the curves offline.
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The Polar Plot module displays pairs of data channels such as the
measured volume around a dummy head and the corresponding angles as
curves in a polar diagram.

The modules Digital Meter and List display data channels numerically.
Use the bar display of the Bar Graph module and the pointer display of
the Analog Meter to display slow procedures. The Analog Meters, Bar
Graphs, and Status Displays are freely scalable and help visualize
procedural operations on test stands.

The Files Modules Group

The files modules group contains modules for reading and saving data.

The Read Data module reads ASCII, IEEE, FlexPro, and DASYLab
DDF file formats. The ODBC Input module reads data from ODBC
databases.

The Write Data module saves data in ASCII, IEEE, DaDisp, DAP-
Vector, DASYlab DDF, NI TDM, and DIAdem DAT, Famos, FlexPro,
nSoft, Remus and SignalysDOS files. The ODBC Output module writes
data into ODBC databases.

The Backup Data module archives already saved data on external storage
media.

The Data Reduction Modules Group

The data reduction modules group contains modules for reducing large
data quantities to specified characteristic values or data sections.

The modules Average and Block Average reduce data blockwise to mean
values or to extreme values.

Use the Separate module if the sampling rates are high in order to output
just one value from each data block or to output just one data block after a
number of rejected data blocks. The Cut Out module outputs only a
specific number of the first values in every data block.

The Multiplexer module combines several data channels into one data
channel whereas the Demultiplexer module distributes one data channel
onto several data channels either value-wise or blockwise.

The Signal Switch module changes the data input either time-controlled
or amplitude-controlled in order to only output data of the active data
channel. The Circular Buffer module saves incoming data and outputs
the data event-driven. In contrast the Shift Register module collects the
values of every data block and then outputs the new data block event-
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driven.

The Network Modules Group

The network modules group contains modules for exchanging data and
messages in networks. If your installation includes the DASYLab net
license, you can use up to 32 network modules in one worksheet.

Multiple DASYLab programs that are installed on different computers in
one network can communicate using the modules Net Input and Net
Output. Use the Message module to create messages or warnings which
you can send via the Message Output module to a Message Input
module in the worksheet on another computer in the network.

The modules DataSocket Import and DataSocket Export exchange
data with OPC servers and National Instruments DataSocket servers.

The Special Modules Group

The special modules group contains various modules with special
functions such as black boxes and actions.

Use the Empty Black Box module to create sub-worksheets in order to
structure complex worksheets and to increase the possible number of
modules in the worksheet. The Black Box module communicates with the
worksheet using the modules Export and Import, which can only be used
with black boxes.

Use the Action module to control event-driven procedures in the
worksheet modules and to create sequence controls. Use the Message
module to visualize and to document the defined actions on your
computer. You send messages with the E-Mail module.

The Time Base module generates time data or extracts time data from
data channels and the Signal Adaptation module synchronizes data
channels with different sampling rates to a common time base.

The Script module offers the basis for creating a module with user-
defined functions. You program the functions and properties in Python
and register the exported script packages in DASYLab.

The Add-On Modules Group

The add-on modules group contains modules that were created with the
DASYLab Extension Toolkit. You can purchase the add-on modules and
install the respective DLLs (Dynamic Link Library), or you can create
your own modules with the Extension Toolkit in order to extend the

© National Instruments Ireland Resources Limited A-7



DASYLab 2016
DASYLab functionality.

The Convolution module weights a time function with other time
functions, for example, to filter the signal. The Weighting module
evaluates data blocks. The Transfer module uses the input signal and the
output signal to calculate the properties of the interjacent, linear, and
time-invariant transfer system.

The Universal Filter eliminates distorting frequency components with
user- defined digital filters. The Save Universal File module saves data
in the Universal File Format 58.
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Tips and Tricks

The following tips and tricks are designed to help you create and process
worksheets:

Order the modules on the screenneatly.

Create short connections between the modules and avoid superfluous
channel branches and channel crossings so that you can follow the
data flow in the worksheet.

Try to keep all channels that go from one module to the next parallel
or bundled.

Include as many channels as possible in a single display module. A
Status Display module with 16 data channels requires less computing
power than 16 individual Status Display modules.

Label your modules so that others can easily understand the functions
and tasks of the modules.

Save the development steps of your worksheets in files with
successive names. This allows you to go back to a previous
development step.

Use black boxes to store tested subsets of the worksheet. This creates
a library of functions that you can re-use in other worksheets.

If you work with many black box modules, configure each with a
different background color. For example, choose darker colors the
deeper the black box lies in the worksheet.

© National Instruments Ireland Resources Limited B-1



DASYLab 2016

Troubleshooting

The following section deals with frequently asked questions:

A worksheet is not loaded

1 cannot load a worksheet I saved earlier. I am using the same
hardware, but DASYLab reports that this worksheet does not match the
installed hardware.

DASYLab does not save the measurement board settings with the
worksheet. If you made changes to your board settings since you last ran
the worksheet, DASYLab cannot recognize or reset the changes. In order
to use the worksheet again, you must restore the hardware settings to
match the worksheet. For example, switch the board from 8 DIFF to 16
SE and if necessary, reactivate the expansion boards that were active
when you saved the worksheet.

Real time output — yes or no?

I want to connect a Switch module to a digital output. Should I select
the Output in real time option?

Whether or not you select this option depends on the output mode setting
of the digital output module. If the output is set to synchronous, output in
real time must be enabled. If the output is asynchronous, output in real
time can be disabled.

If Output in real time is not active, the data is generated as fast as
possible, usually faster than the synchronous digital output can process the
data. If the switch is toggled, the output first processes all the data held
back before the change can take effect.

If the output is asynchronous, the data is processed as quickly as it is
received;the data is not held back in the same way.

This tip applies also to any module that generates data (slider, generator,
Switch) and is output to an analog output on the acquisition board.

Maximum worksheet size?

I want to build a complex worksheet and only can insert 256 modules in
the worksheet. How can I insert more modules?

Use the Black Box module to create one or more sub-worksheets. You can
find a black box under Modules»Special. You can create up to 256
modules in a black box like in the main worksheet. You can insert a black
box just like any other module. Double-click the black box to open a sub-
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worksheet. Use the Import/Export Modules to exchange data with the
level above.

Only 16 branches on a data channel?

1 need to use a channel more than 16 times. How can I create more
than 16 branches?

Use a mathematics module with the NOP function (No Operation).
Connect one of the data channel branches to this module and use the
outputs for 16 more branches.

The display is too slow!

My worksheet takes too long to display the acquired data in the
display windows. What can cause that?

The following factors can slow down the display considerably:
* Your block size is too big for the samplingrate.

* Youconfigured a separate module in such a way that it ignores a large
number of blocks. You will not see a response until the next data block
passes. The time behavior is the same in block-wise and sample-wise
separation.

* The average module is configured to average blockwise and you did
not change the output block size to reflect the data reduction. The
output blocksize also affects a consecutive separate module that
executes a data-reduction blockwise.

* You have specified a very high value for No. of blocks in the
modules Histogram or Statistical Values. The module needs a long
time to output the data.

+ If the hardware is incorrectly configured, data may not displayed
because the hardware is not acquiring data. Check the hardware
settings, especially the board type, the base address, the IRQ channel,
and possibly the DMA channel.
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