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Product overview 2
2.1 Introduction to PC-Based Control 

Components 
The Windows Automation Center with real-time extensions (WinAC RTX 2010) software 
package includes the following components: 
● Windows Logic Controller RTX (WinLC RTX V4.6) 
● IntervalZero RTX 2009 
● WinAC Time Synchronization V4.2 
● Automation License Manager V5.0 SP1 
● SIMATIC NET V7.1 SP2 and SIMATIC NET V8.0 including license for  

Softnet S7 Lean V8.0 
You install WinAC RTX and the documentation from the installation DVD included  
with your release. 
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Introduction 
The PC-based controllers of WinAC (Windows Automation Center) provide the same 
functionality as SIMATIC S7 CPUs (hardware controllers). The Windows Logic Controller 
with real-time extensions (WinLC RTX) provides the functionality of a programmable logic 
controller (PLC) in a real-time, PC-based environment. WinLC RTX uses the IntervalZero 
RTX (formerly Ardence) real-time extension for Windows and is fully code-compatible with 
the SIMATIC product family. 
As part of the SIMATIC family of automation products, WinLC RTX can also communicate 
with STEP 7 or other SIMATIC products, such as WinCC flexible or other SIMATIC S7 
automation systems, including any of the PC-based controllers, over PROFIBUS or  
Industrial Ethernet networks. They use the same method to communicate with distributed 
I/O, for example, with an ET 200S device. They use PG/OP communication  
(PROFIBUS or Industrial Ethernet) for connecting to STEP 7 or other programming software 
on another computer. 

 
You can use the same programming languages, program structure, and programming user 
interface (STEP 7) as for hardware PLCs to develop your process control solution.  
Programs that have been written for S7 automation systems can be used on PC-based 
controllers and vice versa. The PC-based controllers contain a controller panel (Page 17) 
that runs on the PC. With these capabilities, you can use WinLC RTX in  
a typical factory automation.  
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2.2 Introduction to the WinAC RTX controller panel 
The controller panel corresponds to the front panel of the SIMATIC S7 CPUs.  
It is used to start or shut down the controller and to perform other operations.  
The controller panel is a display window on your PC that contains the following elements for 
working with the controller:  
● Two operating mode selector positions for changing the operating mode of the controller  

(Page 60) (similar to the mode selector switch on an S7 CPU front panel). 
● An MRES switch position for resetting the memory (Page 76)  
● Status indicators (Page 77) for the controller 
● Menus for controller operation 

Different versions of the WinLC RTX controller panel 
The user interface of the WinLC RTX controller panel can look different, depending on the 
platform or software package. 
 
WinAC RTX on a standard PC WinAC RTX F on a standard PC 

  

 
WinAC RTX on an Embedded Controller WinAC RTX F on an Embedded Controller 
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2.3 Relationship between the Controller and the Controller Panel 

Opening and closing the controller panel 
Opening and closing the controller panel does not influence the state of the controller.  
The status of the switches and the LEDs are stored in the controller. 

WinAC RTX icon in the Windows taskbar 
The  icon is displayed in the Windows taskbar whenever the controller is in operation. 
You can double-click this icon to open the controller panel when the controller is in operation 
and the controller panel is closed. 
The color of the background frame of this icon provides some additional information  
about the controller: 
● Yellow: The controller is in STOP mode. 
● Green: The controller is in RUN mode. 
● Red: The controller is in a defective state. 
Here, it is the color, rather than the mode selector position, that indicates the actual 
operating mode. For example, the mode selector can be set to RUN, but the controller  
can be in STOP mode due to a program execution error or an operating mode  
change from STEP 7. 
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2.4 PC-based Control Features 

Real-time process control  
WinLC RTX is a software version of an S7 controller that adds real-time control provided by 
a real-time subsystem for the Windows operating system. WinLC RTX executes STEP 7 
user programs like other S7 automation systems and allows for easy integration with STEP 7 
and standard Windows applications. WinLC RTX runs in two separate environments: 
processes that run in the real-time system and processes that run in the Windows 
environment.  
● The processes that run in the real-time system execute the STEP 7 user program for 

WinLC RTX. The process control is assigned the highest priority. 
● The processes that run in the Windows environment perform other operations, such as 

communication and interfaces to Windows systems and applications. 

Advantages of real-time extensions (RTX) 
WinLC RTX uses real-time extensions (IntervalZero RTX) to provide the following functions: 
● Deterministic operation ensures the response is predictable. Execution of the  

STEP 7 user program occurs entirely in the real-time subsystem, thus reducing "jitter". 
● The control process is protected from Windows system errors (Page 97). WinLC RTX is 

notified of all Windows shutdowns (including those caused by a "blue screen") in order to 
programmatically shut down in an orderly fashion. You can configure Windows to reboot 
automatically after a system failure. This option is accessed by the "Startup and 
Recovery" button under the "Advanced" tab of System Properties in Windows Control 
Panel. 

SIMATIC functionality supported by WinLC RTX 
WinLC RTX provides the following features: 
● Support for automatic startup of WinAC RTX when the PC boots or during manual startup 
● Implementation of a large number of S7 code blocks of SIMATIC controllers: organization 

blocks (OBs), system function blocks (SFBs) and system functions (SFCs). 
● Support for PROFIBUS DP for communication with distributed I/O, including DPV0 and 

DPV1 (Page 120) slaves (PROFIBUS DPV1 provides enhanced alarm and status 
reporting, in order to communicate with intelligent slave devices). 

● Support for PROFINET (Page 125) communication via Ethernet submodules:  
PROFINET I/O (Page 128) for communication with distributed I/O and  
PROFINET CBA  (Page 138) (Component Based Automation) for communication with 
other CBA components. 

● Support for a maximum of four individual subnets for connecting the distributed I/O. 
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● Support for isochronous (Page 123) mode for PROFIBUS DP and PROFINET IO 
subnets, which allows WinLC RTX to operate with a constant bus cycle. 

● Uses S7 communication services and offers compatibility with SIMATIC applications, 
such as STEP 7, WinCC, and WinCC flexible for tasks such as programming, testing, 
monitoring, and visualization. 

● Enables point-to-point communication (Page 115) between controllers (hardware and 
software) on the network. 

● Supports routing of S7 communication through the submodule CPs of WinLC RTX, which 
allows STEP 7 on one subnet to connect to an S7 station (such as an S7-400 controller) 
on a different subnet. 

● Supports time synchronization via NTP 
● Provides the ability to archive and restore control programs (Page 85). 
● Allows you to control the operating mode of the controller and to view status information 

in the controller panel (Page 17). 
● Provides a tuning panel (Page 79) for optimizing system performance. 
● Provides time synchronization as either a time master or slave. 
● Use of the supplied SIMATIC NET Softnet-S7 Lean license enables the following: 

– Use of the SIMATIC NET OPC server 
– Ability of OPC client applications to access process data 
– SIMATIC communication via the Windows-Ethernet interface of the PC 

● The Web server allows you to monitor your PC station via the Internet or via your 
company's Intranet. This allows evaluation and diagnostics to be carried out remotely. 

Use of WinLC RTX with WinAC ODK 
WinLC RTX can be used together with WinAC ODK (Open Development Kit) for your total 
automation solution. WinAC ODK (must be ordered separately) enables you to develop 
additional software: 
● Custom PC applications in a higher-level programming language for the purpose of 

exchanging data with WinLC RTX via one of the following programming interfaces  
of the STEP 7 user program: CCX (Custom Code Extension) and SMX (Shared Memory 
Exchange). 

● Software for user interfaces, such as a custom controller panel, to display status 
information and perform controller operations using the CMI  
(Controller Management Interface) programming interface. 
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2.5 System Requirements 
To use WinLC RTX, your PC must meet the following requirements:  
 
Category Requirements 
Operating system Microsoft Windows XP Professional Service Pack 2 and 3 

Microsoft Windows 7 Ultimate, Professional and Enterprise 
Note: WinAC RTX (F) only supports the 32-bit variants of the operating systems. 
IntervalZero (formerly Ardence) RTX 2009  
(included in the product package of WinAC RTX)  
Note: Some hardware configurations that are not SIMATIC industrial PCs do not 
support installation and operation of IntervalZero RTX. The hardware and 
software requirements for IntervalZero RTX can be found in the RTX Runtime 
Release Notes on your installation DVD. 

Processor  
and memory 

PC system:  
 900 MHz or higher 
 At least 1 Gbyte of RAM 
 BIOS must support plug-and-play (ACPI, Advanced Configuration  

and Power Interface) 
Note: Multi-core and hyperthreading systems are also supported. 

Supported 
Windows HALs 

HAL (Hardware Abstraction Layer): 
 MPS multiprocessor PC 
 ACPI uniprocessor PC 
 ACPI multiprocessor PC 
Note: WinAC RTX does not support standard HAL, since PIC  
(Programmable Interrupt Controller) systems are not supported. 

Hard disk Hard disk with 125 Mbytes of free memory space for complete installation. 
During setup, it can specified that certain components, such as documentation, 
are not to be installed in order to save memory space.  
Note: We recommend that you use an NTFS type file system. 
The setup program uses at least 1 Mbyte of available memory on the C:\ drive 
for the WinLC setup program (setup files are deleted once the installation  
is complete). 

Operator interface Color monitor, keyboard and mouse or other pointing device (optional)  
that are supported by Windows 

Communication 
interface 

One or more communication interfaces for communication with STEP 7 or other 
S7 applications or for communication with distributed I/O 

Siemens software Programming and configuration software: STEP 7 V5.5 with installed hardware 
update for WinLC RTX. 

SIMATIC NET 
(optional) 

You only have to install SIMATIC NET from the WinAC RTX installation DVD if 
you need functionality such as use of the OPC server. 
The SIMATIC Softnet-S7 Lean license (6GK1704-1LW63-3AA0) is contained in 
your WinAC RTX installation package. 
Additional information regarding SIMATIC NET products for PC-based 
automation can be found in the SIEMENS Mall or the ST PC Catalog. 
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2.6 Windows User Privileges 
You do not need Windows administrator rights (ADMIN) to perform WinAC RTX operations, 
such as: 
● Changing the operating mode (Page 60) of the controller 
● Changing the idle time or the minimum cycle time (Page 200) of the controller 
● Archiving or restoring (Page 85) control programs 
● Setting the security options (Page 70) 
As a "power user", "user", or "guest", you can perform any operation from the WinLC RTX 
controller panel. You can manage the network rights for the PC station within your 
application and prevent conflicts during installation, commissioning, and operation of a  
PC-based automation solution. 

User change 
If you configured WinLC RTX to start at PC boot (controller was started automatically),  
one user can log off and another user can log on without affecting the controller operation. 
If you have not configured WinLC RTX to start at PC boot (controller was started manually), 
the controller will be shut down when the user changes. 

Restrictions for Windows XP 
The following table shows which functions are restricted for specific Windows user rights. 
 
Operation Administrator Power user User Guest 
Installing WinAC RTX software Permitted Not permitted Not 

permitted 
Not 
permitted 

Configuring or modifying the  
PC station 

Permitted Permitted Not 
permitted 

Not 
permitted 

Performing WinAC RTX operations  Permitted Permitted Permitted Permitted 

Restrictions for Windows 7 
The following table shows which functions are restricted for specific Windows user rights. 
 
Operation Administrator TIA Engineer User 
Installing WinAC RTX software Permitted Not permitted Not permitted 
Configuring or modifying the PC 
station 

Permitted Permitted Not permitted 

Performing WinAC RTX operations Permitted Permitted Permitted 
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Defining access rights under MS Windows 7 
When you install WinAC RTX under MS Windows 7, a "Siemens TIA Engineer" user group 
will be created automatically. This allows the users that are logged in there to configure the 
PC station and to execute the WinAC RTX operations. These user rights must be assigned 
by the administrator.  
Proceed as follows to include those local users in the "Siemens TIA Engineer" group whose 
login permits access to WinAC RTX:  
1. Open the Control Panel under Windows and select the entry "User accounts". 
2. Select the "User accounts" in the navigation window. 
3. Select the "Manage user accounts" in the navigation window. 
4. In the "Advanced" tab select the Advanced" entry in the "Extended user  

administration" section. 
5. Select the "Local users and groups > Users" in the navigation window. All the users are 

displayed in the data window. 
6. In the "Action" menu select the "New user" command and create a user account with the 

same login for each user who is to access WinAC RTX. 
7. Select the context-specific menu command "Properties" for each created user. 
8. In the displayed dialog box select the "Member of" tab and click the "Add" command 

button. 
9. Enter the "Siemens TIA Engineer" user group in the "Enter the object names to be used" 

field in the "Select groups" dialog box. 
10. Confirm your entries with "OK". 

Creating the domain-global user group "Siemens TIA Engineer" 
In the case of operation in a domain, a domain-global user group can alternatively be set up, 
which is then mapped to the local user groups "Siemens TIA Engineer". 
The following prerequisites must be fulfilled: 
● The domain administrator has created a domain-global user group. 
● Within the domains the domain administrator has included those users into the domain-

global user group under whose login WinAC RTX is accessed. 
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2.7 Using Help 
The online help system provides information about the controller panel and the controller. 
This topic provides information about using online help:  
● Accessing help from the controller panel 
● Using the table of contents 
● Using the Index 
● Using full-text search 
● Printing help topics 

Accessing help from the controller panel 
To access online help from the controller panel, use one of the following methods: 
● Click on an entry in the "Help" menu. 
● Click the "Help" button in a dialog or message box to view information about that specific 

dialog or message box. 
● Press the F1 key to view context-sensitive help on the currently selected item  

(for example, a window, dialog, or menu). 
The menu commands available in the controller panel Help menu are listed below: 
● Help on controller 

The Help > Help on controller menu command displays the first page of the online help 
for the controller, which is connected to the controller panel. It describes the controller 
and controller panel operations. 

● Introduction 
The Help > Introduction menu command displays a help topic that provides an 
introduction to PC-based control and the capabilities of the controller. 

● Getting Started 
The Help > Getting Started menu command displays a help topic that assists you while 
working with the controller for the first time. 
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Using the table of contents 
The table of contents is in the left pane of the browser and provides navigation within the 
online help system: 
● Click a book to open it and display the books and topics that it contains. 
● Click the book again to close it. 
● Click any topic within the table of contents to display that topic. 
The topic you are currently viewing is highlighted in the table of contents. 
The table of contents can be either hidden or displayed: 
● Click the "Hide" button in the browser to close the table of contents. 
● Click the "Show" button in the browser and select the "Contents" tab to open the  

table of contents. 

Using the Index 
The index provides access to information about a specific subject. Select the "Index" tab to 
display the index. (If the "Index" tab is not visible, click the "Show" button in the browser.) 

Using full-text search 
To use the full-text search capabilities of the online help, select the "Search" tab.  
(If the "Search" tab is not visible, click the "Show" button in the browser.) 
The full-text search supports the Boolean operators AND (&), OR (|), and NOT (!), 
expressions within quotation marks, nesting of expressions with parentheses, and the 
wildcards * and ? in search expressions. 

Printing help topics 
To print all or part of the online manual corresponding to the online help, follow these steps: 
1. Use the Start > SIMATIC > Documentation menu command to open the PDF file. 
2. Use the File > Print menu command to print all or part of the manual. 
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